probelms with subs

For help and support with issues specific to Mac OS X
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

probelms with subs

Postby a4005406 » Fri Jan 23, 2009 12:04 am

in case it recognizes subtitles (auto- same filename ) - when i play it, I have the "corrupted file" message:(

any idea?
a4005406
 
Posts: 1
Joined: Fri Jan 23, 2009 12:01 am

Re: probelms with subs

Postby rotem925 » Sat Jan 31, 2009 3:37 pm

I have the exact same problem...
did anyone figure any solution?
rotem925
 
Posts: 5
Joined: Sat Jan 31, 2009 3:35 pm

Re: probelms with subs

Postby maler » Thu Feb 05, 2009 11:28 pm

Same problem. I must remove subtitles manualy :(. That's sad, because i have my folder structure with subtitles... :(. And subtitles are quite important for me...
maler
 
Posts: 1
Joined: Thu Feb 05, 2009 11:26 pm

Re: probelms with subs

Postby molfetamina » Tue Feb 24, 2009 2:22 am

Same problem...what can we do??
I need subtites... :cry:
molfetamina
 
Posts: 1
Joined: Tue Feb 24, 2009 2:21 am

Re: probelms with subs

Postby TiBi » Sun Mar 01, 2009 2:47 pm

Before You play movie with subtitles try play something without subs. It works for me.
TiBi
 
Posts: 1
Joined: Sun Mar 01, 2009 2:44 pm

Re: probelms with subs

Postby liddokun » Wed Mar 04, 2009 7:06 pm

Anybody got subs working in osx? And i mean embedded ones..... if i see somebody happy with subs, it's usually on windows and with an external file. Is this a known issue with the Mac build?
liddokun
 
Posts: 24
Joined: Wed Mar 04, 2009 3:25 pm

Re: probelms with subs

Postby Redlum » Fri Mar 06, 2009 12:47 pm

Yes, lots of people are using subs on OSX. Are you able to send a file (or point in the right direction) that causes this issue?

Also include your debug.log file.
Redlum
Project Member
 
Posts: 371
Joined: Mon Jan 12, 2009 9:13 pm

Re: probelms with subs

Postby liddokun » Fri Mar 06, 2009 3:33 pm

I _think_ i got the right part of the debug.log
Code: Select all
[Thread-608] DEBUG 15:17:17.614 Asked stream chunk [0-0] timeseek: 0.0 of [...] Zoku Sayonara Zetsubou Sensei - 05 [h264 1280x720][503D0631].mkv and player MEncoder
[Thread-608] TRACE 15:17:17.614 Starting transcode/remux of [...] Zoku Sayonara Zetsubou Sensei - 05 [h264 1280x720][503D0631].mkv
[osx/mencoder_mt] INFO  15:17:17.628 Starting /Applications/PS3 Media Server.app/Contents/Resources/Java/osx/mencoder_mt -ss 0 -quiet /Users/username/Downloads/[...] Zoku Sayonara Zetsubou Sensei - 05 [h264 1280x720][503D0631].mkv -quiet -quiet -oac lavc -of mpeg -lavfopts format=asf -mpegopts format=mpeg2:muxrate=500000:vbuf_size=1194:abuf_size=64 -ovc lavc -channels 2 -lavdopts debug=0:threads=2 -lavcopts autoaspect=1:vcodec=mpeg2video:acodec=ac3:abitrate=384:threads=2:keyint=1:vqscale=1:vqmin=2:vrc_maxrate=60000:vrc_buf_size=7000 -ass -nofontconfig -subcp cp1252 -subfont /usr/X11/lib/X11/fonts/TTF/Vera.ttf -quiet -quiet -sid 0 -quiet -quiet -ofps 24000/1001 -quiet -quiet -lavdopts fast -quiet -af lavcresample=48000 -srate 48000 -o - -really-quiet -msglevel all=-1
[osx/mencoder_mt] INFO  15:17:17.839 Attaching thread: osx/mencoder_mt
[Timer-31] DEBUG 15:17:17.839 Buffered Space: 0 bytes
[Thread-609] DEBUG 15:17:18.529 [h264 @ 0x106b800]concealing 1800 DC, 1800 AC, 1800 MV errors
[Thread-609] DEBUG 15:17:18.686 [h264 @ 0x106b800]concealing 1800 DC, 1800 AC, 1800 MV errors
[Thread-609] DEBUG 15:17:18.837 [h264 @ 0x106b800]concealing 1800 DC, 1800 AC, 1800 MV errors
[Timer-31] DEBUG 15:17:18.839 Buffered Space: 4014080 bytes
[Thread-609] DEBUG 15:17:18.899 [h264 @ 0x106b800]concealing 1800 DC, 1800 AC, 1800 MV errors
[Thread-609] DEBUG 15:17:19.419 [h264 @ 0x106b800]concealing 1800 DC, 1800 AC, 1800 MV errors
[Thread-609] DEBUG 15:17:19.529 [h264 @ 0x106a400]concealing 1800 DC, 1800 AC, 1800 MV errors
[Timer-31] DEBUG 15:17:19.839 Buffered Space: 9127936 bytes
[Thread-609] DEBUG 15:17:19.844 [h264 @ 0x106a400]concealing 1800 DC, 1800 AC, 1800 MV errors
[Thread-609] DEBUG 15:17:19.990 [h264 @ 0x106b800]concealing 1800 DC, 1800 AC, 1800 MV errors
[Thread-609] DEBUG 15:17:20.185 [h264 @ 0x106a400]concealing 1800 DC, 1800 AC, 1800 MV errors
[Thread-609] DEBUG 15:17:20.340 [h264 @ 0x106b800]concealing 1800 DC, 1800 AC, 1800 MV errors
[Timer-31] DEBUG 15:17:20.839 Buffered Space: 14278656 bytes
[Timer-31] DEBUG 15:17:21.839 Buffered Space: 18284544 bytes
[Timer-31] DEBUG 15:17:22.839 Buffered Space: 21764096 bytes
[Thread-608] DEBUG 15:17:23.773 Wrote on socket: Content-Type: video/mpeg
[Thread-608] DEBUG 15:17:23.773 Wrote on socket: Connection: keep-alive
[Thread-608] DEBUG 15:17:23.773 Wrote on socket: Server: Mac_OS_X-x86_64-10.5.6, UPnP/1.0, PMS/1.10
[Thread-608] DEBUG 15:17:23.773 Wrote on socket:
[Timer-31] DEBUG 15:17:23.839 Buffered Space: 25907200 bytes
[Timer-31] DEBUG 15:17:24.840 Buffered Space: 26279936 bytes
[Timer-31] DEBUG 15:17:25.839 Buffered Space: 22992896 bytes
[Timer-31] DEBUG 15:17:26.840 Buffered Space: 24305664 bytes
[Timer-31] DEBUG 15:17:27.840 Buffered Space: 25053184 bytes
[Timer-31] DEBUG 15:17:28.839 Buffered Space: 27115520 bytes
[Timer-31] DEBUG 15:17:29.839 Buffered Space: 30208000 bytes
[Timer-31] DEBUG 15:17:30.840 Buffered Space: 31973376 bytes
[Thread-610] DEBUG 15:17:30.855 freeMemory: 17623616
[Thread-610] DEBUG 15:17:30.855 totalMemory: 74588160
[Thread-610] DEBUG 15:17:30.855 maxMemory: 771751936
[Thread-610] DEBUG 15:17:30.855 Extending buffer to 419430400
[Timer-31] DEBUG 15:17:31.841 Buffered Space: 31485952 bytes
[Timer-31] DEBUG 15:17:32.840 Buffered Space: 29421568 bytes
[Timer-31] DEBUG 15:17:33.840 Buffered Space: 27979776 bytes
[Timer-31] DEBUG 15:17:34.841 Buffered Space: 27750400 bytes
[Timer-31] DEBUG 15:17:35.841 Buffered Space: 25718784 bytes
[Timer-31] DEBUG 15:17:36.841 Buffered Space: 25718784 bytes
[Timer-31] DEBUG 15:17:37.842 Buffered Space: 24670208 bytes
[Timer-31] DEBUG 15:17:38.841 Buffered Space: 22704128 bytes
[Timer-31] DEBUG 15:17:39.841 Buffered Space: 21524480 bytes
[Timer-31] DEBUG 15:17:40.841 Buffered Space: 19525632 bytes
[Thread-608] DEBUG 15:17:41.299 Sending stream with premature end : 30539776 bytes of get/0$0$191$4$2/%5B...%5D+Zoku+Sayonara+Zetsubou+Sensei+-+05+%5Bh264+1280x720%5D%5B503D0631%5D.mkv. Reason: Broken pipe
[Thread-608] DEBUG 15:17:41.299 Ready to Stop: true

That is a random file. First one i could find on my hd, but all of my mkvs won't show subs. Different releases from different fansub groups.... you know, pretty generical issue, not with a single file :-\
I selected a valid ttf font, just in case. Didn't work before, keeps not working now.
"username" is all lowercase, no spaces, no accents, no numbers, no symbols, and 16 chars long.

Oh, also as an unrelated note, i had to disable autosync for mkvs, or it would be like a second or so messed up.
liddokun
 
Posts: 24
Joined: Wed Mar 04, 2009 3:25 pm

Re: probelms with subs

Postby liddokun » Tue Mar 10, 2009 11:00 pm

New version isn't any better sadly, here is a full debug.log http://pastebin.com/m446d32e8
It's a single startup/playback/stop/shutdown, there shouldn't be any pointless data.
liddokun
 
Posts: 24
Joined: Wed Mar 04, 2009 3:25 pm

Re: probelms with subs

Postby liddokun » Fri Mar 13, 2009 3:48 pm

Bigger debug.log! Now made by a fresh pms.conf by this version viewtopic.php?f=7&t=914&start=20#p5392
Three different mkv files, just to prove my point http://pastebin.com/m37daca87
liddokun
 
Posts: 24
Joined: Wed Mar 04, 2009 3:25 pm

Next

Return to Mac OS X Support

Who is online

Users browsing this forum: thebmillz and 5 guests