Web content will not stream

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Re: Web content will not stream

Postby chocolateboy » Sat Mar 05, 2011 7:42 pm

Twosheds wrote:in the the penultimate line in pmsencoder.log there is a ',' immediately after the word 'program' as shown below.



chocolateboy wrote:third-party command-line applications should be installed in paths without spaces on Windows


https://github.com/chocolateboy/pmsenco ... s#external
chocolateboy
Project Member
 
Posts: 2580
Joined: Wed Sep 16, 2009 10:05 am

Re: Web content will not stream

Postby Twosheds » Sat Mar 05, 2011 8:28 pm

:oops: I had seen this but I forgot to make the changes. Sorry about that. AND I forgot to send the logs. Glad that you were able to help without the need for them.

Having removed the spaces I tried again. Still not working . Here's what I think is the relevant excerpt from debug.log
Code: Select all
[C:\AppsforPMS\sopcast\sopcast.exe] INFO  19:19:44.432 Starting C:\AppsforPMS\sopcast\sopcast.exe "sop://broker.sopcast.com:3912/82153 "
[win32\ffmpeg.exe] INFO  19:19:44.435 Starting C:\Program Files\PS3 Media Server\win32\ffmpeg.exe -v 0 -y -threads 2 -i "http://127.0.0.1:8902/stream" -threads 2 -target ntsc-dvd \\.\pipe\pmsencoder_transcoder_out_1299352784155_32
[win32\ffmpeg.exe] INFO  19:19:44.439 Reading pipe: \\.\pipe\pmsencoder_transcoder_out_1299352784155_32
[New I/O server worker #1-3] DEBUG 19:19:44.635 Sleeping for 6000 milliseconds
[win32\ffmpeg.exe] INFO  19:19:44.635 Attaching thread: win32\ffmpeg.exe
[Timer-1] DEBUG 19:19:44.635 Buffered Space: 0 bytes / inputs: 0
[Thread-31] DEBUG 19:19:45.577 FFmpeg version SVN-r26112-Sherpya, Copyright (c) 2000-2010 the FFmpeg developers
[Thread-31] DEBUG 19:19:45.577   built on Dec 28 2010 04:54:02 with gcc 4.2.5 20090330 (prerelease) [Sherpya]
[Thread-31] DEBUG 19:19:45.577   libavutil     50.36. 0 / 50.36. 0
[Thread-31] DEBUG 19:19:45.577   libavcore      0.16. 0 /  0.16. 0
[Thread-31] DEBUG 19:19:45.577   libavcodec    52.100. 0 / 52.100. 0
[Thread-31] DEBUG 19:19:45.577   libavformat   52.91. 0 / 52.91. 0
[Thread-31] DEBUG 19:19:45.577   libavdevice   52. 2. 2 / 52. 2. 2
[Thread-31] DEBUG 19:19:45.577   libavfilter    1.72. 0 /  1.72. 0
[Thread-31] DEBUG 19:19:45.577   libswscale     0.12. 0 /  0.12. 0
[Thread-31] DEBUG 19:19:45.577   libpostproc   51. 2. 0 / 51. 2. 0
[Thread-31] DEBUG 19:19:45.577 TCP connection to 127.0.0.1:8902 failed: Unknown error
[Thread-31] DEBUG 19:19:45.578 http://127.0.0.1:8902/stream: Input/output error
[win32\ffmpeg.exe] DEBUG 19:19:46.580 EOF
[win32\ffmpeg.exe] TRACE 19:19:46.580 Process C:\Program Files\PS3 Media Server\win32\ffmpeg.exe has a return code of 1! Maybe an error occured... check the log file
[win32\ffmpeg.exe] INFO  19:19:46.580 Stopping process: C:\AppsforPMS\sopcast\sopcast.exe


There doesn't appear to be any errors in the pmsencoder.log
Twosheds
 
Posts: 37
Joined: Tue Apr 27, 2010 4:28 pm
Location: Lincolnshire, UK

Re: Web content will not stream

Postby chocolateboy » Sat Mar 05, 2011 8:35 pm

Twosheds wrote:Starting C:\AppsforPMS\sopcast\sopcast.exe "sop://broker.sopcast.com:3912/82153 "


What's with the space after the URI? If that doesn't fix it, please attach all the files: https://github.com/chocolateboy/pmsencoder#Help
chocolateboy
Project Member
 
Posts: 2580
Joined: Wed Sep 16, 2009 10:05 am

Re: Web content will not stream

Postby Twosheds » Sat Mar 05, 2011 9:18 pm

No space in the URI this time but it's still not working.

Thanks for all your help.
Attachments
debug.zip
(17.46 KiB) Downloaded 97 times
Twosheds
 
Posts: 37
Joined: Tue Apr 27, 2010 4:28 pm
Location: Lincolnshire, UK

Re: Web content will not stream

Postby chocolateboy » Sat Mar 05, 2011 10:47 pm

Probably a timing issue:

20:03:47.348 Starting C:\AppsforPMS\sopcast\sopcast.exe "sop://broker.sopcast.com:3912/6816"
20:03:47.349 Starting C:\Program Files\PS3 Media Server\win32\ffmpeg.exe


The hook command is run asynchronously. Adding before and after hooks is on my TODO list, but, until then, you'll have to start the SopCast server manually and use the http:// URI.
chocolateboy
Project Member
 
Posts: 2580
Joined: Wed Sep 16, 2009 10:05 am

Re: Web content will not stream

Postby Twosheds » Sun Mar 06, 2011 7:55 am

Once again, thanks for your help.

I'll keep a lookout for the relevant changes in future releases
Last edited by Twosheds on Sun Mar 06, 2011 8:33 am, edited 1 time in total.
Twosheds
 
Posts: 37
Joined: Tue Apr 27, 2010 4:28 pm
Location: Lincolnshire, UK

Re: Web content will not stream

Postby SharkHunter » Sun Mar 06, 2011 8:09 am

In older releases mencoder was used. Mencoder was more forgiving than ffmpeg is with respect to start up time (of sopcast for example).
SharkHunter
 
Posts: 941
Joined: Tue Jun 01, 2010 8:39 pm

Re: Web content will not stream

Postby chocolateboy » Sun Mar 06, 2011 9:41 pm

PMSEncoder 1.5.5 has been released.

This release fixes the Windows/MPlayer issue.
chocolateboy
Project Member
 
Posts: 2580
Joined: Wed Sep 16, 2009 10:05 am

Re: Web content will not stream

Postby grolschie » Mon Mar 07, 2011 8:13 pm

chocolateboy wrote:PMSEncoder 1.5.5 has been released.

This release fixes the Windows/MPlayer issue.


Thank you very much Chocolateboy. Now my web.conf works again. :-)
grolschie
 
Posts: 263
Joined: Thu Jun 10, 2010 7:05 am

Re: Web content will not stream

Postby brotherjohn » Tue Mar 08, 2011 5:24 pm

Hi chocolateboy,
could you please modify the filmtrailer.groovy script from here that it works with the new pmsencoder 1.5.5?
Thank you in advance for your great work.
EDIT: Here is the debug.log:
Code: Select all
[win32\ffmpeg.exe] INFO  17:55:53.342 Starting C:\Program Files\PS3 Media Server\win32\ffmpeg.exe -v 0 -y -threads 2 -i "concat:http://de.clip-1.filmtrailer.com/4752_15942_a_5.mp4?log_var=72|491100000-1|http://www.player.previewnetworks.com/v4.0/PNPlayer.swf?default_quality=xlarge&loading_screen=http://partner-images.previewnetworks.com/film640x360\|http://de.clip-1.filmtrailer.com/4752_20461_a_5.mp4?log_var=72|491100000-1|http://www.player.previewnetworks.com/v4.0/PNPlayer.swf?default_quality=xlarge&loading_screen=http://partner-images.previewnetworks.com/film640x360\|http://de.clip-1.filmtrailer.com/4752_20358_a_5.mp4?log_var=72|491100000-1|http://www.player.previewnetworks.com/v4.0/PNPlayer.swf?default_quality=xlarge&loading_screen=http://partner-images.previewnetworks.com/film640x360\|http://de.clip-1.filmtrailer.com/4752_20284_a_5.mp4?log_var=72|491100000-1|http://www.player.previewnetworks.com/v4.0/PNPlayer.swf?default_quality=xlarge&loading_screen=http://partner-images.previewnetworks.com/film640x360\|http://de.clip-1.filmtrailer.com/4752_20107_a_5.mp4?log_var=72|491100000-1|http://www.player.previewnetworks.com/v4.0/PNPlayer.swf?default_quality=xlarge&loading_screen=http://partner-images.previewnetworks.com/film640x360" -threads 2 -target ntsc-dvd \\.\pipe\pmsencoder_transcoder_out_1299603351260_38
[win32\ffmpeg.exe] INFO  17:55:53.350 Reading pipe: \\.\pipe\pmsencoder_transcoder_out_1299603351260_38
[Thread-30] DEBUG 17:55:53.480 FFmpeg version SVN-r26112-Sherpya, Copyright (c) 2000-2010 the FFmpeg developers
[Thread-30] DEBUG 17:55:53.480   built on Dec 28 2010 04:54:02 with gcc 4.2.5 20090330 (prerelease) [Sherpya]
[Thread-30] DEBUG 17:55:53.480   libavutil     50.36. 0 / 50.36. 0
[Thread-30] DEBUG 17:55:53.480   libavcore      0.16. 0 /  0.16. 0
[Thread-30] DEBUG 17:55:53.480   libavcodec    52.100. 0 / 52.100. 0
[Thread-30] DEBUG 17:55:53.480   libavformat   52.91. 0 / 52.91. 0
[Thread-30] DEBUG 17:55:53.480   libavdevice   52. 2. 2 / 52. 2. 2
[Thread-30] DEBUG 17:55:53.480   libavfilter    1.72. 0 /  1.72. 0
[Thread-30] DEBUG 17:55:53.480   libswscale     0.12. 0 /  0.12. 0
[Thread-30] DEBUG 17:55:53.480   libpostproc   51. 2. 0 / 51. 2. 0
[Thread-30] DEBUG 17:55:53.480 concat:http://de.clip-1.filmtrailer.com/4752_15942_a_5.mp4?log_var=72|491100000-1|http://www.player.previewnetworks.com/v4.0/PNPlayer.swf?default_quality=xlarge&loading_screen=http://partner-images.previewnetworks.com/film640x360\|http://de.clip-1.filmtrailer.com/4752_20461_a_5.mp4?log_var=72|491100000-1|http://www.player.previewnetworks.com/v4.0/PNPlayer.swf?default_quality=xlarge&loading_screen=http://partner-images.previewnetworks.com/film640x360\|http://de.clip-1.filmtrailer.com/4752_20358_a_5.mp4?log_var=72|491100000-1|http://www.player.previewnetworks.com/v4.0/PNPlayer.swf?default_quality=xlarge&loading_screen=http://partner-images.previewnetworks.com/film640x360\|http://de.clip-1.filmtrailer.com/4752_20284_a_5.mp4?log_var=72|491100000-1|http://www.player.previewnetworks.com/v4.0/PNPlayer.swf?default_quality=xlarge&loading_screen=http://partner-images.previewnetworks.com/film640x360\|http://de.clip-1.filmtrailer.com/4752_20107_a_5.mp4?log_var=72|491100000-1|http://www.player.previewnetworks.com/v4.0/PNPlayer.swf?default_quality=xlarge&loading_screen=http://partner-images.previewnetworks.com/film640x360: No such file or directory
[win32\ffmpeg.exe] INFO  17:55:53.500 Attaching thread: win32\ffmpeg.exe
[Timer-2] DEBUG 17:55:53.500 Buffered Space: 0 bytes / inputs: 0
[New I/O server worker #1-1] DEBUG 17:55:53.542 Sleeping for 6000 milliseconds
[win32\ffmpeg.exe] DEBUG 17:55:54.500 EOF
[win32\ffmpeg.exe] TRACE 17:55:54.500 Process C:\Program Files\PS3 Media Server\win32\ffmpeg.exe has a return code of 1! Maybe an error occured... check the log file
brotherjohn
 
Posts: 146
Joined: Wed Sep 15, 2010 9:13 am

PreviousNext

Return to General Help and Support

Who is online

Users browsing this forum: Bing [Bot], Majestic-12 [Bot] and 13 guests