weird PMS chinese filename problem

For help and support with issues specific to Linux/Unix
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

weird PMS chinese filename problem

Postby think4less » Sat Jan 01, 2011 2:12 am

Happy New year!

Yesterday I successfully compiled pms 1.20.412 on my QNAP ts-239 using ssh through Putty. I started the program using ./ through Putty and everything was fine. I can see and stream all files including those with chinese character file name. no problems at all.

The next step was to put the pms into, here is my autostart code
Code: Select all


#Symlink Optware to /opt
rm -rf /opt
ln -sf /share/HDA_DATA/.qpkg/Optware /opt

#Export Optware PATH
echo "export PATH=$PATH:/opt/bin:/opt/sbin:/usr/local/sbin" >> /etc/profile

#Start Optware
/etc/init.d/ start

#Start JAVA
/share/HDA_DATA/.qpkg/JRE/ start

export JAVA_HOME=/usr/local/jre

#Start PS3 MediaServer
cd /opt/pms
./ &

the program started fine however I can only see files with english characters, I no longer be able to see any chinese charactor file showing up. I checked the debug.log however it was exactly the same as i manually run through putty.

does really make any difference than running through putty?
Posts: 1
Joined: Sat Jan 01, 2011 1:54 am

Re: weird PMS chinese filename problem

Postby avengeriic » Fri Feb 18, 2011 10:38 pm

I had the same problem with the stock 1.10.5 release. It wasn't just limited to Chinese -- filenames with Japanese characters or accents in them didn't show up, either. The problem appears to be that the LANG environment variable needs to be set. Setting it to "en_US.UTF-8" fixed the problem for me. To ensure that it's always set, I added the following two lines near the top of after the #!/bin/sh:

Code: Select all
export LANG
Posts: 1
Joined: Fri Feb 18, 2011 10:32 pm

Return to Linux/Unix Support

Who is online

Users browsing this forum: No registered users and 1 guest