Web content will not stream

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

groovy documentation

Postby Twosheds » Wed Feb 16, 2011 10:07 am

I've read through most of this thread and the chocolateboy's github site but I can't find anything that describes the format/content/how-to of a 'groovy' script. Is there any documentation for these scripts and if so, where can I find it ?

Thanks
Twosheds
 
Posts: 37
Joined: Tue Apr 27, 2010 4:28 pm
Location: Lincolnshire, UK

Re: Web content will not stream

Postby chocolateboy » Wed Feb 16, 2011 1:05 pm

Twosheds wrote:Is there any documentation for these scripts and if so, where can I find it ?


viewtopic.php?f=12&t=31&p=45208#p45124
chocolateboy
Project Member
 
Posts: 2580
Joined: Wed Sep 16, 2009 10:05 am

Re: Web content will not stream

Postby Twosheds » Wed Feb 16, 2011 2:01 pm

Thanks for the quick response
Twosheds
 
Posts: 37
Joined: Tue Apr 27, 2010 4:28 pm
Location: Lincolnshire, UK

Re: Web content will not stream

Postby Twosheds » Thu Feb 17, 2011 12:07 pm

I've loaded the latest version of SubJunk SB15 and PMSEncoder 1.4.0 and I'm getting the error(s) from PMSEncoder in debug.log that appears to relate to pmsencoder.groovy in the attached file. My pmsencoder.groovy file :-
Code: Select all
// add &has_verified=1 to the YouTube page URI to bypass age verification
config {
    profile ('YouTube') { // replace the built-in profile
        // extract the resource's video_id from the URI of the standard YouTube page
        pattern {
            match uri: '^http://(?:\\w+\\.)?youtube\\.com/watch\\?v=(?<video_id>[^&]+)'
        }

        action {
            let uri: '${uri}&has_verified=1' // append &has_verified=1

            // extract the resource's sekrit identifier ($t) from the page pointed to by the new URI
            scrape '&t=(?<t>[^&]+)'

            // Now, with $video_id and $t defined, call the custom YouTube handler to resolve the URI.
            // Note: the parentheses are required for a no-arg action
            youtube()
        }
    }
}


I downloaded this a while back( August last year, I think). I've looked on Github but can't find a later version. All I can find is a one line entry
Code: Select all
../src/main/resources/pmsencoder.groovy


Should I be using this ?
Attachments
PMSEnc.zip
Portion of debug.log relevant to PMSEncoder error message
(1.22 KiB) Downloaded 80 times
Twosheds
 
Posts: 37
Joined: Tue Apr 27, 2010 4:28 pm
Location: Lincolnshire, UK

Re: Web content will not stream

Postby chocolateboy » Thu Feb 17, 2011 1:43 pm

Twosheds wrote:I'm getting the error(s) from PMSEncoder in debug.log that appears to relate to pmsencoder.groovy in the attached file.


I can't unzip that file, but you don't need (and shouldn't use) pmsencoder.groovy:

https://github.com/chocolateboy/pmsenco ... oder-1.2.0
chocolateboy
Project Member
 
Posts: 2580
Joined: Wed Sep 16, 2009 10:05 am

Re: Web content will not stream

Postby Twosheds » Thu Feb 17, 2011 4:02 pm

Sorry about the zip file, using winzip 15.0 and it must have used the new format.

I followed the instructions given in your links but I'm now finding that when I click on a broadcast via the channel plugin it doesn't start and there is a Mencoder error on the debug.log. Its on line 1644 of the attached debug.log. The zip file also contains the pmsencoder.log as well. The zip file should be ok this time.
Attachments
debug.zip
(20.35 KiB) Downloaded 71 times
Twosheds
 
Posts: 37
Joined: Tue Apr 27, 2010 4:28 pm
Location: Lincolnshire, UK

Re: Web content will not stream

Postby chocolateboy » Thu Feb 17, 2011 4:42 pm

Assuming you have SopCast installed, you'll need to use this script (for now):

https://github.com/chocolateboy/pmsenco ... ast.groovy

If SopCast.exe isn't in your %PATH%, you'll need to provide the full path e.g.

Code: Select all
$HOOK = "C:\\Apps\\SopCast\\SopCast.exe \"${$URI}\""


If you need to supply the full path, I recommend installing/moving the SopCast executable to somewhere without spaces in the path.

See the link I posted earlier for instructions on how/where to install scripts.
chocolateboy
Project Member
 
Posts: 2580
Joined: Wed Sep 16, 2009 10:05 am

Re: Web content will not stream

Postby Twosheds » Thu Feb 17, 2011 7:00 pm

Thanks for the info. I've ensured that I'm set up the way you described.
A sopcast stream will play OK on my Bravia TV but the sopcast 'console' opens on the pc as well and plays the stream at the same time.
If I try to open a stream using XBMC on the pc, the sopcast application opens up on the pc, plays the stream for a few seconds & then closes down but nothing is displayed on the XBMC.

Is this the expected behaviour ?
Twosheds
 
Posts: 37
Joined: Tue Apr 27, 2010 4:28 pm
Location: Lincolnshire, UK

Re: Web content will not stream

Postby chocolateboy » Thu Feb 17, 2011 7:11 pm

Twosheds wrote:Is this the expected behaviour ?


I don't know. I don't use SopCast (or Windows). Others have reported getting it working (search the thread), so someone else may be able to help.
chocolateboy
Project Member
 
Posts: 2580
Joined: Wed Sep 16, 2009 10:05 am

Re: Web content will not stream

Postby grolschie » Fri Feb 18, 2011 10:45 am

Hi chocolateboy.

I am having trouble playing flv files/stream with pmsencoder.

psmencoder works fine for me with mms streams. However, some flv files have picture but no sound. The info displayed on screen for the mms stream is "Dolby Digital 2.0ch 44.1khz 128kbps". The info displayed for the flv file is "(blank) 128kbps". I am using Channel plugin and it's passing the correct file to pmsencoder.

Looking at the log, I see the parameters being passed to mencoder.exe are identical except for the pipe and of course the url. Downloading the file itself, it plays fine in VLC. Are there any known issues with playing flv? If not, how can I get the sound working please? Thanks in advance.
Attachments
pmsencoder.zip
pmsencoder.log
(1.47 KiB) Downloaded 72 times
grolschie
 
Posts: 263
Joined: Thu Jun 10, 2010 7:05 am

PreviousNext

Return to General Help and Support

Who is online

Users browsing this forum: Yahoo [Bot] and 14 guests