Latest SVN build discussion

Download and discuss official beta builds here

Re: Latest Windows/Linux beta build discussion

Postby otmanix » Thu Jan 27, 2011 9:56 pm

Hello,

once again I compiled PMS available at svn for you. Before downloading please read all notes.

- latest PMS stable version is PMS 1.10.51, available here: http://code.google.com/p/ps3mediaserver/downloads/list?can=1
- latest PMS beta release (unstable, leading edge) is PMS 1.20.412, also available at: http://code.google.com/p/ps3mediaserver/downloads/list?can=1
- latest PMS svn version (unstable, bleeding edge) is PMS 1.21.0 r467, compile it yourself (read howtos at http://ps3mediaserver.org/forum/viewtopic.php?f=6&t=3507) or download it at my blog http://otmanix.de/english/2011/01/27/ps3-media-server-1-21-0-r467/

Wikipedia about:
leading edge
Leading edge is the part of an aerofoil or wing which leads in movement through the air and, as a metaphor, a noun or adjective referring to state-of-the-art developments in a field (also cutting edge in this context).

bleeding edge
Bleeding edge technology refers to technology that is so new that the user is required to risk unreliability, and possibly greater expense, in order to use it. The term bleeding edge is formed as an allusion to "leading edge" and its synonym cutting edge, but implying a greater degree of risk: the "bleeding edge" is in front of the "cutting edge". Recently however, the term has been increasingly used by the general public to mean "ahead of cutting edge" largely without the negative, risk-associated connotation concurrent with the term's use in more specific fields.


If you want to post a problem or maybe just some comments please post the PMS version being used.
If you want to try out latest svn versions please make sure to try out latest PMS beta before.
If you experience a certain problem when using the beta version report that "latest beta 1.20.412 causes problem xyz".
If you see a problem when using latest svn version report that "PMS svn 1.21.0 r476 causes new problem xyz. This didn't happen before on latest beta / PMS 1.20.412.".

PMS file locations on Win7:
C:\Users\xxx\AppData\Roaming\PMS\pms.conf
C:\Users\xxx\AppData\Roaming\PMS\web.conf
C:\Users\xxx\AppData\Local\Temp\ps3mediaserver\debug.log

Have fun, Otmanix
I provide NO application support via PM, so please post your question to the forum.
PS3 Media Server related articles on my blog: http://otmanix.de/?cat=11&lang=en
User avatar
otmanix
 
Posts: 528
Joined: Fri Jan 30, 2009 12:40 am
Location: Bavaria, Germany

Re: Latest Windows/Linux beta build discussion

Postby mazey » Fri Jan 28, 2011 12:36 am

ok if u get errors with the new version just delete c:\users\yourname\appdata\PMS\database folder then it will work fine again. for some reason it dont like the old db prev to version 467 and resetting your media library or trying to play a file throws out errors, i just scanned and works fine now and started playing files fine, no errors

whats this?
[New I/O server worker #1-1] TRACE 10:55:27.991 Media renderer was not recognized. HTTP User agent :FDSSDP

i think ill add that to the wmp.conf also heh.
PMS 1.90.2 SNAPSHOT - HP Proliant Microserver N54L 2.2Ghz - Windows Home Server 2011 (64bit) 8GB - Bravia KDL55HX750
mazey
 
Posts: 770
Joined: Sat Oct 24, 2009 9:07 am

Re: Latest Windows/Linux beta build discussion

Postby SubJunk » Fri Jan 28, 2011 2:12 am

Thanks for the feedback mazey :)
I think FDSSDP is a built in Windows thing. I might block its detection or something since I've seen that too
SubJunk
 
Posts: 1210
Joined: Fri Mar 27, 2009 5:25 am

Re: Latest Windows/Linux beta build discussion

Postby Twosheds » Tue Feb 01, 2011 10:28 pm

Portions of my WEB.CONF appear to be ignored by the latest build ( r467) . Here's a sample that works perfectly with 1.20.412 before installing r467 and then again after re-installing 1.20.412
I'm using Windows Vista and I tried r467 it with both my Bravia 5810 TV and XBMC on the PC

Code: Select all

#p2p
videostream.Web,P2P=Sopcast,http://127.0.0.1:8902/stream
videostream.Web,P2P=TVU,http://127.0.0.1:8901/stream



Any ideas ?
Twosheds
 
Posts: 37
Joined: Tue Apr 27, 2010 4:28 pm
Location: Lincolnshire, UK

Latest SVN build discussion

Postby SubJunk » Tue Feb 08, 2011 10:45 pm

This thread has been created to differentiate between discussing the latest beta release (the discussion for which is here) and the SVN builds that people make for themselves.
So if you built the program yourself from our SVN repository, or got one from someone else (any unofficial source), this thread is for discussing that :)
Please try to post in the appropriate thread and thanks for your enthusiasm for testing, you guys help us a lot :)
SubJunk
 
Posts: 1210
Joined: Fri Mar 27, 2009 5:25 am

Re: Latest Windows/Linux SVN discussion

Postby mazey » Tue Feb 08, 2011 10:53 pm

awesome :) anyone else experiencing this im using r490 :)

[main] TRACE 08:50:18.456 Checking font cache... launching simple instance of MPlayer... You may have to wait 60 seconds!
[main] TRACE 08:50:39.165 Done!

20 or so second delay everytime pms starts, mplayer.exe appears to be doing something during the delay using cpu and mem etc.

btw this thread should be stickied too so it doesnt drop down too low. :)
PMS 1.90.2 SNAPSHOT - HP Proliant Microserver N54L 2.2Ghz - Windows Home Server 2011 (64bit) 8GB - Bravia KDL55HX750
mazey
 
Posts: 770
Joined: Sat Oct 24, 2009 9:07 am

Re: Latest Windows/Linux SVN discussion

Postby shagrath » Tue Feb 08, 2011 11:05 pm

mazey wrote:[main] TRACE 08:50:18.456 Checking font cache... launching simple instance of MPlayer... You may have to wait 60 seconds!
[main] TRACE 08:50:39.165 Done!

20 or so second delay everytime pms starts, mplayer.exe appears to be doing something during the delay using cpu and mem etc.


mplayer is creating the font cache (usually on Windows, a directory named USERPROFILE_FONTCONFIG_CACHE is created in the PMS root folder). But it should be one shot
shagrath
Project Lead
 
Posts: 2667
Joined: Wed Jan 14, 2009 1:39 pm

Re: Latest Windows/Linux SVN discussion

Postby mazey » Tue Feb 08, 2011 11:08 pm

shagrath wrote:
mazey wrote:[main] TRACE 08:50:18.456 Checking font cache... launching simple instance of MPlayer... You may have to wait 60 seconds!
[main] TRACE 08:50:39.165 Done!

20 or so second delay everytime pms starts, mplayer.exe appears to be doing something during the delay using cpu and mem etc.


mplayer is creating the font cache (usually on Windows, a directory named USERPROFILE_FONTCONFIG_CACHE is created in the PMS root folder). But it should be one shot


yes its being created and it does take longer the first time round about 45 seconds but its still doing it for 20 seconds each time it starts i tried deleting the appdata/local/temp/ps3mediaserver folder where the fontconfig cache is kept but i am still having delays, as soon as i put a older mplayer back it works without delay again even 735 is fine. im guessing 848 something funky is going on with my pc. relaunched again to check if the file being generated is being modified and it is not if that helps any.
PMS 1.90.2 SNAPSHOT - HP Proliant Microserver N54L 2.2Ghz - Windows Home Server 2011 (64bit) 8GB - Bravia KDL55HX750
mazey
 
Posts: 770
Joined: Sat Oct 24, 2009 9:07 am

Re: Latest Windows/Linux SVN discussion

Postby shagrath » Tue Feb 08, 2011 11:11 pm

But is the folder USERPROFILE_FONTCONFIG_CACHE modified at each launch (or part of its contents) ?
shagrath
Project Lead
 
Posts: 2667
Joined: Wed Jan 14, 2009 1:39 pm

Re: Latest Windows/Linux SVN discussion

Postby mazey » Tue Feb 08, 2011 11:13 pm

shagrath wrote:But is the folder USERPROFILE_FONTCONFIG_CACHE modified at each launch (or part of its contents) ?


nope nothing is being modified the time still shows an hour ago or so when i first installed r490
PMS 1.90.2 SNAPSHOT - HP Proliant Microserver N54L 2.2Ghz - Windows Home Server 2011 (64bit) 8GB - Bravia KDL55HX750
mazey
 
Posts: 770
Joined: Sat Oct 24, 2009 9:07 am

PreviousNext

Return to Beta Builds

Who is online

Users browsing this forum: No registered users and 1 guest