Sony BRAVIA 2010 series

Discuss alternative media renderers (not PS3) supported by PS3 Media Server (e.g. Xbox 360, TVs &c.)

Re: Sony BRAVIA 2010 series (EX4/EX5/EX7/HX7/NX5)

Postby Illico » Mon Jan 10, 2011 12:29 pm

brotherjohn wrote:I replaced the line
Code: Select all
TranscodeVideo=MPEGTSAC3
with
Code: Select all
TranscodeVideo=MPEGAC3

I did this because with this setting I get dvr-ms files listed. Otherwise the Sony Bravia doesn't list these files on the XMB.
Do you know whether this has any side effects?

Two choices: TranscodeVideo=MPEGAC3 (mpeg2-ps) or TranscodeVideo=MPEGTSAC3 (mpeg2-ts)
MPEG_TS_SD_EU_ISO(Mpeg2-ts) is better than MPEG_PS_PAL(mpeg2-ps) DLNA profile
viewtopic.php?f=15&t=2099&p=12540&hilit=20Mbps#p12540
Sony Bravia KDL-46EX501 | Sony BDP-S373 | Sony SMP-N100 |Serviio / PS3MS | Buffalo 2Share DD
User avatar
Illico
 
Posts: 129
Joined: Wed Jun 30, 2010 2:28 pm
Location: France

Re: Sony BRAVIA 2010 series (EX4/EX5/EX7/HX7/NX5)

Postby mrklaw » Mon Jan 10, 2011 1:27 pm

I have a HX803, tried editing one of the conf files to 'HX8' but how do I know if its picked up correctly? PS3MS will show up on the TV, but .avis won't play. It isn't helped by my mini running at 720p and me not being able to see the bottom of the status screen in PS3MS as it doesn't have scroll bars!

edit: temporarily changed to 1080p. PS3MS shows the TV as being picked up, and its using the correct .conf file (one picked up from here). So that conf file should tell it what formats my TV can play, and anything not in that list should be transcoded into one of those formats? So whats going wrong? Video I'm trying to play shows up as [AVC] when listed

although I have my mini under the TV for plex, if I can get the TV playing all my videos, then my mini can be moved to the spare room
mrklaw
 
Posts: 2
Joined: Wed Sep 08, 2010 11:09 pm

Re: Sony BRAVIA 2010 series (EX4/EX5/EX7/HX7/NX5)

Postby brotherjohn » Mon Jan 10, 2011 3:37 pm

Illico wrote:
brotherjohn wrote:I replaced the line
Code: Select all
TranscodeVideo=MPEGTSAC3
with
Code: Select all
TranscodeVideo=MPEGAC3

I did this because with this setting I get dvr-ms files listed. Otherwise the Sony Bravia doesn't list these files on the XMB.
Do you know whether this has any side effects?

Two choices: TranscodeVideo=MPEGAC3 (mpeg2-ps) or TranscodeVideo=MPEGTSAC3 (mpeg2-ts)
MPEG_TS_SD_EU_ISO(Mpeg2-ts) is better than MPEG_PS_PAL(mpeg2-ps) DLNA profile
viewtopic.php?f=15&t=2099&p=12540&hilit=20Mbps#p12540

So, could you please explain, what is the reason, why I can't see the dvr-ms files on the XMB of the Bravia, if I choose MPEGTSAC3. This should have no influence on it. Or am I wrong?
How is it possible to use the better format 'MPEGTSAC3' (what I wanted to do) and to see the dvr-ms files? Is it because of thumbnail generating? I have no idea why I can't see the files.
brotherjohn
 
Posts: 146
Joined: Wed Sep 15, 2010 9:13 am

Re: Sony BRAVIA 2010 series (EX4/EX5/EX7/HX7/NX5)

Postby Illico » Mon Jan 10, 2011 8:38 pm

brotherjohn wrote:So, could you please explain, what is the reason, why I can't see the dvr-ms files on the XMB of the Bravia, if I choose MPEGTSAC3. This should have no influence on it. Or am I wrong?

I don't know, ask to developpers...
Sony Bravia KDL-46EX501 | Sony BDP-S373 | Sony SMP-N100 |Serviio / PS3MS | Buffalo 2Share DD
User avatar
Illico
 
Posts: 129
Joined: Wed Jun 30, 2010 2:28 pm
Location: France

Re: Sony BRAVIA 2010 series (EX4/EX5/EX7/HX7/NX5)

Postby ALB » Tue Jan 11, 2011 4:23 pm

Hi Everyone,

I'm seeing some issues streaming videos to my Bravia EX503. The videos are in various formats on the PC, mpeg1, mov, divx, xvid etc. When browsing the videos from the TV, the videos appear as MPEG2 files - I assume this is indicating what PMS will transcode the file(s) to.

The videos stream, but I am seeing lots of black and white squares/rectangles on the screen, appearing in random places, and of a random size. This happens with both PMS and WMP12. Videos play fine on the PC. Videos also play fine on my PS3, but in this case, the videos are not being transcoded.

I'm using the PMS Beta. PC is Intel Quad Core, Windows 7 Ult, 3GB RAM. PC is connected to wireless router via LAN cable. Bravia TV and PS3 are connected to router wirelessly. Wireless G spec.

Has anyone else observed the black & white blocks when videos are transcoded?

Thanks

Alan
Panasonic TH42-PZ800B Plasma | Sony KDL-40EX503 | PS3 UK 60GB
ALB
 
Posts: 3
Joined: Tue Jan 11, 2011 4:02 pm

Re: Sony BRAVIA 2010 series (EX4/EX5/EX7/HX7/NX5)

Postby Dutchice » Sun Jan 16, 2011 6:35 pm

brotherjohn wrote:How is it possible to use the better format 'MPEGTSAC3' (what I wanted to do) and to see the dvr-ms files? Is it because of thumbnail generating? I have no idea why I can't see the files.


BrotherJohn,

I don't recommend using any renderer.conf file other than the default ones included already with current PS3 beta r412. In particular the .conf file posted earlier on this thread to be found here.

If your BRAVIA is in fact the EX505, the default BraviaEX.conf should be good to go. You have not indicated if you had problems playing dvr-ms files with the default configuration file to start with.

Delete all files in your "PS3 Media Server\Renderes" folder except for BraviaEX.conf, then please make sure you are using the ORIGINAL conf file. Then open the file with wordpad and get rid of the "LINE FEED" which appears between end of line;
Code: Select all
TranscodeExtensions=dvr-

and the following line starting with;
Code: Select all
ms,dvr,mkv,dv,ty,mov,ogm...

result should look like this;
Code: Select all
TranscodeExtensions=dvr-ms,dvr,mkv,dv,ty,mov,ogm...

Save the conf file, then log out of your current Windows session then log in back again, relaunch PS3 Media Server. Check to see if you now can see and play the dvr-ms files in your BRAVIA xbar.

Cheers!
User avatar
Dutchice
 
Posts: 5
Joined: Tue Nov 09, 2010 7:37 pm

Re: Sony BRAVIA 2010 series (EX4/EX5/EX7/HX7/NX5)

Postby ALB » Mon Jan 17, 2011 7:46 pm

ALB wrote:Has anyone else observed the black & white blocks when videos are transcoded?

Thanks

Alan


Hi Everyone,

For some unknown reason, the black and white blocks are no longer appearing during the transcode of videos - no idea why. However the video and audio is stuttering after 30-60 seconds of play back.

I also keep getting the FATAL ERROR: Out of Memory.

I have been going through the PMS FAQ's and the Dummies thread. I found this post:

http://ps3mediaserver.org/forum/viewtopic.php?f=6&t=3507&start=90#p38969

I have tried most of what is suggested: increasing the PMS Transcode buffer to 600, and increasing the Java Heap to 1024 and even 1536. But still getting stuttering play back. Tried limiting and unlimiting the network bandwidth.

Current Settings are:
Transcode Buffer: 600
Cores: 4
AC3 Audio: 384
Maximum Bandwidth: 20 mbps
Mpeg2 quality: Keyint:5;vqscale=1;vqmin=2
Definitely disable subtitles: ticked
Java Heap: 1024

Any other ideas or links to useful posts?

Thanks

Alan
Panasonic TH42-PZ800B Plasma | Sony KDL-40EX503 | PS3 UK 60GB
ALB
 
Posts: 3
Joined: Tue Jan 11, 2011 4:02 pm

Re: Sony BRAVIA 2010 series (EX4/EX5/EX7/HX7/NX5)

Postby Wolf » Mon Jan 17, 2011 11:54 pm

pedicoq wrote:Hey guys, I discovered a solution for BRAVIA's aspect ratio problem:

put this code in Codecs Specific Parameters:
1 -
Code: Select all
((double) width / height) >= 1.7 && ((double) width / height) <= 1.85 :: -mpegopts vaspect=4/3
((double) width / height) >= 2.3 && ((double) width / height) <= 2.5 :: -mpegopts vaspect=221/100


and this in Custom Options:
2 -
Code: Select all
-vf expand=1:::::16/9


These options are in the tab Transcoding Settings>Video Files Engines>Mencoder.


This works wonders, thanks!
Wolf
 
Posts: 35
Joined: Fri Mar 05, 2010 10:06 pm

Re: Sony BRAVIA 2010 series (EX4/EX5/EX7/HX7/NX5)

Postby brotherjohn » Wed Jan 19, 2011 10:24 pm

Dutchice wrote:
brotherjohn wrote:How is it possible to use the better format 'MPEGTSAC3' (what I wanted to do) and to see the dvr-ms files? Is it because of thumbnail generating? I have no idea why I can't see the files.


BrotherJohn,

I don't recommend using any renderer.conf file other than the default ones included already with current PS3 beta r412. In particular the .conf file posted earlier on this thread to be found here.

If your BRAVIA is in fact the EX505, the default BraviaEX.conf should be good to go. You have not indicated if you had problems playing dvr-ms files with the default configuration file to start with.

Delete all files in your "PS3 Media Server\Renderes" folder except for BraviaEX.conf, then please make sure you are using the ORIGINAL conf file. Then open the file with wordpad and get rid of the "LINE FEED" which appears between end of line;
Code: Select all
TranscodeExtensions=dvr-

and the following line starting with;
Code: Select all
ms,dvr,mkv,dv,ty,mov,ogm...

result should look like this;
Code: Select all
TranscodeExtensions=dvr-ms,dvr,mkv,dv,ty,mov,ogm...

Save the conf file, then log out of your current Windows session then log in back again, relaunch PS3 Media Server. Check to see if you now can see and play the dvr-ms files in your BRAVIA xbar.

Cheers!

The problem is with the default BraviaEX.conf file that it doesn't work for some files, for example mp4. You can find my post here One solution is to use another more restrictive .conf file. I use the following and it does a good job for video trancoding and it plays mp4 files :) :
Code: Select all
# ps3mediaserver renderer profile for Sony Bravia EX500/EX700 series
# Refer to PS3.conf for help

RendererName=Sony Bravia EX Series (NEW)
RendererIcon=bravia.png
UserAgentSearch=notusedhere
UserAgentAdditionalHeader=X-AV-Client-Info
UserAgentAdditionalHeaderSearch=(BRAVIA KDL.+EX5)|(BRAVIA KDL.+EX7)|(BRAVIA KDL.+NX7)
Video=true
Audio=true
Image=true
SeekByTime=true
TranscodeVideo=MPEGAC3
TranscodeAudio=MP3
DefaultVBVBufSize=true
MuxH264ToMpegTS=true
MuxDTSToMpeg=false
WrapDTSIntoPCM=false
MuxLPCMToMpeg=false
MaxVideoBitrateMbps=0
MaxVideoWidth=0
MaxVideoHeight=0
H264Level41Limited=true
MimeTypesChanges=audio/wav=audio/L16|video/mp4=video/mpeg
DLNALocalizationRequired=true
#TranscodeExtensions=dvr-ms,dvr
#StreamExtensions=

#Required to be true for Bravia TVs and Sony Bluray players
ForceJPGThumbnails=true
MediaParserV2_ThumbnailGeneration=false

MediaInfo=true
# [Supported video formats]:
Supported = f:mpegps    v:mpeg2    a:ac3|lpcm|mpa    m:video/mpeg
#Supported = f:mpegts    v:mpeg2/h264    a:ac3|mpa    m:video/mpeg
#Supported = f:mpegts    v:mpeg2/h264    a:ac3|aac|mpa    m:video/vnd.dlna.mpeg-tts

# [Supported audio formats]:
Supported = f:mp3        n:2            m:audio/mpeg
Supported = f:wav        n:2            m:audio/L16

# [Supported image formats]
Supported = f:jpg m:image/jpeg
brotherjohn
 
Posts: 146
Joined: Wed Sep 15, 2010 9:13 am

Re: Sony BRAVIA 2010 series (EX4/EX5/EX7/HX7/NX5)

Postby Illico » Thu Jan 20, 2011 9:35 am

brotherjohn wrote:MediaInfo=true
# [Supported video formats]:
Supported = f:mpegps v:mpeg2 a:ac3|lpcm|mpa m:video/mpeg
#Supported = f:mpegts v:mpeg2/h264 a:ac3|mpa m:video/mpeg
#Supported = f:mpegts v:mpeg2/h264 a:ac3|aac|mpa m:video/vnd.dlna.mpeg-tts

Be carefull, there were a syntax mistake
"v:mpeg2/h264" must be replace by "v:mpeg2|h264"

Check with that
Code: Select all
# ps3mediaserver renderer profile for Sony Bravia 2010 series
# Refer to PS3.conf for help

RendererName=Sony Bravia 2010 Series
RendererIcon=bravia.png
UserAgentSearch=notusedhere
UserAgentAdditionalHeader=X-AV-Client-Info
UserAgentAdditionalHeaderSearch=(BRAVIA KDL.+EX4)|(BRAVIA KDL.+EX5)|(BRAVIA KDL.+EX7)|(BRAVIA KDL.+HX7)|(BRAVIA KDL.+NX5)|(BRAVIA KDL.+NX7)
Video=true
Audio=true
Image=true
SeekByTime=true
TranscodeVideo=MPEGTSAC3
TranscodeAudio=MP3
DefaultVBVBufSize=true
MuxH264ToMpegTS=true
MuxDTSToMpeg=false
WrapDTSIntoPCM=false
MuxLPCMToMpeg=false
MaxVideoBitrateMbps=0
MaxVideoWidth=0
MaxVideoHeight=0
H264Level41Limited=true
MimeTypesChanges=audio/wav=audio/L16|video/mp4=video/mpeg
DLNALocalizationRequired=true
#TranscodeExtensions=
#StreamExtensions=

#Required to be true for Bravia TVs and Sony Bluray players
ForceJPGThumbnails=true
MediaParserV2_ThumbnailGeneration=false

MediaInfo=true
# [Supported video formats]:
Supported = f:mpegps    v:mpeg2    a:ac3|lpcm|mpa    m:video/mpeg
Supported = f:mpegts    v:mpeg2|h264    a:ac3|mpa    m:video/mpeg
Supported = f:mpegts    v:mpeg2|h264    a:ac3|aac|mpa    m:video/vnd.dlna.mpeg-tts

# [Supported audio formats]:
Supported = f:mp3        n:2            m:audio/mpeg
Supported = f:wav        n:2            m:audio/L16

# [Supported image formats]
Supported = f:jpg m:image/jpeg
Sony Bravia KDL-46EX501 | Sony BDP-S373 | Sony SMP-N100 |Serviio / PS3MS | Buffalo 2Share DD
User avatar
Illico
 
Posts: 129
Joined: Wed Jun 30, 2010 2:28 pm
Location: France

PreviousNext

Return to Alternative Media Renderers

Who is online

Users browsing this forum: Bing [Bot] and 4 guests