Problem playing MKV with VC-1 video

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Problem playing MKV with VC-1 video

Postby Fxp » Sun Mar 01, 2009 8:02 pm

I'm trying, unsuccessfully, to play the following 1080p video on my PS3 using PS3 media center:

Container...........: Matroska
Video Encoder.......: VC-1 (Untouched Video)
Video Aspect Ratio..: 1.78:1 (1920x1080)
Audio Codec.........: DTS
Audio Bitrate.......: 1536 kbit/sec
Audio Channels......: 5.1 channnels
Subtitles...........: Dutch + English
Source..............: Blu-Ray
File Size...........: 13,6 GB
DXVA compliant......: Yes

All I get after trying all the video engines is "corrupt data" error message. Is VC-1 codec the problem?
Fxp
 
Posts: 3
Joined: Sun Mar 01, 2009 7:58 pm

Re: Problem playing MKV with VC-1 video

Postby shagrath » Sun Mar 01, 2009 10:05 pm

you forgot the 5-

viewtopic.php?f=6&t=496
shagrath
Project Lead
 
Posts: 2667
Joined: Wed Jan 14, 2009 1:39 pm

Re: Problem playing MKV with VC-1 video

Postby Fxp » Mon Mar 02, 2009 9:07 am

Sorry,

1) Core2 Duo 4500 2.2 Ghz processor & 2 GB RAM
2) Wired connection
3) Corrupted data error while playing 1080p video encoded with VC-1
4) Used all engines
5) Debug file
Fxp
 
Posts: 3
Joined: Sun Mar 01, 2009 7:58 pm

Re: Problem playing MKV with VC-1 video

Postby shagrath » Mon Mar 02, 2009 9:17 am

ok
with mencoder, you can try to get the "wvc1dmod.dll" file here: http://www.mplayerhq.hu/MPlayer/release ... 071007.zip
and copy it into ps3mediaserver/win32/codecs/

with tsMuxer, that's normal, VC is not (or badly) supported natively by ps3

with Avisynth, the file does not seem to work, and I can't see why (that's the trouble with AviSynth)
you should try to launch (on your computer) the temporary .avs script file created into your <windows temp folder>/javaps3media folder
shagrath
Project Lead
 
Posts: 2667
Joined: Wed Jan 14, 2009 1:39 pm

Re: Problem playing MKV with VC-1 video

Postby quepaso » Mon Mar 02, 2009 2:29 pm

I would honestly suggest sticking to L4.1 re-encodes for anything VC-1, that way you get to use tsmuxer which is 1000x preferred then transcoding at all, since you're re-encoding the vc-1 anyway during a transcode. You lose quality either way, so best to use the easier method.
quepaso
 
Posts: 37
Joined: Tue Jan 20, 2009 10:49 pm

Re: Problem playing MKV with VC-1 video

Postby Fxp » Mon Mar 02, 2009 6:26 pm

shagrath wrote:ok
with mencoder, you can try to get the "wvc1dmod.dll" file here: http://www.mplayerhq.hu/MPlayer/release ... 071007.zip
and copy it into ps3mediaserver/win32/codecs/

with tsMuxer, that's normal, VC is not (or badly) supported natively by ps3

with Avisynth, the file does not seem to work, and I can't see why (that's the trouble with AviSynth)
you should try to launch (on your computer) the temporary .avs script file created into your <windows temp folder>/javaps3media folder


Thanks, after putting dll file in codecs folder, movie started playing.
Fxp
 
Posts: 3
Joined: Sun Mar 01, 2009 7:58 pm

Re: Problem playing MKV with VC-1 video

Postby ExSport » Mon Mar 16, 2009 8:57 pm

Shagrath, why "wvc1dmod.dll" is not included in newest PMS versions? And this file is sufficient or better to copy all files from "windows-essential-20071007" for better file compatibility and support?
Thanks
ExSport
 
Posts: 2168
Joined: Mon Jan 19, 2009 5:40 pm


Return to General Help and Support

Who is online

Users browsing this forum: Google [Bot] and 13 guests