X360: 5.1 DTS/AC3 movies now supported! (magma)

Discuss third-party additions, plugins and translations for PS3 Media Server

Re: X360: 5.1 DTS/AC3 movies now supported! (magma)

Postby devildog93 » Thu Oct 14, 2010 9:11 pm

gando2182 wrote:any chance you can update to the latest beta? 1.20.412 with the magma code


If you are concerned about the ability to use "go to" on a PS3, you can simply add this update.jar to the main install directory. I know it works because I used it myself with the MAGMA release.

http://ps3mediaserver.org/files/patchs/ ... update.jar
User avatar
devildog93
 
Posts: 1301
Joined: Fri Mar 19, 2010 8:37 pm

Re: X360: 5.1 DTS/AC3 movies now supported! (magma)

Postby whitefrt » Wed Oct 20, 2010 5:03 pm

To all who asked:

Updating magma to work with the recent 412 release isn't really a big problem, however almost all changes between 404-412 are mostly ps3/non-windows changes and are not significant to X360/windows users so you really won't benefit.

(Revision 407 does seems to include a more recent mencoder version which you can do yourself by downloading it from the web and replacing the mencoder executable)

When a major ps3mediaserver revision will be released (or if there are a lot of requests) I'll make sure to sync the code and release a new magma based version.

I've updated magma significantly since the first release - it's now fully optimized for multicore systems and supports video hardware encoding to WMV3/VC1 but you really need a capable media center to make use of these features (it doesn't rely on mencoder anymore).
On slower systems without a capable GPU, software encoding to WMV2 is actually faster than hardware encoding to WMV3 (WMV3/VC1 codecs are insanely complex and slow to encode but are of higher quality).. so meanwhile I see no point in releasing that version as most people without fast GPUs won't benefit.
whitefrt
 
Posts: 18
Joined: Wed Jul 29, 2009 7:22 am

Re: X360: 5.1 DTS/AC3 movies now supported! (magma)

Postby Maslakoff » Wed Oct 20, 2010 10:01 pm

Hello!
5.1 is awesome with this MAGMA release. But i have some problems too.
For example, when i try to watch some DVD ISO, i see this:

Code: Select all
[New I/O server worker #1-1] TRACE 00:44:55.264 Renderer Xbox360 found on this address: /192.168.1.7
[New I/O server worker #1-2] TRACE 00:46:38.382 Starting transcode/remux of Title 2
[win32/magma.exe] TRACE 00:46:41.257 Process C:\Program Files (x86)\PS3 Media Server\win32\magma.exe has a return code of 1! Maybe an error occured... check the log file


Some play, some don't. So, how long should we wait for a new, improved version of magma.exe?.. It's cool, yes. But a little bit unstable.
Maslakoff
 
Posts: 3
Joined: Wed Oct 20, 2010 9:53 pm

Re: X360: 5.1 DTS/AC3 movies now supported! (magma)

Postby whitefrt » Thu Oct 21, 2010 9:01 am

Please verify that this is indeed a magma problem, does the movie play when you turn magma off? (to turn it off: set transcoding settings->number of audio channels to 2 channels stereo)

If the movie still doesn't play then this is a mencoder problem, otherwise please attach the debug.log, magma.log and the movie's mediainfo settings and I'll take a look.

I've never had any magma-related problems, when I did have a problem playing a movie it was always caused by mencoder not being able to play it correctly.
whitefrt
 
Posts: 18
Joined: Wed Jul 29, 2009 7:22 am

Re: X360: 5.1 DTS/AC3 movies now supported! (magma)

Postby Maslakoff » Thu Oct 21, 2010 12:16 pm

debug.log
Code: Select all
[New I/O server worker #2-1] TRACE 14:57:28.498 Starting transcode/remux of Title 2
[New I/O server worker #2-1] DEBUG 14:57:28.509 channels=6
[Thread-25] INFO  14:57:28.595 Stopping process: win32/mplayer.exe
[New I/O server worker #2-1] INFO  14:57:28.681 Creating pipe \\.\pipe\combinedOUT1287658648666
[Thread-15] DEBUG 14:57:28.698 Receiving a NOTIFY from [192.168.1.2:54500]
[Timer-0] DEBUG 14:57:28.949 Buffered Space: 0 bytes / inputs: 0
[Thread-46] INFO  14:57:28.949 Waiting for pipe connection \\.\pipe\combinedOUT1287658648666
[New I/O server worker #2-1] INFO  14:57:28.961 Creating pipe \\.\pipe\mencoderWRITE1287658648666
[New I/O server worker #2-1] INFO  14:57:28.962 Creating pipe \\.\pipe\mencoderREAD1287658648666
[Thread-49] INFO  14:57:28.964 Waiting for pipe connection \\.\pipe\mencoderWRITE1287658648666
[Thread-50] INFO  14:57:28.965 Waiting for pipe connection \\.\pipe\mencoderREAD1287658648666
[win32/magma.exe] INFO  14:57:28.966 Starting C:\Program Files (x86)\PS3 Media Server\win32\magma.exe -v 0 -log -i \\.\pipe\mencoderREAD1287658648666 -f asf -fopts -all -ovc copy -oac wmapro -copts -b 384 -bps 16 -o \\.\pipe\combinedOUT1287658648666
[win32/mencoder.exe] INFO  14:57:28.967 Starting C:\Program Files (x86)\PS3 Media Server\win32\mencoder.exe -ss 0 -dvd-device F:\Movies\POLLY_MAGGOO_DVD9_[rutracker.org]\VIDEO_TS dvd://2 -quiet -oac pcm -of lavf -lavfopts format=asf -mpegopts format=mpeg2:muxrate=500000:vbuf_size=1194:abuf_size=64:vaspect=16/9 -ovc lavc -channels 6 -lavdopts debug=0:threads=1 -lavcopts autoaspect=1:vcodec=wmv2:acodec=wmav2:abitrate=256:threads=1:keyint=1:vqscale=1:vqmin=2:vrc_maxrate=30000:vrc_buf_size=1835 -subcp cp1252 -subfont C:\Windows\Fonts\Arial.ttf -quiet -quiet -quiet -quiet -quiet -quiet -quiet -quiet -quiet -quiet -sid 2 -fps 30000/1001 -quiet -quiet -quiet -quiet -vf yadif -ofps 23.976 -quiet -mc 0 -noskip -af lavcresample=48000 -srate 48000 -o \\.\pipe\mencoderWRITE1287658648666
[win32/mencoder.exe] INFO  14:57:28.987 Reading pipe: \\.\pipe\combinedOUT1287658648666
[win32/mencoder.exe] INFO  14:57:28.988 Attaching thread: win32/mencoder.exe
[Thread-15] DEBUG 14:57:29.033 Receiving a NOTIFY from [192.168.1.2:54500]
[Thread-50] INFO  14:57:29.790 Result of \\.\pipe\mencoderREAD1287658648666 : true
[Thread-15] DEBUG 14:57:29.827 Receiving a NOTIFY from [192.168.1.2:54500]
[Thread-28] INFO  14:57:30.218 Stopping process: win32/mplayer.exe
[Thread-29] INFO  14:57:30.218 Stopping process: win32/mplayer.exe
[Thread-15] DEBUG 14:57:30.359 Receiving a NOTIFY from [192.168.1.2:54500]
[Thread-52] DEBUG 14:57:30.593 MEncoder Sherpya-SVN-r30369-4.2.5 (C) 2000-2009 MPlayer Team
[Thread-52] DEBUG 14:57:30.609 There are 4 titles on this DVD.
[Thread-52] DEBUG 14:57:30.609 There are 1 angles in this DVD title.
[Thread-52] DEBUG 14:57:30.671 audio stream: 0 format: ac3 (mono) language: fr aid: 128.
[Thread-52] DEBUG 14:57:30.671 number of audio channels on disk: 1.
[Thread-52] DEBUG 14:57:30.671 subtitle ( sid ): 1 language: en
[Thread-52] DEBUG 14:57:30.671 subtitle ( sid ): 2 language: ru
[Thread-52] DEBUG 14:57:30.671 number of subtitles on disk: 2
[Thread-52] DEBUG 14:57:30.671 success: format: 2  data: 0x0 - 0x8401a000
[Thread-52] DEBUG 14:57:30.671 MPEG-PS file format detected.
[Thread-52] DEBUG 14:57:30.671 VIDEO:  MPEG2  720x480  (aspect 3)  29.970 fps  9608.0 kbps (1201.0 kbyte/s)
[Thread-52] DEBUG 14:57:30.671 [V] filefmt:2  fourcc:0x10000002  size:720x480  fps:29.970  ftime:=0.0334
[Thread-52] DEBUG 14:57:30.671 Input fps will be interpreted as 29.970 instead.
[Thread-52] DEBUG 14:57:30.671 ==========================================================================
[Thread-52] DEBUG 14:57:30.671 Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
[Thread-52] DEBUG 14:57:30.671 AUDIO: 48000 Hz, 1 ch, s16le, 192.0 kbit/25.00% (ratio: 24000->96000)
[Thread-52] DEBUG 14:57:30.671 Selected audio codec: [ffac3] afm: ffmpeg (FFmpeg AC-3)
[Thread-52] DEBUG 14:57:30.671 ==========================================================================
[Thread-49] INFO  14:57:30.671 Result of \\.\pipe\mencoderWRITE1287658648666 : true
[Thread-52] DEBUG 14:57:30.671 OK, exit.
[Thread-52] DEBUG 14:57:30.687 Opening video filter: [expand osd=1]
[Thread-52] DEBUG 14:57:30.687 Expand: -1 x -1, -1 ; -1, osd: 1, aspect: 0.000000, round: 1
[Thread-52] DEBUG 14:57:30.687 Opening video filter: [yadif]
[Thread-52] DEBUG 14:57:30.687 ==========================================================================
[Thread-51] DEBUG 14:57:30.687 libdvdread: Using libdvdcss version 1.2.10 for DVD access
[Thread-51] DEBUG 14:57:30.687 libdvdread: Could not open F:\Movies\POLLY_MAGGOO_DVD9_[rutracker.org]\VIDEO_TS with libdvdcss.
[Thread-51] DEBUG 14:57:30.687 libdvdread: Can't open F:\Movies\POLLY_MAGGOO_DVD9_[rutracker.org]\VIDEO_TS for reading
[Thread-51] DEBUG 14:57:30.687 libdvdread: Device (null) inaccessible, CSS authentication not available.
[Thread-51] DEBUG 14:57:30.687 ** MUXER_LAVF *****************************************************************
[Thread-51] DEBUG 14:57:30.687 REMEMBER: MEncoder's libavformat muxing is presently broken and can generate
[Thread-51] DEBUG 14:57:30.687 INCORRECT files in the presence of B-frames. Moreover, due to bugs MPlayer
[Thread-51] DEBUG 14:57:30.687 will play these INCORRECT files as if nothing were wrong!
[Thread-51] DEBUG 14:57:30.687 *******************************************************************************
[Thread-52] DEBUG 14:57:30.687 Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
[Thread-52] DEBUG 14:57:30.687 Could not find matching colorspace - retrying with -vf scale...
[Thread-52] DEBUG 14:57:30.687 Opening video filter: [scale]
[Thread-52] DEBUG 14:57:30.687 VDecoder init failed :(
[Thread-51] DEBUG 14:57:30.687 The selected video_out device is incompatible with this codec.
[Thread-51] DEBUG 14:57:30.687 Try appending the scale filter to your filter list,
[Thread-51] DEBUG 14:57:30.687 e.g. -vf spp,scale instead of -vf spp.
[Thread-52] DEBUG 14:57:30.687 Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
[Thread-52] DEBUG 14:57:30.687 Selected video codec: [ffmpeg2] vfm: ffmpeg (FFmpeg MPEG-2)
[Thread-52] DEBUG 14:57:30.687 ==========================================================================
[Thread-52] DEBUG 14:57:30.687 Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
[Thread-52] DEBUG 14:57:30.687 videocodec: libavcodec (720x480 fourcc=32564d57 [WMV2])
[Thread-52] DEBUG 14:57:30.687 [VE_LAVC] Using constant qscale = 1.000000 (VBR).
[Thread-52] DEBUG 14:57:30.734 VIDEO CODEC ID: 19
[Thread-52] DEBUG 14:57:30.734 AUDIO CODEC ID: 10000, TAG: 0
[Thread-52] DEBUG 14:57:30.734 Writing header...
[Thread-15] DEBUG 14:57:30.859 Receiving a NOTIFY from [192.168.1.2:54500]
[Timer-0] DEBUG 14:57:30.956 Buffered Space: 0 bytes / inputs: 0
[Thread-54] DEBUG 14:57:31.549 -------------------------------------------
[Thread-54] DEBUG 14:57:31.565 Magma [Version 0.59, 08/03/2010]
[Thread-54] DEBUG 14:57:31.565 Copyright (c) 2010 Daniel Ridner (whitefrt)
[Thread-54] DEBUG 14:57:31.565 -------------------------------------------
[Thread-54] DEBUG 14:57:31.565 -- ERROR: .\wma_encoder.cpp:263:
[Thread-54] DEBUG 14:57:31.565    Assert: ?????e
[Thread-50] INFO  14:57:31.924 Disconnected pipe: \\.\pipe\mencoderREAD1287658648666
[Thread-34] INFO  14:57:32.190 Stopping process: win32/mplayer.exe
[Thread-38] INFO  14:57:32.190 Stopping process: win32/mplayer.exe
[Thread-35] INFO  14:57:32.206 Stopping process: win32/mplayer.exe
[win32/magma.exe] TRACE 14:57:32.565 Process C:\Program Files (x86)\PS3 Media Server\win32\magma.exe has a return code of 1! Maybe an error occured... check the log file
[Thread-43] INFO  14:57:32.846 Stopping process: win32/mplayer.exe
[Thread-48] INFO  14:57:32.924 Error :Pipe closed
[Timer-0] DEBUG 14:57:32.971 Buffered Space: 0 bytes / inputs: 0
[Thread-49] INFO  14:57:33.924 Error: Pipe closed
[Thread-51] DEBUG 14:57:33.940 [mpeg2video @ 031723e0]ac-tex damaged at 15 7
[Thread-51] DEBUG 14:57:33.940 [mpeg2video @ 031723e0]Warning MVs not available
[Thread-51] DEBUG 14:57:33.940 [mpeg2video @ 031723e0]concealing 1035 DC, 1035 AC, 1035 MV errors
[Thread-51] DEBUG 14:57:33.940 [asf @ 0316a9c0]Codec for stream 0 does not use global headers but container format requires global headers
[Thread-51] DEBUG 14:57:33.940 [asf @ 0316a9c0]Codec for stream 1 does not use global headers but container format requires global headers
[Thread-51] DEBUG 14:57:33.940 Error while writing frame.
[Thread-51] DEBUG 14:57:33.956 Error while writing frame.
[Thread-51] DEBUG 14:57:33.956 Error while writing frame.
[Thread-51] DEBUG 14:57:33.971 Error while writing frame.
[Thread-51] DEBUG 14:57:33.987 Error while writing frame.
[Thread-51] DEBUG 14:57:34.002 Error while writing frame.
[Thread-51] DEBUG 14:57:34.002 Error while writing frame.
[Thread-51] DEBUG 14:57:34.018 Error while writing frame.
[Thread-51] DEBUG 14:57:34.034 Error while writing frame.

and so on...

magma.log
Code: Select all
-------------------------------------------
Magma [Version 0.59, 08/03/2010]
Copyright (c) 2010 Daniel Ridner (whitefrt)
-------------------------------------------

-- ERROR: .\wma_encoder.cpp:263:
   Assert: ?????e


Maybe something wrong with wma_encoder. But i have all necessary codecs.

upd: this film has only one AC3 audiotrack, and it's in MONO. As i noted, all films in MONO are unplayable.
If i turn off MAGMA plugin - it works fine.
Maslakoff
 
Posts: 3
Joined: Wed Oct 20, 2010 9:53 pm

Re: X360: 5.1 DTS/AC3 movies now supported! (magma)

Postby Maslakoff » Sat Nov 06, 2010 10:37 am

So, will there be a new version of MAGMA release?..
Maslakoff
 
Posts: 3
Joined: Wed Oct 20, 2010 9:53 pm

Re: X360: 5.1 DTS/AC3 movies now supported! (magma)

Postby digitalinsite » Fri Apr 22, 2011 3:21 pm

hi,

thanks heaps for the X360 magma release. Plays AC3 and AAC multi channel on my 360 perfectly!

One thing I did notice though - MKV files with subtitles aren't showing the subs anymore. Works fine on the normal release of PMS but no subs in MKV in Magma.

Thanks
digitalinsite
 
Posts: 1
Joined: Fri Apr 22, 2011 3:16 pm

Re: X360: 5.1 DTS/AC3 movies now supported! (magma)

Postby archie01 » Tue Jun 14, 2011 10:57 pm

so if i have settings in pms set to a bitrate of 5.1 ac3 448 is it going to be 448 or 440? it is completely lossless or not? also when is the new version coming out because this the magma version will not let you install pms as a service for some reason. thanks great work so far and keep it coming
archie01
 
Posts: 5
Joined: Tue Jun 14, 2011 6:09 am

Re: X360: 5.1 DTS/AC3 movies now supported! (magma)

Postby tin » Sun Aug 07, 2011 4:34 am

Soo... is there anyone willing & able to get this working on OS X? :D
tin
 
Posts: 26
Joined: Tue Aug 02, 2011 4:59 am

Re: X360: 5.1 DTS/AC3 movies now supported! (magma)

Postby Val Killmore » Tue Aug 09, 2011 11:40 pm

archie01 wrote:so if i have settings in pms set to a bitrate of 5.1 ac3 448 is it going to be 448 or 440? it is completely lossless or not? also when is the new version coming out because this the magma version will not let you install pms as a service for some reason. thanks great work so far and keep it coming


Works for me as a service. Possibly something in your settings within Windows ?

As far as lossless. AC3, otherwise known as Dolby Digital, is a lossy codec. DTS is in fact a lossy format as well.

This is the best version of PMS I have used as of yet. I simply updated the MPlayer/Mencoder engines, and this version plays damn near everything. Doesn't have the fancy bells and whistles of some of the other builds, and has a few minor drawbacks, but this version plays movie after movie, with or without subs, MKV's with or without header compression (with the mplayer/mencoder version in my sig), rarely has sync issues.

In the last two days, since re-installing this version, I have yet to have a 'data corrupt', or a file that won't play. If it doesn't play at first, an option in the #transcode# folder works.

And it works great for both my PS3 and my 360, providing 5.1 to it. I wish this version could be tweaked with a few bells and whistles (iTunes to work, some of the presets), but maintain it's playback capabilities, and it would be the sh*t, plain and simple. :D
Val Killmore: Potato Chip Assassin
SubJunk53--Java 7u4--Acer Aspire 6930 2CoreDuo @ 2.00 GHz 3.00 GB RAM serving to : PS3 Slim -- 2 Xbox360
User avatar
Val Killmore
 
Posts: 712
Joined: Sun May 01, 2011 8:48 am

PreviousNext

Return to Additions and Plugins

Who is online

Users browsing this forum: Yahoo [Bot] and 3 guests