[Solved] Very Slow Streaming/Transcoding

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

[Solved] Very Slow Streaming/Transcoding

Postby FireFox1337 » Sun Feb 22, 2009 8:16 pm

First off system Specs:
____________________
Cpu: Amd Opteron 2Ghz (dual core)
Memory: 1 Gig ram
2x nvidia 7800 gtx in Sli
100Mbit Wired connection to PS3

Defualt settings other then using tsmuxer instead of mencoder

Problem:
im trying to stream some 720p HD content to my ps3 i tried using TsMuxer and Mencoder but
ITS VERY SLOW i mean i wait 30 seconds and get 1.5 seconds of video then wait another 30 seconds and get 1.5 seconds of video.
and the quality isnt very good on the tv considering 720p source

anyhelp?

un trace this is what it says:
[Thread-200] TRACE 14:07:27.515 Starting transcode/remux of saosin-live_at_the_theater_of_living_arts_(11-03-07)-dvdrip-x264-2007-vfi.mkv
[Thread-14] TRACE 14:09:27.312 Sending ALIVE...
[Thread-14] TRACE 14:12:31.578 Sending ALIVE...
[Thread-14] TRACE 14:15:35.171 Sending ALIVE...


Thanks for any help in advnace!
Last edited by FireFox1337 on Wed Feb 25, 2009 4:26 am, edited 2 times in total.
FireFox1337
 
Posts: 12
Joined: Sun Feb 22, 2009 8:05 pm

Re: Movies Not Working

Postby FireFox1337 » Sun Feb 22, 2009 8:38 pm

and is there any way to get ps3mediaserver to stream xvid/divx without re-encoding because the format is supported!?
FireFox1337
 
Posts: 12
Joined: Sun Feb 22, 2009 8:05 pm

Re: Movies Not Working

Postby meskibob » Sun Feb 22, 2009 8:55 pm

Post the actual debug log. It's much more specific as to what's actually going on.

For xvid/divx, just don't play them from the transcoded folder and they'll be streamed as is.
I provide NO application support via PM or email, so please post your question to the forum per the Forum Rules.
meskibob
Moderator
 
Posts: 4768
Joined: Mon Jan 19, 2009 4:11 pm

Re: Movies Not Working

Postby FireFox1337 » Sun Feb 22, 2009 9:28 pm

so yeah even when i'm not transcoding just streaming, its extremely slow + shuddery here's the log.

http://rapidshare.com/files/201305748/debug.log

nerohome media worked really good with xvid etc but doesnt have HD support for .264 mkv
FireFox1337
 
Posts: 12
Joined: Sun Feb 22, 2009 8:05 pm

Re: Very Slow Streaming/Transcoding

Postby FireFox1337 » Mon Feb 23, 2009 12:01 am

i tried it on my other computer which has.
2.2Ghz Quad Core Proc
4Gig DDR2 Ram
100Mbit card ethernet card

tryed with 720p source with mEncoder defualt settings....streaming is faster but still Very shuddery...
shagrath said that a pentium 4 could do 720p but a brand new 2.2Ghz Quad core cant???

any help Please

thanks in advance
FireFox1337
 
Posts: 12
Joined: Sun Feb 22, 2009 8:05 pm

Re: Very Slow Streaming/Transcoding

Postby FireFox1337 » Mon Feb 23, 2009 7:00 pm

bump really neeed help with this please
FireFox1337
 
Posts: 12
Joined: Sun Feb 22, 2009 8:05 pm

Re: Very Slow Streaming/Transcoding

Postby shagrath » Mon Feb 23, 2009 7:34 pm

Code: Select all
[Thread-90] DEBUG 15:24:50.453 Wrote on socket:
[Thread-91] DEBUG 15:25:33.421 Opened handler on socket Socket[addr=/192.168.2.11,port=50234,localport=5001]
[Thread-90] DEBUG 15:25:33.437 Sending stream with premature end : 2162688 bytes of get/0$1$7$1$3$0/haco-globeglobalassault-xvid.avi. Reason: An established connection was aborted by the software in your host machine
[Thread-90] DEBUG 15:25:33.437 Sending stream: 2162688 bytes of get/0$1$7$1$3$0/haco-globeglobalassault-xvid.avi
[Thread-90] DEBUG 15:25:33.437 Close Connection


same troubles than a lot of people with mp3s playing for example, there's a delay of 30 seconds between each request by ps3
that makes the DLNA feature unusable
I really don't know what happens... I would like to believe it's the server and I could do something about it but I really don't know
If you can test the same file without stuttering with another server, well...

my guess would be a network settings badly tuned or something like that (on router, network interface, etc.)
shagrath
Project Lead
 
Posts: 2667
Joined: Wed Jan 14, 2009 1:39 pm

Re: Very Slow Streaming/Transcoding

Postby FireFox1337 » Mon Feb 23, 2009 8:30 pm

alright thanks so now i know why xvids dont work but what about the transcoding.....my home network gets about 15MB/s to any computer. so i dont see it being the connection, my computer specs are more then enough.....any reasons on extreme transcoding shuddering?

thanks alot and im very envious of all you people streaming 1080p to ur big screen and my 62" is lacking :P

thanks alot shag...great program too bad i cant config it right :)
FireFox1337
 
Posts: 12
Joined: Sun Feb 22, 2009 8:05 pm

Re: Very Slow Streaming/Transcoding

Postby Konceptz » Tue Feb 24, 2009 12:00 am

How is your network setup? judging by the original post I'm guessing a router that the PC and PS3 are both directly wired into?

What OS? If its vista,try turning your firewall off and making sure that network discovery is enabled.

Also under network options in the PS3 make sure you set the duplex to auto. Changing this setting has practically eliminated any delays I had in streaming. I dunno how or why as forcing it to 100 full duplex should not cause this issue (something to to do with the logic controller on the PS3 NIC i guess).

Also try leaving the media server running overnight. I found this helps too.
Konceptz
 
Posts: 46
Joined: Sun Feb 01, 2009 8:19 am

Re: Very Slow Streaming/Transcoding

Postby FireFox1337 » Wed Feb 25, 2009 1:18 am

Koncepts i would like to give you a BIG thank you i changed my settings on ps3 from 100 full duplex to auto fixed EVERYTHING!

i would reccomend putting this in the FAQ to save other new people head aches.

again thanks sooooooooo much bro.

this server is the bomb!@
FireFox1337
 
Posts: 12
Joined: Sun Feb 22, 2009 8:05 pm

Next

Return to General Help and Support

Who is online

Users browsing this forum: No registered users and 11 guests