Choppiness Problem, and asking for help with settings

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Choppiness Problem, and asking for help with settings

Postby dovjm29 » Fri Aug 06, 2010 7:21 pm

I am a newbie and have read the tutorials and everything is somewhat working. My biggest problem is the choppiness at times and not sure what the culprit could be??

first I will specify what setup I am running.

Currently have a compaq desktop with:

Sempron LE-1300 (S) 2.3 GHz (45W)
1600 MT/s (mega transfers/second)
Socket AM2
Chipset
GeForce 6150SE nForce 430
2 gigs of ram.....

I have a N Wireless Card Installed and an N300 router

I stream to my PS3 which is wired to the router. which sends video and audio to my home theater processor via HDMI and then that to the Tv via HDMi for video. It works pretty well considering, but it is still choppy at times... What can I do to fix this??? Is there anything that can be done to settings, or router or is it computer issue??? Is it just a fact of life dealing with wireless streaming and nothing can be done, but maybe adjust settings???


thanks bunch

David
dovjm29
 
Posts: 2
Joined: Fri Aug 06, 2010 7:17 pm

Re: Choppiness Problem, and asking for help with settings

Postby devildog93 » Fri Aug 06, 2010 8:35 pm

Not knowing if you are talking about straight streaming (avi,mp4,m2ts) with compatible video containers.....

or

Transcoding (mkv) then streaming.

It could be, most likely, two things. Your network or your CPU.

If you are transcoding with MEncoder, or AviSynth/MEncoder, you can adjust both your bandwidth limit, and video quality settings.
Or, you can use {tsMuxer} engine if you are transcoding MKV files, and DO NOT require subtitles.
As stated in many threads, and well known to myself, {tsMuxer} is MUCH easier on BOTH your CPU and network. It may help you enough to work with your WiFi ---> PC and stop the stutter.

To use {tsMuxer}, you can:
1) set it to default engine for transcoding (will show behind filename.MKV like this {tsMuxer})
2) go into the #transcode# folder and select it manually {tsMuxer}
User avatar
devildog93
 
Posts: 1301
Joined: Fri Mar 19, 2010 8:37 pm

Re: Choppiness Problem, and asking for help with settings

Postby dovjm29 » Fri Aug 06, 2010 10:14 pm

Well I am running N Wireless Router, pure N 300... and have a N300 wireless card in the desktop. I can recheck the download/upload speeds but it is pretty good, let me know if this would be helpful. Now I realize my Desktop is not high end or anything but it is only year old and when streaming it is not utilizing more than 20 percent or so of the CPU... I have looked at the CPU percentages while streaming and not above 20 percent..... So doesnt sound like it could be the computer but could be i guess.


I am not using MKV files, I am streaming AVI files currently. I did have some MKV files and I converted them to AVI or Mpeg files.

Sorry again I am a newbie, but since they are avi files their is nothing to transcode correct??? so what settings could I change since it is just plan streaming???

And when I said choppiness, it does work it is not like it is choppy the entire time. It does work, but maybe every 3rd minute or so it gets choppy for few seconds or so. Not sure if it could be wireless interference or what could be the matter.....

Any suggestions on what settings I can change for steaming the AVI files, and not the MKV files???
dovjm29
 
Posts: 2
Joined: Fri Aug 06, 2010 7:17 pm

Re: Choppiness Problem, and asking for help with settings

Postby devildog93 » Sat Aug 07, 2010 1:07 am

I would guess that it is most likely your network then. Be it outside interference or other network traffic.
Possibly the bitrate hits peaks that surpass your actual network WiFi thru-put.

You could try to force transcode, using MEncoder. Set your "bandwidth limit" to about 15Mbps, and set your "video quality settings" to "lossless"

See if the transcoded video gives you grief. Your PC should keep up with .avi files being transcoded, thus the "lossless" recommendation.

Also, I recommend always making sure you have your PS3 set to "auto-detect" the "operation mode of the network device" under NETWORK SETTINGS.
The wrong duplex/speed can cause choppiness.
User avatar
devildog93
 
Posts: 1301
Joined: Fri Mar 19, 2010 8:37 pm

Re: Choppiness Problem, and asking for help with settings

Postby durwood » Sun Aug 15, 2010 8:45 pm

Choppy video solved. SOLVED CHOPPY VIDEO. I have a 1tb drive connected to router. Mac connected to router. Ps3 to router. All ethernet cat5e. PSM on mac serving files from TB to the ps3. make sure your file is a format that PSM can serve without on the fly transcoding. This slows it up. Get a compatible file type or convert it. Ex: MKV to avi converter. Make sure you go into network setup in the ps3 and set it to 100 half-duplex not automatic. 100 half duplex allows more of bandwidth to the download stream than to up stream. That is streaming the data to the ps3. In the PSM settings go to transcoding settings - general - buffer max size - 400, video quality max mbits - 14, quality settings keyint = 1: vqscale= 1, vqmin=2. also. don't try to stream a high def movie while downloading or transferring to the hard drive. these are eating up bandwidth. These settings finally allowed 720p video to be played from an external drive to the ps3 via PSM. I was downloading the file to the PS# hard drive and of course that worked. But now there is no need to do that. No need to upgrade my 40GB hard drive to 160 gb or 320gb. everything is stored on the TB. 40 is fine for game demos and other BS. 100 half duplex not automatic!
durwood
 
Posts: 21
Joined: Sun Aug 15, 2010 8:23 pm

Re: Choppiness Problem, and asking for help with settings

Postby devildog93 » Mon Aug 16, 2010 5:17 pm

Your solution might have worked for you, but I know for a fact, that "auto detect" is what STOPPED the choppiness on my roommates setup.

He had his set to "full duplex", I discoverd that his setting was wrong after looking at the router, and seeing that cable was in fact only a "half-duplex" cable. I switched his PS3 to "auto detect" and he has had no choppiness since.

Worked for you, but not recommended.
User avatar
devildog93
 
Posts: 1301
Joined: Fri Mar 19, 2010 8:37 pm

Re: Choppiness Problem, and asking for help with settings

Postby durwood » Wed Aug 18, 2010 5:16 am

just throwing out what worked for me. try all these suggestions until it works.
durwood
 
Posts: 21
Joined: Sun Aug 15, 2010 8:23 pm


Return to General Help and Support

Who is online

Users browsing this forum: No registered users and 17 guests