Got Veetle working on PS3! (still need some help though)

Discuss third-party additions, plugins and translations for PS3 Media Server

Got Veetle working on PS3! (still need some help though)

Postby motafa » Sat Aug 14, 2010 6:13 am

Veetle finally working on PS3. Veetle is the best streaming platform online, period. unbelievable HD streams for sports, shows, movies etc..

Using PS3 Media server v. 1.20.409 (its a beta) with pmsencoder plugin as the web encoding engine

*NOTE: Leave veetle running in the browser window throughout this entire process. Once it starts running on the ps3, it'll stop running in the browser window, DO NOT CLOSE THE BROWSER WINDOW

1. Ping veetle.com and get their IP (for windows machines run cmd.exe and simply type 'ping veetle.com'), record the IP address that shows up. Call it the 'Veetle IP'. In my case it was 77.67.109.221

2. Find the veetle channel you want to watch click on it...it should start streaming and the URL of the page will be as follows:

http: //veetle.com/index.php/channel/view#4b8e3c391e48b ... take the part after the '#' sign and call it the 'Channel Code'..in this case it would be 4b8e3c391e48b

3. Download a tcp/ip port monitor, I use tcpview...check out this cap off of a different forum:

Image

forget the localhost part, and record the port number, in this case 54012. Call it the veetle port.

4. Put the following together:

Code: Select all
http://[your local network IP]:[veetle port]/[veetle IP],[Channel Code]


e.g. in my case: http://192.168.1.2:54012/77.67.109.221,4b8e3c391e48b

5. Create a .rss file containing the following (note: this is a simple text file with the .rss extension)
Code: Select all
<?xml version="1.0" encoding="UTF-8"?>
<rss version="2.0">
  <channel>
    <title>Veetle</title>
    <link>http://192.168.11.3:57990/77.67.109.221,4b8e3c391e48b</link>
    <description>VEETLE</description>
    <language>en-us</language>
    <generator>mo</generator>
    <ttl>1</ttl>
    <item>
      <title>Veetle</title>
      <link>http://192.168.11.3:49791/77.67.109.221,4c65dde07279c</link>
      <description>Veetle video</description>
      <enclosure url="http://192.168.11.3:49791/77.67.109.221,4c65dde07279c" />
    </item>
  </channel>
</rss>


Note: I borrowed this rss format off of somewhere else in this forum..replace my http://.. with your relevant URL

6. Go to your WEB.conf file and add the following line under videofeed

Code: Select all
videofeed.Web,Veetle=file:///C:/Program Files (x86)/PS3 Media Server/Mo.rss


Where 'C:/Program Files (x86)/PS3 Media Server/Mo.rss' should represent the path to your rss file

7. go to your ps3 and watch the stream via the 'Web' folder

NOW for the help part

the stream plays great for about 2 mins then just stops...I believe this might be a buffering issue...I increased my buffer size to 600...still same problem...could chocolateboy maybe take a look at this issue?

I hope this pleases at least one other person
motafa
 
Posts: 2
Joined: Sat Aug 14, 2010 5:32 am

Re: Got Veetle working on PS3! (still need some help though)

Postby Twosheds » Tue Aug 17, 2010 3:48 pm

I've tried your method but I'm having no luck at all. I've tried using a Bravia TV & XBMC as clients but neither work.

You might like to know that when I play the Veetle feed through VLC it too stops after a minute or two. If I press the play button in VLC it restarts and then continues to play. Perhaps something similar will work with PMS.
Twosheds
 
Posts: 37
Joined: Tue Apr 27, 2010 4:28 pm
Location: Lincolnshire, UK

Re: Got Veetle working on PS3! (still need some help though)

Postby motafa » Tue Aug 17, 2010 4:56 pm

Well in VLC you can simply put in the

Code: Select all
http://192.168.1.2:54012/77.67.109.221,4b8e3c391e48b


URL form and it'll play smoothly (again, you must leave the browser running the channel)....this tells me something is going wrong with the transcoding.

Also, when you play the transcoded stream in xbmc, does the video seem to play quite a bit slower than the audio?
motafa
 
Posts: 2
Joined: Sat Aug 14, 2010 5:32 am

Re: Got Veetle working on PS3! (still need some help though)

Postby chocolateboy » Tue Aug 17, 2010 4:59 pm

There's a much easier way to do this (through the HTTP Live Streaming streams), but neither VLC nor MEncoder support them particularly well at the moment. I've got it working with hls-player, but that has issues as well (and it also stops after two minutes).
chocolateboy
Project Member
 
Posts: 2577
Joined: Wed Sep 16, 2009 10:05 am

Re: Got Veetle working on PS3! (still need some help though)

Postby Twosheds » Wed Aug 18, 2010 7:44 am

Motafa,

That's exactly how I do it but I still find vlc stops after a minute or two. Pressing the start button in VLC restarts it and then it's ok.

As I mentioned in my original post, I can't get your method to work using XBMC so I can't comment regarding audio/video lag.

Chocolateboy,

Do you mean this sort of thing ?
Code: Select all
videostream.Web,P2P=Veetle,http://127.0.0.1:51992/77.67.109.221,4bfd36af787bb/stream


I've tried it but with no luck
Twosheds
 
Posts: 37
Joined: Tue Apr 27, 2010 4:28 pm
Location: Lincolnshire, UK

Re: Got Veetle working on PS3! (still need some help though)

Postby chocolateboy » Wed Aug 18, 2010 9:26 am

Twosheds wrote:Do you mean this sort of thing ?
Code: Select all
videostream.Web,P2P=Veetle,http://127.0.0.1:51992/77.67.109.221,4bfd36af787bb/stream


No, I mean the .m3u8 (dynamic) playlists. You'll need to read up on HTTP Live Streaming if you want to know more.
chocolateboy
Project Member
 
Posts: 2577
Joined: Wed Sep 16, 2009 10:05 am

Re: Got Veetle working on PS3! (still need some help though)

Postby zalo » Tue Nov 16, 2010 1:25 am

i cant get the stream to show up at all on the ps3 but in vlc i can get it to start and keep playing as long as before you start it in vlc, you stop it in the browser
zalo
 
Posts: 2
Joined: Mon Nov 15, 2010 10:04 am

Re: Got Veetle working on PS3! (still need some help though)

Postby zalo » Tue Nov 16, 2010 8:01 am

figured it out, open veetle channel, scan for port, get http link, stop web player

open vlc, open network, put in link, streaming/transcoding wizard, choose the link from the playlist, choose mms stream, no transcode

in web.conf, videostream.Web,P2P=Veetle,mms://127.0.0.1:8080

start PMS, make sure you have the advanced HD h264 tab checked in the mencoder options

i think that should be it, i have been watching zeus HD on the PS3 for the last 20 minutes with just a few glitches but nothing upsetting
zalo
 
Posts: 2
Joined: Mon Nov 15, 2010 10:04 am

Re: Got Veetle working on PS3! (still need some help though)

Postby ottoman1384 » Fri Dec 10, 2010 6:21 pm

I use this batch file to get Sopcast working on the ps3.
Code: Select all
"C:\Program Files\VideoLAN\VLC\vlc.exe" -vvv http://127.0.0.1:8902/tv.asf --sout "#std{access=mmsh,mux=asfh,dst=:1234}"


Is there anyway of configuring Veetle to use a batch file similar to this to make it work, instead of going through all those steps?
ottoman1384
 
Posts: 42
Joined: Wed Dec 16, 2009 2:47 am

Re: Got Veetle working on PS3! (still need some help though)

Postby warhawk » Tue Mar 29, 2011 12:50 am

I was trying to follow these steps, but maybe something is different in VLC or i am doing something wrong.
In step 1 is easy and got that working no problem.
In step 2, i didn't see any wizard, but only streaming, so i put the link in it and go through the wizard. Again no MMS stream option.
In step 3, it look all good as i can see the link on the PS3.
In step 4, i didn't see a HD h264 tab in mencoder options.

So now when i hit play on the PS3, the data values on the PMS shown up in negative? Then it fails. Would appreciate the help in getting this going. Thanks :).

1) Open veetle channel, scan for port, get http link, stop web player
2) Open vlc, Open network, Put in link, streaming/transcoding wizard, choose the link from the playlist, choose mms stream, no transcode
3) in web.conf, videostream.Web,P2P=Veetle,mms://127.0.0.1:8080
4) start PMS, make sure you have the advanced HD h264 tab checked in the mencoder options
5) i think that should be it, i have been watching zeus HD on the PS3 for the last 20 minutes with just a few glitches but nothing upsetting
warhawk
 
Posts: 1
Joined: Tue Mar 29, 2011 12:42 am

Next

Return to Additions and Plugins

Who is online

Users browsing this forum: Yahoo [Bot] and 3 guests