Sony Bravia 40HX703 with PS3 Media server?

Discuss alternative media renderers (not PS3) supported by PS3 Media Server (e.g. Xbox 360, TVs &c.)

Sony Bravia 40HX703 with PS3 Media server?

Postby NaNaNii » Mon Aug 02, 2010 11:08 pm

How can i stream avi movies from my pc to Sony Bravia 40HX703 via Ps3 Media server. I've already got it setup up but can only play mkv's, not avi's. They work fine with my PS3
NaNaNii
 
Posts: 11
Joined: Thu Jul 15, 2010 9:06 pm

Re: Sony Bravia 40HX703 with PS3 Media server?

Postby Illico » Tue Aug 03, 2010 2:57 pm

40HX703 an 40EX500 use the same firmware see http://support.sony-europe.com/tvhc/dow ... DL-46EX500

So search on forum for EX500 configuration file.
For example, edit the Bravia5500.conf file and add "(BRAVIA KDL.+HX7)" on line "UserAgentAdditionalHeaderSearch=".
Sony Bravia KDL-46EX501 | Sony BDP-S373 | Sony SMP-N100 |Serviio / PS3MS | Buffalo 2Share DD
User avatar
Illico
 
Posts: 129
Joined: Wed Jun 30, 2010 2:28 pm
Location: France

Re: Sony Bravia 40HX703 with PS3 Media server?

Postby NaNaNii » Wed Aug 04, 2010 11:43 am

The TV can find PS3MS just fine. It's just the playback which is the issue. The avi files do not work
NaNaNii
 
Posts: 11
Joined: Thu Jul 15, 2010 9:06 pm

Re: Sony Bravia 40HX703 with PS3 Media server?

Postby Illico » Wed Aug 04, 2010 1:11 pm

Could you post this avi file information with MediaInfo ?
Could you post the Configuration file that you use for your Bravia TV ?
Sony Bravia KDL-46EX501 | Sony BDP-S373 | Sony SMP-N100 |Serviio / PS3MS | Buffalo 2Share DD
User avatar
Illico
 
Posts: 129
Joined: Wed Jun 30, 2010 2:28 pm
Location: France

Re: Sony Bravia 40HX703 with PS3 Media server?

Postby NaNaNii » Wed Aug 04, 2010 1:35 pm

Here's the media info of a typical avi which i'm trying to play

General
Complete name : D:\Films\Adulthood\Adulthood.LiMiTED.DVDRip.XviD.avi
Format : AVI
Format/Info : Audio Video Interleave
File size : 701 MiB
Duration : 1h 35mn
Overall bit rate : 1 029 Kbps
Writing application : Nandub v1.0rc2
Writing library : Nandub build 1852/release

Video
ID : 0
Format : MPEG-4 Visual
Format profile : Advanced Simple@L5
Format settings, BVOP : No
Format settings, QPel : No
Format settings, GMC : No warppoints
Format settings, Matrix : Default (H.263)
Codec ID : XVID
Codec ID/Hint : XviD
Duration : 1h 35mn
Bit rate : 888 Kbps
Width : 624 pixels
Height : 352 pixels
Display aspect ratio : 16:9
Frame rate : 25.000 fps
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Bits/(Pixel*Frame) : 0.162
Stream size : 605 MiB (86%)
Writing library : XviD 1.2.0SMP (UTC 2006-01-08)

Audio
ID : 1
Format : MPEG Audio
Format version : Version 1
Format profile : Layer 3
Mode : Joint stereo
Mode extension : MS Stereo
Codec ID : 55
Codec ID/Hint : MP3
Duration : 1h 35mn
Bit rate mode : Variable
Bit rate : 128 Kbps
Channel(s) : 2 channels
Sampling rate : 48.0 KHz
Stream size : 87.0 MiB (12%)
Alignment : Aligned on interleaves
Interleave, duration : 24 ms (0.60 video frame)
Interleave, preload duration : 462 ms
Writing library : LAME3.90.
Encoding settings : -m j -V 4 -q 2 -lowpass 17.6 --abr 128

Here's my .conf file
# ps3mediaserver renderer profile for Sony Bravia 5500 series
# Refer to PS3.conf for help

RendererName=Sony Bravia 5500 Series
RendererIcon=bravia.png
UserAgentSearch=notusedhere
UserAgentAdditionalHeader=X-AV-Client-Info
UserAgentAdditionalHeaderSearch=(BRAVIA KDL.+5[0-9]{3})|(BRAVIA KDL.+WE5)|(BRAVIA KDL-[0-9]{2}XBR9)|(BRAVIA KDL.+EX5)(BRAVIA KDL.+HX7)
Video=true
Audio=true
Image=true
SeekByTime=true
TranscodeVideo=MPEGAC3
TranscodeAudio=MP3
DefaultVBVBufSize=true
MuxH264ToMpegTS=true
MuxDTSToMpeg=false
WrapDTSIntoPCM=false
MuxLPCMToMpeg=false
MaxVideoBitrateMbps=0
MaxVideoWidth=0
MaxVideoHeight=0
H264Level41Limited=true
MimeTypesChanges=audio/wav=audio/L16|video/mp4=video/mpeg
DLNALocalizationRequired=true
TranscodeExtensions=dvr-ms,dvr,mkv,dv,ty,mov,ogm,hdmov,hdm,rmv,rmvb,rm,asf,evo,asx,flv,m2v,mpe,mod,tivo,ty,tmf,ts,tp,m2p,mp4,m4v,avi,wmv,wm,divx,div,flac,mlp,fla,wma,m4a,aac,dts,mka,ape,ogg,shn,mpc,ra,mp2,wv,oma,aa3,gif,png,arw,cr2,crw,dng,raf,mrw,nef,pef,tif,tiff
StreamExtensions=


#Better/faster codec detection method ! true to enable it
#Need testing !
MediaInfo=false
Supported = f:mpegps|mpegts v:mpeg2|mp4|h264 a:ac3|lpcm|aac|mpa m:video/mpeg
Supported = f:mp3 m:audio/mpeg
Supported = f:wav m:audio/L16
Supported = f:jpg m:image/jpeg
NaNaNii
 
Posts: 11
Joined: Thu Jul 15, 2010 9:06 pm

Re: Sony Bravia 40HX703 with PS3 Media server?

Postby Illico » Wed Aug 04, 2010 2:44 pm

Thx,

1) Your *DVDRip.XviD.avi file seems OK. Its a high profile L5 of MPEG4 video but mencoder must transcode it to mpeg2 video (and mpeg2ps container with MP3 audio), do you have a debug.log file with mencoder command line? So MPEG_PS_PAL renderer profile will be used.

2) In your .conf file,
- The symbol | is missing between brackets (BRAVIA KDL.+EX5) and (BRAVIA KDL.+HX7)
UserAgentAdditionalHeaderSearch=(BRAVIA KDL.+5[0-9]{3})|(BRAVIA KDL.+WE5)|(BRAVIA KDL-[0-9]{2}XBR9)|(BRAVIA KDL.+EX5)|(BRAVIA KDL.+HX7)
- MediaInfo=false so you don't use MediaInfo for codec detection, and all files extensions list on "TranscodeExtensions=" will be transcode, ok why not!

3) Do you have the latest beta version ? viewtopic.php?f=2&t=3217#p13908

To be continued
Sony Bravia KDL-46EX501 | Sony BDP-S373 | Sony SMP-N100 |Serviio / PS3MS | Buffalo 2Share DD
User avatar
Illico
 
Posts: 129
Joined: Wed Jun 30, 2010 2:28 pm
Location: France

Re: Sony Bravia 40HX703 with PS3 Media server?

Postby NaNaNii » Wed Aug 04, 2010 3:17 pm

Yeah, i've got the last beta version. I've added the missing |. I've changed the MediaInfo Value to True. I'm not sure what you mean on the debug file

Thanks for your help by the way, Really appreciate it :)
NaNaNii
 
Posts: 11
Joined: Thu Jul 15, 2010 9:06 pm

Re: Sony Bravia 40HX703 with PS3 Media server?

Postby Illico » Wed Aug 04, 2010 3:34 pm

NaNaNii wrote:I'm not sure what you mean on the debug file

I wanted to say:
1) Restart your PMS
2) Start to stream your avi file with your bravia TV.
3) Look at this viewtopic.php?f=6&t=496#p2482 and send the debug.log file
I will look at something like that:
[win32/mencoder.exe] TRACE 18:04:54.523 Process C:\Program Files (x86)\PS3 Media Server\win32\mencoder.exe has a return code of 1! Maybe an error occured... check the log file
Sony Bravia KDL-46EX501 | Sony BDP-S373 | Sony SMP-N100 |Serviio / PS3MS | Buffalo 2Share DD
User avatar
Illico
 
Posts: 129
Joined: Wed Jun 30, 2010 2:28 pm
Location: France

Re: Sony Bravia 40HX703 with PS3 Media server?

Postby Illico » Wed Aug 04, 2010 3:44 pm

NaNaNii wrote:I've changed the MediaInfo Value to True.

If you change the MediaInfo Value to true, all supported media formats of this renderer will be streamed or remux (Tsmux), the rest will be transcoded.
"TranscodeExtensions=" and "StreamExtensions=" lines will be ignored, so could be comment.

Bravia HX703, only support mpeg2ps, mpeg2ts with mpeg2 or h264(AVC) video and ac3,mp3,aac audio. So you must change your .conf with following

Could you try with following changes ?

TranscodeVideo=MPEGTSAC3
TranscodeAudio=MP3
#TranscodeExtensions=
#StreamExtensions=
MediaInfo=true
Supported = f:mpegps|mpegts v:mpeg2|h264 a:ac3|lpcm|aac m:video/mpeg
Supported = f:mp3 m:audio/mpeg
Supported = f:wav m:audio/L16
Supported = f:jpg m:image/jpeg
Sony Bravia KDL-46EX501 | Sony BDP-S373 | Sony SMP-N100 |Serviio / PS3MS | Buffalo 2Share DD
User avatar
Illico
 
Posts: 129
Joined: Wed Jun 30, 2010 2:28 pm
Location: France

Re: Sony Bravia 40HX703 with PS3 Media server?

Postby NaNaNii » Wed Aug 04, 2010 11:16 pm

I've made the changes to the conf file

Here my Debug File
http://www.2shared.com/uploadComplete.j ... A5dNvjqG5M

When i play a avi on my bravia, it says "there are no items to display"
NaNaNii
 
Posts: 11
Joined: Thu Jul 15, 2010 9:06 pm

Next

Return to Alternative Media Renderers

Who is online

Users browsing this forum: Google [Bot] and 5 guests