No sound on newer MKV files?

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

No sound on newer MKV files?

Postby HarleyGuy » Sat Jul 10, 2010 10:07 pm

Been using this for months now without ever having a single issue, and now have 3 separate MKV files that play fine on thew PC in VLC Media Player, but get no sound at all on the PS3.

Last Boy Scout
The Losers
Repo Men Sample

Has something changed in these new MKV files?

Here is my info:

3.2ghz Quad Core, 6gb, Win 7, PS3MS v1.10.51
100mbit PC - Actiontec MI424WR Router - PS3
Streaming to a PS3
Video Plays back fine, but neither regular streaming nor transcoding seems to allow sound to playback on the PS3. Playback on PC via VLC works fine

MediaInfo for one of the files:

General
Complete name : M:\Hi-Def Movies\Last Boy Scout, The - 1080p.mkv
Format : Matroska
File size : 7.94 GiB
Duration : 1h 45mn
Overall bit rate : 10.8 Mbps
Encoded date : UTC 2010-07-06 17:45:18
Writing application : mkvmerge v4.1.1 ('Bouncin' Back') built on Jul 3 2010 22:54:08
Writing library : libebml v1.0.0 + libmatroska v1.0.0

Video
ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High@L4.0
Format settings, CABAC : Yes
Format settings, ReFrames : 5 frames
Muxing mode : Container profile=Unknown@4.0
Codec ID : V_MPEG4/ISO/AVC
Duration : 1h 45mn
Bit rate : 9 282 Kbps
Width : 1 920 pixels
Height : 800 pixels
Display aspect ratio : 2.40:1
Frame rate : 23.976 fps
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Bits/(Pixel*Frame) : 0.252
Stream size : 6.67 GiB (84%)
Writing library : x264 core 98 r1649 c54c47d
Encoding settings : cabac=1 / ref=5 / deblock=1:0:0 / analyse=0x3:0x113 / me=umh / subme=7 / psy=1 / psy_rd=1.00:0.00 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=1 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=0 / chroma_qp_offset=-2 / threads=12 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / constrained_intra=0 / bframes=3 / b_pyramid=2 / b_adapt=1 / b_bias=0 / direct=1 / weightb=1 / weightp=2 / keyint=250 / keyint_min=25 / scenecut=40 / intra_refresh=0 / rc_lookahead=40 / rc=2pass / mbtree=1 / bitrate=9282 / ratetol=1.0 / qcomp=0.60 / qpmin=10 / qpmax=51 / qpstep=4 / cplxblur=20.0 / qblur=0.5 / ip_ratio=1.40 / aq=1:1.00

Audio
ID : 2
Format : DTS
Format/Info : Digital Theater Systems
Codec ID : A_DTS
Duration : 1h 45mn
Bit rate mode : Constant
Bit rate : 1 510 Kbps
Channel(s) : 6 channels
Channel positions : Front: L C R, Side: L R, LFE
Sampling rate : 48.0 KHz
Bit depth : 24 bits
Stream size : 1.11 GiB (14%)

Text
ID : 3
Format : UTF-8
Codec ID : S_TEXT/UTF8
Codec ID/Info : UTF-8 Plain Text
HarleyGuy
 
Posts: 2
Joined: Sat Jul 10, 2010 9:45 pm

Re: No sound on newer MKV files?

Postby Soupladel » Sun Jul 11, 2010 12:28 am

I am having the exact same problem and i have no idea why it is happening, have spent the last couple of hours tryingt o get repo men working and it just will not play the audio, I have a DTS compatible amp but PMS will not allow me to select the option for keeping the DTS stream.
Soupladel
 
Posts: 9
Joined: Sun May 02, 2010 12:50 pm

Re: No sound on newer MKV files?

Postby elpablo » Sun Jul 11, 2010 12:37 am

HarleyGuy wrote:....
Writing application : mkvmerge v4.1.1 ('Bouncin' Back') built on Jul 3 2010 22:54:08

That's the problem, 4.1.0 or newer
Thx to a friend on another forum (tid88) I discovered that since 4.1.0 mkvtoolnix have a different compression option on audio track inside mkv to save wasted space (or they said so, but I've found that the gain is about 500kb on 7-8 Gb file, pratically NOTHING).
You can read here http://www.bunkus.org/videotools/mkvtoolnix/faq.html
Code: Select all
 Why does audio not play anymore since v4.1.0 (MP3, AC3, DTS audio tracks)?
The Matroska specifications know a feature called "header removal compression". This allows a muxer to keep a certain number of bytes that are identical for each frame in the track headers removing them from the individual frames. This reduces the size of the tracks significantly without altering the content as a demuxer can add the bytes found in the track headers to each frame during demuxing.

Starting with v4.1.0 mkvmerge uses header removal compression for a couple of track types by default. These include AC3, DTS and MP3 audio tracks as well as Dirac and MPEG-4 part 2 (aka. XviD/DivX) video tracks. The user muxing a file may disable it by explicitely selecting 'none' as the compression scheme for such a track.

If your player has difficulties playing such files then it is a bug in thath player or in the demuxer but not in mkvmerge. This feature has been part of the Matroska specification since more than six years, and there's no excuse for refusing to add support for it.


In advance, they said that "If your player has difficulties playing such files then it is a bug in thath player or in the demuxer but not in mkvmerge. This feature has been part of the Matroska specification since more than six years, and there's no excuse for refusing to add support for it."
So I'm re-merging mkv files with toolnix 3.4.0 to play fine on my PS3.

A new job for shagrath?

The waste is probably that new option. Yes, waste of time.

byEz
elpablo
 
Posts: 3
Joined: Sat Feb 13, 2010 1:00 pm

Re: No sound on newer MKV files?

Postby drem » Sun Jul 11, 2010 12:44 am

Unfortunately the answer is Cinavia:
http://www.afterdawn.com/news/article.c ... at_pirates

Hopefully someone can get this thing de-activated.
drem
 
Posts: 22
Joined: Wed Nov 11, 2009 10:40 pm

Re: No sound on newer MKV files?

Postby Soupladel » Sun Jul 11, 2010 12:55 am

May not be actually, I have just repackaged my mkv with 3.4.0 version of mkv toolnix and it is working fine now :-)
Soupladel
 
Posts: 9
Joined: Sun May 02, 2010 12:50 pm

Re: No sound on newer MKV files?

Postby HarleyGuy » Sun Jul 11, 2010 2:49 pm

Soupladel wrote:May not be actually, I have just repackaged my mkv with 3.4.0 version of mkv toolnix and it is working fine now :-)


Soupladel

Can you tell me specifically what you did within mkvtoolnix to get the audio working?

I tried using it for the first time and it seemed to work ok, but still got no sound.

Thanks!
HarleyGuy
 
Posts: 2
Joined: Sat Jul 10, 2010 9:45 pm

Re: No sound on newer MKV files?

Postby devildog93 » Sun Jul 11, 2010 8:27 pm

Version 3.3.0 of MKVToolnix works fine as well.
User avatar
devildog93
 
Posts: 1301
Joined: Fri Mar 19, 2010 8:37 pm

Re: No sound on newer MKV files?

Postby Nordica » Sun Jul 11, 2010 9:13 pm

Repo men, is the firs movie i have encountered this problem with. But i try MKVToolnix and hope it works :)

*EDIT*
And it did !! Thanks !
(MKVToolnix v3.4.0)
Start the mkvmerge GUI, add the movie file to "Input files"

Under "Tracks, chapters and tags" i unchecked Chapters and S_TEXT/UTF (I don't care about chapters and subtitles)

Then just hit "start muxing" w8 for a while and now u have a movie with working DTS track.
Nordica
 
Posts: 2
Joined: Mon Jul 05, 2010 4:49 pm

Re: No sound on newer MKV files?

Postby fenixen » Thu Jul 15, 2010 6:07 pm

any fix coming for this issue?
fenixen
 
Posts: 8
Joined: Tue Mar 30, 2010 10:12 pm

Re: No sound on newer MKV files?

Postby psykotick » Sun Jul 18, 2010 6:01 am

I really hope that there will be a fix somehow. I have been using PS3 Media Server for over a year, and it has always been perfect for me.
psykotick
 
Posts: 7
Joined: Thu Sep 17, 2009 7:27 am

Next

Return to General Help and Support

Who is online

Users browsing this forum: Bing [Bot], Google [Bot], Yahoo [Bot] and 9 guests