Subtitles

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Subtitles

Postby Eagle » Mon Feb 09, 2009 11:55 pm

Hello,

Can someone tell me how to put a filter on subtitles?(i use the Avisynth/MEncoder engine)
Here is an example of my problem: I have a mkv file with english subtitles inside, but i want to use an external subtitle(dutch srt file)
Every time i start the movie i see dubble subtitles: the english one and the dutch one
But there is another problem: Other mkv files has the dutch subtitles inside, so then i have to use that one
Maybe there is a script for Avisynth to configure it right!!(disable the english subtitles)
I hope someone can help me

My computer: Core 2 Quad Q6600
2GB Ram
Wired Network 100Mbit
Installed:Haalisplitter
ffdshow, vsfilter(autoloading version)
Eagle
 
Posts: 9
Joined: Mon Feb 09, 2009 11:19 pm

Re: Subtitles

Postby Chaoz » Tue Feb 10, 2009 2:24 am

Find the Haali Media Splitter filter

Go to Languages -> Audio and Subtitle Settings -> type "off" in the value.
Chaoz
 
Posts: 45
Joined: Mon Jan 19, 2009 10:26 pm

Re: Subtitles

Postby Eagle » Tue Feb 10, 2009 10:58 am

Thank you Chaoz for your reply!

I tried this option, but i still get the double subtitles (with Avisynth/MEncoder) if i set Languages -> Audio and Subtitle Settings -> type "off"
(Or do i have to put there: eng,off?)

It seems that Haali splitter always loads the first text stream from the mkv file if the following option is configured:
Haali Splitter -> Options -> Compatibility ->Autoload VSFilter -> Yes
If i set this option to No then only the external (dutch) srt file is loaded(This is only right for this movie!)
But when i load another mkv with dutch subtitles inside, i don't see subtitles(because the VSFilter setting is No!)
(P.s. If this setting is configured as No, in the system tray i only see Matroska splitter and ffdshow audio decoder.
Do you know which application then loads the external .srt subtitle???)

So is there a way to "script" this in PS3 Media Server 1.04 Under Transcoding Options -> Avisynth/MEncoder
or with the Haali Splitter -> Options ->Languages (by the way i tried several options here but nothing seems to work)
------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
PS3 Media Server Version: 1.04
Haali Splitter Version: 1.9.42.1
Eagle
 
Posts: 9
Joined: Mon Feb 09, 2009 11:19 pm

Re: Subtitles

Postby Chaoz » Tue Feb 10, 2009 6:51 pm

Eagle wrote:Thank you Chaoz for your reply!

I tried this option, but i still get the double subtitles (with Avisynth/MEncoder) if i set Languages -> Audio and Subtitle Settings -> type "off"
(Or do i have to put there: eng,off?)

It seems that Haali splitter always loads the first text stream from the mkv file if the following option is configured:
Haali Splitter -> Options -> Compatibility ->Autoload VSFilter -> Yes
If i set this option to No then only the external (dutch) srt file is loaded(This is only right for this movie!)
But when i load another mkv with dutch subtitles inside, i don't see subtitles(because the VSFilter setting is No!)
(P.s. If this setting is configured as No, in the system tray i only see Matroska splitter and ffdshow audio decoder.
Do you know which application then loads the external .srt subtitle???)

So is there a way to "script" this in PS3 Media Server 1.04 Under Transcoding Options -> Avisynth/MEncoder
or with the Haali Splitter -> Options ->Languages (by the way i tried several options here but nothing seems to work)
------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
PS3 Media Server Version: 1.04
Haali Splitter Version: 1.9.42.1



Go to the transcoded folder of where the video is and there should be a file labled 'Mencoder Dutch' or something like that. That's the subtitle.
Chaoz
 
Posts: 45
Joined: Mon Jan 19, 2009 10:26 pm

Re: Subtitles

Postby Subject2Change » Tue Feb 10, 2009 7:22 pm

You should also be able to disable certain languages with in the PSM Settings. And make Dutch your primary.
Core2Duo E8400 (@ 3.0), 8gigs of Mushkin, Vista Home Premium SP2 64bit, 2.5 TB of Space, Wired to Linksys WRT54G wired to 80GB MGS4 PS3 on Sharp 32" 720p LCD TV
Subject2Change
 
Posts: 63
Joined: Sun Feb 01, 2009 6:28 am

Re: Subtitles

Postby Eagle » Tue Feb 10, 2009 7:45 pm

Chaoz wrote:

Go to the transcoded folder of where the video is and there should be a file labled 'Mencoder Dutch' or something like that. That's the subtitle.


Thanks for your reply Chaoz!
I understand what you said and that works fine!
but then i'll use the MEncoder engine and not the Avisynth engine.
I only want to use Avisynth engine
Last edited by Eagle on Tue Feb 10, 2009 7:54 pm, edited 1 time in total.
Eagle
 
Posts: 9
Joined: Mon Feb 09, 2009 11:19 pm

Re: Subtitles

Postby Eagle » Tue Feb 10, 2009 7:49 pm

Subject2Change wrote:You should also be able to disable certain languages with in the PSM Settings. And make Dutch your primary.


Thanks for your reply Subject2Change!
But i'll think this options only work if you use the MEncoder engine!
and i only want to use the Avisynth engine!
Eagle
 
Posts: 9
Joined: Mon Feb 09, 2009 11:19 pm

Re: Subtitles

Postby Eagle » Wed Feb 11, 2009 6:57 pm

Is there anyone who knows the answer??
Eagle
 
Posts: 9
Joined: Mon Feb 09, 2009 11:19 pm

Re: Subtitles

Postby shagrath » Wed Feb 11, 2009 7:34 pm

what's the difficulty ? in haalin, set subtitles language priority: dut,nl,ned,eng
and enable auto load in VobSub for your srt(don't remember where the setting is)
and don't put an english srt next to a dutch movie if you don't want them
shagrath
Project Lead
 
Posts: 2664
Joined: Wed Jan 14, 2009 1:39 pm

Re: Subtitles

Postby Eagle » Wed Feb 11, 2009 8:35 pm

shagrath wrote:what's the difficulty ? in haalin, set subtitles language priority: dut,nl,ned,eng
and enable auto load in VobSub for your srt(don't remember where the setting is)
and don't put an english srt next to a dutch movie if you don't want them


Thank you for your reply shagrath! But i think you don't understand me!
The difficulty is that i have a movie with english subtitles inside and i want to use dutch subtitles! so then i use an external dutch srt file. But Haali splitter always loads the internal subtitle and direct vobsub always loads the dutch srt file so i have double subtitles on the tv(And even when i configure Haali splitter with the language priority you said doesn't work!!!)

And when i say in Haali autoload vsfilter->no then i have a problem when i watch a DIFFERENT movie with dutch subtitles inside(NO external dutch srt)because no subtitles are loaded.
The point is that i don't want to change every time the autoload vsfilter setting in Haali for the different movies because my computer is upstairs and my tv downstairs. So there have to be a way to configure it right.
I hope you now understand what my problem is.
Eagle
 
Posts: 9
Joined: Mon Feb 09, 2009 11:19 pm

Next

Return to General Help and Support

Who is online

Users browsing this forum: Bing [Bot], geb724, Yahoo [Bot] and 22 guests