Subtitles (priority settings) don't work correctly

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Subtitles (priority settings) don't work correctly

Postby puntloos » Mon Feb 22, 2010 11:13 pm

(... or I misunderstand this setting, but I don't think so)

Using 1.20.400

My main goal is that I do NOT want to see subtitles unless I specifically enable them. Reasons:
1/ Transcoding when not needed loses quality
2/ Subtitles are just annoying if all viewers speak the audio's language.

Makes sense, right? :)

Now.

Option 1:
- Definitely disable all subtitles
- Use subtitles from the Transcode folder where appropriate
Problem: Ps3mediaserver uses bad settings and for some reason the subtitle size is HUGE (like filling 30% of the screen height). Perhaps this is because the mencoded subtitles settings are greyed out when you tick 'disable all subtitles'?

Option 2:
- Allow subtitles (untick definitely disable..)
- Mencoder -> audio language priority: eng,nld,ger
- Mencoder -> audio/subtitles language priority: en,off;eng,off;nl,off;nld;off
Problem: any file that has subtitles will show them, even english/dutch subs.

Help?
puntloos
 
Posts: 51
Joined: Thu Nov 26, 2009 7:33 pm

Re: Subtitles (priority settings) don't work correctly

Postby Tired1 » Tue Feb 23, 2010 3:13 am

I'm not sure what language you speak (natively) but if you go to audio subtitles language priority (in the mencoder settings) and for me it's en,off;eng,off;jp,on;jpn,on;zh,on; etcetc... But this only works if your video files have properly tagged audio sources (a lot of the torrent downloads DO NOT have properly tagged audio). Also: instead of definitely disabling subs, you can turn them off by default and use the Transcode folder to select them when needed...
Tired1
 
Posts: 49
Joined: Tue Jan 26, 2010 2:07 pm

Re: Subtitles (priority settings) don't work correctly

Postby puntloos » Tue Feb 23, 2010 12:50 pm

Tired1 wrote:I'm not sure what language you speak (natively)

English, Dutch natively, and I can handle German but I do prefer subtitles for that. Anyway it's not that important for the general issue ;) )
but if you go to audio subtitles language priority (in the mencoder settings) and for me it's en,off;eng,off;jp,on;jpn,on;zh,on; etcetc...

You've specified a lot explicitly, which is cool but unnecessary I think. For me the rule needs to be "only turn off subtitles if the language is english or dutch" so I've only specified that in rules.
But this only works if your video files have properly tagged audio sources (a lot of the torrent downloads DO NOT have properly tagged audio).

Audio and subtitle streams are all properly tagged.
Also: instead of definitely disabling subs, you can turn them off by default and use the Transcode folder to select them when needed...

Indeed, that was my listed option 2. It sadly doesn't work.

From another thread:
Using the additional mencoder settings:
Code: Select all
-subfont-text-scale 2 -subpos 96


Works pretty well for me.. I think that this workaround works for me, but this is still a bug, I believe.
puntloos
 
Posts: 51
Joined: Thu Nov 26, 2009 7:33 pm

Re: Subtitles (priority settings) don't work correctly

Postby ExSport » Tue Feb 23, 2010 3:57 pm

en,off;eng,off;jp,on;jpn,on;zh,on; etcetc...

You don't understand the syntax of this audio/subtitles priority specification ;)
Exactly I mean this part:
Code: Select all
jpn,on

What is ON? :) You are defining what subs can be enabled if some specific audio is played so ON is nothing. You need to use lang-tags or OFF where it is useless to define lang-tag ;)
Use something like
Code: Select all
eng,off;ger,off;jpn,eng;*,eng

It has this meaning: If eng audio, disable subs. If ger audio, disable subs. If jpn audio, use eng subs(if exists). If any other audio, use eng subs.
This is the logic.
Also when no language tag is defined, you can see audio or subs as "undetermined". it means you need to use UND in priority settings so if UND audio, disable subs. Then it will be something like:
Code: Select all
eng,off;ger,off;jpn,eng;und,off;*,eng

External subs can be tagged this way(english): moviename.ENG.srt
ExSport
 
Posts: 2167
Joined: Mon Jan 19, 2009 5:40 pm

Re: Subtitles (priority settings) don't work correctly

Postby Tired1 » Wed Feb 24, 2010 9:16 am

puntloos wrote:Audio and subtitle streams are all properly tagged.

And it still shows them? That's very odd. Do they show up in the transcode folder with the proper names?

(on a sidenote: I had copied what I had in my subtitle settings as I'm having issues with a file that they won't show in, so I was trying things and didn't pay attention when I posted, my bad, but I learned that you can add und to the mix, so tyty)
Tired1
 
Posts: 49
Joined: Tue Jan 26, 2010 2:07 pm

Re: Subtitles (priority settings) don't work correctly

Postby DarkKnight » Thu Mar 04, 2010 8:23 pm

Im also having the same problem.

I just went to the beta build and also seem to always get subtitles
DarkKnight
 
Posts: 2
Joined: Tue Sep 08, 2009 10:25 pm

Re: Subtitles (priority settings) don't work correctly

Postby puntloos » Sat Mar 13, 2010 1:37 am

I'm pretty sure the priority settings indeed are broken, but just forcing them all off and then using the Transcode folder when needed works pretty well.
puntloos
 
Posts: 51
Joined: Thu Nov 26, 2009 7:33 pm

Re: Subtitles (priority settings) don't work correctly

Postby ExSport » Sat Mar 13, 2010 8:55 am

puntloos wrote:I'm pretty sure the priority settings indeed are broken, but just forcing them all off and then using the Transcode folder when needed works pretty well.

I am pretty sure it is not! ;)
Priority works like charm for me.
ExSport
 
Posts: 2167
Joined: Mon Jan 19, 2009 5:40 pm

Re: Subtitles (priority settings) don't work correctly

Postby puntloos » Sat Mar 13, 2010 1:21 pm

Can you list all your subtitle priority settings for me?

Mine are so simple I can hardly imagine they are broken.

Mine:
Audio Language Priority: eng,nld,ger
Subtitles Language Priority: eng,nld,ger
Audio/Subs Priority: en,off;eng,off;nl,off;nld,off

Result: all movies that have subtitles get them turned on. It's possible (but I wouldn't know why) that some are mis-tagged but most movies show up properly in the transcode folder. Example:

[Mencoder] {Audio: AC3/English] {Sub:Embedded/English}
Seems clear to me that my priority settings should not show the subs, right? Wrong.

-M
puntloos
 
Posts: 51
Joined: Thu Nov 26, 2009 7:33 pm

Re: Subtitles (priority settings) don't work correctly

Postby ExSport » Sat Mar 13, 2010 4:22 pm

1. use 2-char lang tag only(nl) so you will not mis-configure nld or dut 3-char format
2. version of your pms?
3. restart PMS, play "wrong" file, shutdown PMS, post debug.log here
Easy 8-)
ExSport
 
Posts: 2167
Joined: Mon Jan 19, 2009 5:40 pm

Next

Return to General Help and Support

Who is online

Users browsing this forum: Google [Bot] and 22 guests