Chinese character files not showing up

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Chinese character files not showing up

Postby alui » Sun Feb 01, 2009 7:58 am

Shagrath,

I have some movies that are named in chinese characters. Most of them (but not all) don't show up on my PS3. The weird thing is a few of them do show up. I'm guessing that the ones that do show up use a different character encoding set from the ones that don't show, even though they are all chinese characters. I skimmed through the debug.log and found the following that might be helpful ...

[Thread-51] INFO 01:41:29.767 Forcing short path name on V:\TEST\????????.rmvb
[Thread-51] DEBUG 01:41:29.767 Search extension for V:\TEST\_WS0FM~M
..........
[Thread-92] INFO 01:41:41.217 File automatically added: ????????.rmvb
[Thread-92] INFO 01:41:41.569 Forcing short path name on V:\TEST\????????.rmvb
[Thread-92] DEBUG 01:41:41.569 Search extension for V:\TEST\_WS0FM~M

Seemed like the media server was not recognizing the filename, and when I changed the name to test.rmvb it showed up. BTW, I'm running the latest version 1.03.

Thanks
alui
 
Posts: 16
Joined: Tue Jan 27, 2009 3:29 am

Re: Chinese character files not showing up

Postby shagrath » Sun Feb 01, 2009 11:37 am

I fixed a bug in filename charset encoding for the next version: I guess it should work better
shagrath
Project Lead
 
Posts: 2664
Joined: Wed Jan 14, 2009 1:39 pm

Re: Chinese character files not showing up

Postby alui » Sat Feb 07, 2009 5:14 am

shagrath wrote:I fixed a bug in filename charset encoding for the next version: I guess it should work better


FYI, I just installed 1.04 and tested it on my files. They still are not showing up. Hoping that you can fix it in the next version ...

Thanks.
alui
 
Posts: 16
Joined: Tue Jan 27, 2009 3:29 am

Re: Chinese character files not showing up

Postby shagrath » Sat Feb 07, 2009 11:59 am

post some non working filenames here... I'll try to test them
shagrath
Project Lead
 
Posts: 2664
Joined: Wed Jan 14, 2009 1:39 pm

Re: Chinese character files not showing up

Postby alui » Sun Feb 08, 2009 5:29 am

shagrath wrote:post some non working filenames here... I'll try to test them


Turns out that it's not the filenames that were causing the problem. Rather, it's where they're stored. The problematic files were stored on a shared NAS drive. I did a test and copied one of these error files to an internal hard drive and an external usb drive, and both of them showed up and transcoded fine with no re-naming of the file. So, the problem is that the PS3 media server can't display chinese character files that are stored on a NAS drive. Not sure if there's an easy fix to this peculiar bug.

Thanks
alui
 
Posts: 16
Joined: Tue Jan 27, 2009 3:29 am


Return to General Help and Support

Who is online

Users browsing this forum: Google [Bot] and 8 guests