Last.Fm scrobbling support

Discuss third-party additions, plugins and translations for PS3 Media Server

Re: Last.Fm scrobbling support

Postby sG4RYt » Wed Dec 23, 2009 10:25 pm

Guys, I need help installing this thing

I downloaded the zip file and opened it with winrar, extracted the .jar file. There was no "plugin" folder in my PS3MediaServer file so I created one and dropped the .jar file there. Nothing changed. What am I doing wrong? What do I have to do for it to work? Thanks in advance.
sG4RYt
 
Posts: 1
Joined: Wed Dec 23, 2009 10:22 pm

Re: Last.Fm scrobbling support

Postby bdconnell » Sat Dec 26, 2009 10:01 pm

On my install the "plugins" folder was created automatically (I think). Try changing the name of your folder from "plugin" to "plugins", and restart the ps3ms. Dropping the scrobbler .jar file into the "plugins" directory is all you should need to do to enable it.

If the .jar file is being loaded by ps3ms, the "General Configuration" tab should now have a button under the Plugin header named "Last.fm scrobbler plugin for ps3mediaserver" that will allow you to set your last.fm username and password. Configuring your last.fm username and password should put the following lines in your ps3.conf file:

lastfm.scrobbler.user = <username>
lastfm.scrobbler.password = <password>

If that doesn't happen by using the configuration button, you can try putting the above lines directly in the ps3.conf file, which I believe is what I had to do. For me, the ps3ms server logs are showing that login is happening - but for some reason the actual scrobble calls do not seem to work.
bdconnell
 
Posts: 4
Joined: Sun Dec 20, 2009 3:04 pm

Re: Last.Fm scrobbling support

Postby EvilAaron » Sat Jan 02, 2010 8:41 pm

Thank-you for working on PS3MS last.fm scrobbling support. I have wanted this for a while and this almost works perfect for me.

Plugin installs fine and after entering sign in info in plugin options and rebooting PS3MS I get handshakes with last FM. "listening Now" displays on Last.fm profile correctly but for each single playthrough of a song it submits on average 3 - 6 plays to last.fm. I found it submits a play count of 1 to last.fm for each minute played of track through PS3MS. Resulting in very skewed stats.

Any known solution to this behavior?
EvilAaron
 
Posts: 4
Joined: Sat Apr 25, 2009 7:59 pm

Re: Last.Fm scrobbling support

Postby Snorfle » Mon Jan 11, 2010 1:06 am

Just wanted to report that I am also seeing this behavior, though it seems inconsistent. Sometimes I will see 2-3 scrobbles for one song, sometimes it works fine and I only get 1.
Snorfle
 
Posts: 10
Joined: Sat Apr 18, 2009 5:45 am

Re: Last.Fm scrobbling support

Postby stallman » Fri Jan 15, 2010 8:32 pm

aloha !

i'm using Java PS3 Media Server v1.10.51 on Java 1.6.0_17-Sun Microsystems Inc. @ OS Windows 7 x86 6.1
and my ps3ms have no any plugins directories
i've trying to create plugins and plugin directories and put LastFM plugin but he is not detected. What's wrong ?

that is my log
Code: Select all
[main] TRACE 23:24:33.167 Starting Java PS3 Media Server v1.10.51
[main] TRACE 23:24:33.169 by shagrath / 2008-2009
[main] TRACE 23:24:33.170 http://ps3mediaserver.blogspot.com
[main] TRACE 23:24:33.170 http://code.google.com/p/ps3mediaserver
[main] TRACE 23:24:33.170
[main] TRACE 23:24:33.170 Java 1.6.0_17-Sun Microsystems Inc.
[main] TRACE 23:24:33.172 OS Windows 7 x86 6.1
[main] TRACE 23:24:33.172 Encoding: Cp1251
[main] TRACE 23:24:33.216 Temp folder: C:\Users\stallman\AppData\Local\Temp\javaps3media
[main] TRACE 23:24:33.249 AVISynth not found! Transcoder profile AviSynth/FFmpeg will not be used!
[main] TRACE 23:24:33.250 Registering transcoding engine FFmpeg Audio
[main] TRACE 23:24:33.257 Registering transcoding engine MEncoder
[main] TRACE 23:24:33.258 AVISynth not found! Transcoder profile Avisynth/MEncoder will not be used!
[main] TRACE 23:24:33.258 Registering transcoding engine MPlayer Audio
[main] TRACE 23:24:33.259 Registering transcoding engine MEncoder Web
[main] TRACE 23:24:33.260 Registering transcoding engine MPlayer Video Dump
[main] TRACE 23:24:33.261 Registering transcoding engine MPlayer Web
[main] TRACE 23:24:33.264 Registering transcoding engine TsMuxer
[main] TRACE 23:24:33.264 Registering transcoding engine Audio High Fidelity
[main] TRACE 23:24:33.265 Executable of transcoder profile VideoLan Audio Streaming not found!
[main] TRACE 23:24:33.266 Executable of transcoder profile VideoLan Video Streaming not found!
[main] TRACE 23:24:33.266 Registering transcoding engine FFmpeg DVR-MS Remux
[main] TRACE 23:24:33.275 Registering transcoding engine Raws Thumbnailer
[main] TRACE 23:24:33.276 AviSynth in not installed ! You cannot use avsmencoder as transcoding engine !
[main] TRACE 23:24:33.695 Scanning network interface lo / Software Loopback Interface 1
[main] TRACE 23:24:33.697 Scanning network interface net0 / WAN Miniport (SSTP)
[main] TRACE 23:24:33.700 Scanning network interface net1 / WAN Miniport (IKEv2)
[main] TRACE 23:24:33.702 Scanning network interface net2 / WAN Miniport (L2TP)
[main] TRACE 23:24:33.705 Scanning network interface net3 / WAN Miniport (PPTP)
[main] TRACE 23:24:33.707 Scanning network interface ppp0 / WAN Miniport (PPPOE)
[main] TRACE 23:24:33.710 Scanning network interface eth0 / WAN Miniport (IPv6)
[main] TRACE 23:24:33.712 Scanning network interface eth1 / WAN Miniport (Network Monitor)
[main] TRACE 23:24:33.715 Scanning network interface eth2 / WAN Miniport (IP)
[main] TRACE 23:24:33.717 Scanning network interface ppp1 / RAS Async Adapter
[main] TRACE 23:24:33.720 Scanning network interface eth3 / null
[main] TRACE 23:24:33.723 Using address /192.168.0.2 found on network interface: name:eth3 () index: 11 addresses: /192.168.0.2;
[main] TRACE 23:24:33.723 Created socket: /192.168.0.2:5001
[Thread-5] TRACE 23:24:33.728 Starting DLNA Server on host 192.168.0.2 and port 5001...
[main] TRACE 23:24:33.732 Sending ALIVE...
[main] TRACE 23:24:33.761 Using following UUID: 5192e321-cf43-31de-937c-59d592a5186b
[Thread-5] TRACE 23:24:36.862 Receiving a request from: 192.168.0.3
[main] TRACE 23:24:39.177 It's ready! You should see the server appears on XMB
[Thread-15] TRACE 23:24:49.176 Sending ALIVE...


ps: sorry for my english :oops:
stallman
 
Posts: 2
Joined: Fri Jan 15, 2010 8:26 pm

Re: Last.Fm scrobbling support

Postby stallman » Fri Jan 15, 2010 8:47 pm

my bad )
1.10.51 not supported this feature ... :oops:
stallman
 
Posts: 2
Joined: Fri Jan 15, 2010 8:26 pm

Re: Last.Fm scrobbling support

Postby Biertrinker » Sun May 09, 2010 11:07 pm

Anyone tried getting it work with latest beta 1.20.409?
No chance to run it on my pc...
Biertrinker
 
Posts: 29
Joined: Sun Feb 21, 2010 11:05 pm

Re: Last.Fm scrobbling support

Postby Guris » Wed Jun 30, 2010 6:52 pm

Biertrinker wrote:Anyone tried getting it work with latest beta 1.20.409?
No chance to run it on my pc...

I have tried ... it definitely sends some info to Last.fm but evidently not correctly.
When I play some track I can see this track on my Last.fm profile with 'Listening now' text.
But when the track ends, it disappears from Last.fm.

Could anyone clarify to me if the plugin has to send some info after the end of the track? If so this could be the source of incorrect functionality...
Any sign of developement or fix attempt would be nice :?
Guris
 
Posts: 1
Joined: Wed Jun 30, 2010 6:42 pm

Re: Last.Fm scrobbling support

Postby fa_sol » Sun Aug 01, 2010 3:03 am

Hi,

i have some problem using the lastfm plugin in my PMS.
i have the last version of both pms and plugin. i unzipped the .jar in the plugins folder.

then i start my pms. in the trace window, everything start correctly, but the only thing about lastfm is :
[main] TRACE 03:47:42.185 Detected plugin net.pms.external.LastFMScrobbler

that's all.
even if i write mon login/pwd in the general configuration tab, to log into my lastfm account... no trace a activity of the plugin...
and if y listen to songs from my ps3, nothing appears on my lastfm page... not even "now listening".
i don't really understand what could cause this problem, so if anybody could help me on this way...

thanks for everything you developped anyway.

bye

r
fa_sol
 
Posts: 1
Joined: Sun Aug 01, 2010 2:56 am

Re: Last.Fm scrobbling support

Postby hullabaloo » Tue Oct 19, 2010 6:20 pm

having the same problem as the guy above me ^
hullabaloo
 
Posts: 1
Joined: Mon Sep 20, 2010 6:10 pm

PreviousNext

Return to Additions and Plugins

Who is online

Users browsing this forum: Yahoo [Bot] and 5 guests