Web content will not stream

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Re: Web content will not stream

Postby chocolateboy » Mon Jan 04, 2010 1:09 pm

lovswr wrote:chocolateboy, thank you, thank you, a thousand times thank you!


My pleasure :-)

lovswr wrote:I would warn that your script appears to be very strict in that it wants \/some\/path\/bin\/ps3mencoder... in that the end must be \/bin\/ps3mencoder.


Probably a permissions issue with your path e.g. your ~/bin is not readable or executable by PMS:

Code: Select all
chmod a+rx ~/bin


ps3mencoder doesn't care where it's located. On my system, it works fine under ~/bin/ps3mencoder.
chocolateboy
Project Member
 
Posts: 2580
Joined: Wed Sep 16, 2009 10:05 am

Re: Web content will not stream

Postby lovswr » Mon Jan 04, 2010 2:27 pm

chocoloateboy you are probably right about the path thing. I always seem to have problems with that.


Otomanix SOOL is scheisse out of luck. Nothing against you, it is that this problem has been so frustrating. I think chocoloatboys' thread should be made into a sticky.
lovswr
 
Posts: 31
Joined: Mon Jan 19, 2009 5:00 pm

Re: Web content will not stream

Postby ElimGarak » Mon Jan 04, 2010 4:02 pm

Sorry, chocolateboy... Is there some "procedure for dummies" to follow?
I got lost since "make it executable". ^_^
Thank you!
ElimGarak
 
Posts: 38
Joined: Mon Jan 19, 2009 10:54 am

Re: Web content will not stream

Postby pocho » Mon Jan 04, 2010 4:09 pm

ElimGarak wrote:Sorry, chocolateboy... Is there some "procedure for dummies" to follow?
I got lost since "make it executable". ^_^
Thank you!


+1
pocho
 
Posts: 20
Joined: Thu Dec 10, 2009 1:43 am

Re: Web content will not stream

Postby chocolateboy » Mon Jan 04, 2010 5:50 pm

UPDATE: For a quick solution to Web video streaming with PS3 Media Server go here and follow the instructions. For troubleshooting, discussion &c. read on, but bear in mind that this post, and most of the installation instructions in this thread, are obsolete.

---

(Please provide details - at the very least say what platform you're on.)

Assuming you're both on Windows, try this:

  1. download and install the latest version of Strawberry Perl
  2. open a console (cmd.exe) and type:
    Code: Select all
    cpan -i File::Which IO::All List::MoreUtils PAR::Packer
  3. convert the Perl script to an .exe:
    Code: Select all
    pp -o ps3mencoder.exe ps3mencoder
  4. Add the path to the .exe file to PMS.conf e.g. mencoder_path = C:\\Wherever\\ps3mencoder.exe
  5. Restart PMS &c.

If it works, please upload the .exe so others can download and use it without going through the first three steps.
Last edited by chocolateboy on Sun Jan 31, 2010 11:26 pm, edited 4 times in total.
chocolateboy
Project Member
 
Posts: 2580
Joined: Wed Sep 16, 2009 10:05 am

Re: Web content will not stream

Postby beagle » Mon Jan 04, 2010 9:39 pm

I have tried unsuccesfully to get this to work.

I had problems compiling the file as it came up with an error when trying to include Which and a couple of other files.

Can anyone compile and link to ps3mencoder.exe, please?

Also where is the PMS.conf file. I've searched and don't appear to have it.

I'm running on xp and PS3Mediaserver v1.11.369
beagle
 
Posts: 15
Joined: Fri Dec 18, 2009 10:25 am

Re: Web content will not stream

Postby ElimGarak » Tue Jan 05, 2010 3:32 am

I reached this point:
"pp -o ps3mencoder.exe ps3mencoder"

But then it tells me the command is not recognized.
I even tried opening a console window in C:\strawberry\perl\bin (after copying pmsencoder in that directory), executing perl.exe and typing the command but nothing happens.

Seems like I need a procedure for dummiERS. ^#__#^

P.S:
Yes, I use Windows XP SP3. Sorry! ^_^
ElimGarak
 
Posts: 38
Joined: Mon Jan 19, 2009 10:54 am

Re: Web content will not stream

Postby ElimGarak » Tue Jan 05, 2010 7:25 pm

Nobody can compile di EXE for us? :oops:
ElimGarak
 
Posts: 38
Joined: Mon Jan 19, 2009 10:54 am

Re: Web content will not stream

Postby chocolateboy » Wed Jan 06, 2010 1:06 am

Download ps3mencoder.exe and drop it in PS3 Media Server's win32 subdirectory alongside mencoder.exe e.g.

Code: Select all
C:\Program Files\PS3 Media Server\win32


Add the path to PMS.conf (e.g. C:\Program Files\PS3 Media Server\PMS.conf) - create the file/line if it doesn't exist:

Code: Select all
mencoder_path = C:\\Program Files\\PS3 Media Server\\win32\\ps3mencoder.exe


Restart PMS and move "MEncoder Web" to the top of the "Video Web Streaming Engines". Save the configuration (and possibly restart PMS).

If something goes wrong take a look at the PMS debug log and at the ps3mencoder logfile, which can be found in your temp directory e.g.

Code: Select all
C:\Documents and Settings\<username>\Local Settings\Temp\ps3mencoder.log


It's a standalone Windows .exe, so there's no need to download or install anything else. I've only tested it on XP.

Further updates to the .exe and the Perl script will be posted here.
Last edited by chocolateboy on Sat Jan 23, 2010 6:36 pm, edited 3 times in total.
chocolateboy
Project Member
 
Posts: 2580
Joined: Wed Sep 16, 2009 10:05 am

Re: Web content will not stream

Postby lovswr » Wed Jan 06, 2010 4:49 am

Well streaming from the web worked for me for about 20 minutes. Then my PS3 media server crashed on my pc. When I restarted it, under Video Web Streaming Engines, mencoder now has a red circle wtih the line through it! :( It's like the gods are conspiring against me! I tried uninstalling mencoder & ffmpeg to no avail.

What's totally crazy, is that mencoder works just fine on my system with any other program than PS3 Media Server. Anybody got any idea's?
lovswr
 
Posts: 31
Joined: Mon Jan 19, 2009 5:00 pm

PreviousNext

Return to General Help and Support

Who is online

Users browsing this forum: No registered users and 6 guests