Video Playing Too Fast on MKVs

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Video Playing Too Fast on MKVs

Postby drmarlin » Mon Oct 12, 2009 7:10 pm

Hi,

Symptom: MKVs made from MakeMKV play in PS3MS. Audio plays normally/correctly however the video plays at about 1.5x to 2x speed so everything is out of sync. I have replicated the problem on three different host/server computers and playback devices.

I have been making MKVs from all of my kids' DVDs and hope I don't have to start over/find an alternate approach (having already gone through about 100 DVDs with MakeMKV). I did some searching on the board and found some others reporting problems with videos playing too fast but was not able to find a resolution.

What I've tried:
- Disabling subtitles (don't want/need them anyways);
- Adding "-mc 0 -noskip" to mencoder command line arguments;
- Combinations of mencoder transcoding options

Help! :)

Server Setup #1 (Preferred Server/Host):
- PS3MS v1.11.363
- Windows Home Server (Windows Server 2003)
- RAM: 2GB
- CPU: 2.6Ghz AMD Athlon LE-1640 (Single Core)
- (Note that this is a headless unit without any onboard audio/video)

Server Setup #2:
- PS3MS v1.11.363
- Windows 7 32-bit
- RAM: 2GB
- CPU: 2.7Ghz AMD Athlon 64 X2 Dual Core (5200)

Server Setup #3:
- PS3MS v1.20 (r356)
- MAC OS X 10.6.1
- RAM: 2GB
- CPU: 2.8Ghz Intel Core 2 Duo

Streaming Devices (Duplicate Results on all 3):
- PS 3 (Firmware 3.01) (802.11g)
- Xbox 360 (100Mb Ethernet)
- HP MediaSmart SL4278N TV (802.11n)

Encoding Engine: mencoder

Sample MediaInfo from MKV file:
General
Complete name : \\HOMESERVER\Movies\Kids Movies\A Bug's Life\A Bug's Life.mkv
Format : Matroska
File size : 3.02 GiB
Duration : 1h 34mn
Overall bit rate : 4 547 Kbps
Encoded date : UTC 2009-10-11 23:17:11
Writing application : MakeMKV v1.4.8 beta darwin(x86-release)
Writing library : libmakemkv v1.4.8 beta (0.7.7/0.8.1) darwin(x86-release)

Video
ID : 1
Format : MPEG Video
Format version : Version 2
Format profile : Main@Main
Format settings, Matrix : Default
Codec ID : V_MPEG2
Codec ID/Info : MPEG 1 or 2 Video
Duration : 1h 34mn
Bit rate mode : Variable
Bit rate : 4 072 Kbps
Nominal bit rate : 9 800 Kbps
Width : 720 pixels
Height : 480 pixels
Display aspect ratio : 4:3
Frame rate : 29.970 fps
Standard : Component
Colorimetry : 4:2:0
Scan type : Progressive
Bits/(Pixel*Frame) : 0.393
Stream size : 2.70 GiB (89%)

Audio
ID : 2
Format : AC-3
Format/Info : Audio Coding 3
Codec ID : A_AC3
Duration : 1h 34mn
Bit rate mode : Constant
Bit rate : 384 Kbps
Channel(s) : 6 channels
Channel positions : Front: L C R, Surround: L R, LFE
Sampling rate : 48.0 KHz
Video delay : 7ms
Stream size : 261 MiB (8%)
Title : 3/2+1
Language : English

Text
ID : 3
Format : VobSub
Codec ID : S_VOBSUB
Codec ID/Info : The same subtitle format used on DVDs
Language : English

Menu
00:00:00.000 : en:Chapter 01
00:00:28.051 : en:Chapter 02
00:04:29.792 : en:Chapter 03
00:07:53.295 : en:Chapter 04
00:09:53.413 : en:Chapter 05
00:15:20.073 : en:Chapter 06
00:17:20.507 : en:Chapter 07
00:18:57.438 : en:Chapter 08
00:20:06.173 : en:Chapter 09
00:26:09.536 : en:Chapter 10
00:27:50.660 : en:Chapter 11
00:31:31.036 : en:Chapter 12
00:32:44.910 : en:Chapter 13
00:35:59.270 : en:Chapter 14
00:39:44.326 : en:Chapter 15
00:41:28.630 : en:Chapter 16
00:45:19.328 : en:Chapter 17
00:45:55.697 : en:Chapter 18
00:47:18.780 : en:Chapter 19
00:49:15.432 : en:Chapter 20
00:52:52.816 : en:Chapter 21
00:56:37.836 : en:Chapter 22
00:58:51.503 : en:Chapter 23
01:02:26.217 : en:Chapter 24
01:04:29.497 : en:Chapter 25
01:05:32.593 : en:Chapter 26
01:06:47.468 : en:Chapter 27
01:10:03.697 : en:Chapter 28
01:10:51.578 : en:Chapter 29
01:15:17.814 : en:Chapter 30
01:17:31.948 : en:Chapter 31
01:20:02.975 : en:Chapter 32
01:21:15.680 : en:Chapter 33
01:23:08.126 : en:Chapter 34
01:24:18.563 : en:Chapter 35
01:28:33.279 : en:Chapter 36
01:29:58.831 : en:Chapter 37

Debug (from Windows Home Server) attached.
Attachments
debug.zip
debug.log
(11.79 KiB) Downloaded 63 times
drmarlin
 
Posts: 7
Joined: Mon Sep 21, 2009 5:42 am

Re: Video Playing Too Fast on MKVs

Postby shagrath » Tue Oct 13, 2009 8:05 pm

could you try to disable "alternative sync", and put "-mc 0.1" in custom options ?
shagrath
Project Lead
 
Posts: 2667
Joined: Wed Jan 14, 2009 1:39 pm

Re: Video Playing Too Fast on MKVs

Postby drmarlin » Wed Oct 14, 2009 2:51 am

Unfortunately no discernible difference. Would incrementing the number help?
drmarlin
 
Posts: 7
Joined: Mon Sep 21, 2009 5:42 am

Re: Video Playing Too Fast on MKVs

Postby shagrath » Wed Oct 14, 2009 9:47 pm

don't think so
but actually without subtitles, it shouldn't transcode at all, just remux, so any mencoder options will not have any effect
try to disable the "switch to tsmuxer" option
shagrath
Project Lead
 
Posts: 2667
Joined: Wed Jan 14, 2009 1:39 pm

Re: Video Playing Too Fast on MKVs

Postby drmarlin » Wed Oct 21, 2009 3:54 am

I've tried a clean install of PS3MS and disabled the "switch to tsmuxer" option.

Unfortunately no effect with the same MKV. Same symptoms with the audio playing at normal speed and video in high-speed (out of sync).

:(
drmarlin
 
Posts: 7
Joined: Mon Sep 21, 2009 5:42 am

Re: Video Playing Too Fast on MKVs

Postby esprit » Thu Apr 01, 2010 6:37 pm

Hi,

Is there any news on this problem ?

I am confronting a similar one with one mkv.
Looking at the debug.log, i have done some tests with mencoder and mplayer as client, I found out that
the options that was causing problems are "-fps 50 -ofps 50" (perhaps because they are mixed with another
option that is causing the video playing two times faster than it should, but the fact is when removed, the
video is playing at the correct speed).

Mencoder command line is :
mencoder -ss 0 -quiet /data/mymovie.mkv -quiet -quiet -oac lavc -of mpeg -quiet -quiet -mpegopts format=mpeg2:muxrate=500000:vbuf_size=1194:abuf_size=64 -ovc lavc -channels 6 -lavdopts debug=0:threads=2 -lavcopts autoaspect=1:vcodec=mpeg2video:acodec=ac3:abitrate=640:threads=2:keyint=1:vqscale=1:vqmin=2 -subcp cp1252 -subfont /usr/share/fonts/truetype/msttcorefonts/Arial.ttf -subfont-text-scale 3 -subfont-outline 1 -subfont-blur 1 -subpos 98 -quiet -quiet -sid 100 -fps 50 -ofps 50 -sub /data/mymovie 2.sub -mc 0 -noskip -af lavcresample=48000 -srate 48000 -o /tmp/javaps3media/mencoder1270142766611

(by the way, it seems that there is a bug in the Subtitle finding routines, which associates "mymovie 2.sub" with "mymovie.mkv", but i will fill a bug report after more testing on this point)

The mkv is @25fps (that the only one I have at this framerate).

Is there a way to avoid those two options to be used ?

Hope this helps.

By the way, as it is my first post in this forum : thanks for this great piece of software ! ;)
esprit
 
Posts: 3
Joined: Thu Apr 01, 2010 6:10 pm

Re: Video Playing Too Fast on MKVs

Postby ultratoto14 » Fri Apr 02, 2010 8:45 am

There's a bug in TSMuxer.
TSmuxer takes a value in the h264 header named timebase. Previously, this value was set by x264 to the framerate. But on recent release,it is at the right value : 90000 (means timebase 1/90000s).
Tsmuxer takes this value to set the ts framerate 90000.

Try to check 'Force framerate parsed from FFMpeg' in the tsMuxer configuration panel and tell me if it helps
ultratoto14
 
Posts: 33
Joined: Wed Mar 04, 2009 2:09 pm

Re: Video Playing Too Fast on MKVs

Postby esprit » Fri Apr 02, 2010 6:45 pm

Are you answering me or the initial poster ?
Cause in my case I'm not using tsmuxer but mencoder (because the MKV has subtitles in it, so i have to transcode).
And the option is already checked.
esprit
 
Posts: 3
Joined: Thu Apr 01, 2010 6:10 pm

Re: Video Playing Too slow on MKVs

Postby rh58610 » Fri Apr 02, 2010 7:14 pm

Hello,
i have read all your possible answers , about video playing too fast on mkv's.
my problem is that, if i play a mkv move, video is going too slow,,,,,, it looks like slowmotion.
if i stream a normal mpg there s no problem at all.
but, when i dont use the transcode, everything works normal, i have to transcode while i nead the dutch subtitles,
only the mkv's giving trouble,
any suggestions??? all comment is welcome,
grt rene
rh58610
 
Posts: 1
Joined: Fri Apr 02, 2010 7:04 pm

Re: Video Playing Too Fast on MKVs

Postby anachron » Fri Apr 09, 2010 11:13 pm

esprit:
I have the same problem you're experiencing. After a lot of research (triggered by your findings) I have concluded that it is a bug in ffmpeg. I have confirmed a previously filed bug over at their place (https://roundup.ffmpeg.org/issue1756).

You can work around the bug (well, atleast I can) by adding this to the "Transcoding options -> MEncoder -> Expert Settings" dialog:
Code: Select all
container == matroska && framerate == 50 :: -fps 25 -ofps 25



This is my first post here. Thanks for making this great program!
anachron
 
Posts: 1
Joined: Fri Apr 09, 2010 10:59 pm

Next

Return to General Help and Support

Who is online

Users browsing this forum: Yahoo [Bot] and 22 guests