setting max bandwidth not working

For help and support with issues specific to Mac OS X
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

setting max bandwidth not working

Postby shawndre » Thu Jan 29, 2009 2:08 am

I set the maximum bandwidth to 15mbps and have the streaming quality set at "good quality for hd wifi transcoding.

when i play a movie it will sometimes go over the 15mbps limit all the way up past 50mbps causing the video to start stuttering. how do i fix this?

thank you

-Andre
shawndre
 
Posts: 9
Joined: Wed Jan 21, 2009 11:18 pm

Re: setting max bandwidth not working

Postby StainlessBanner » Sat Jan 31, 2009 7:12 am

I'm having the same spiking issues with no way to control it.
StainlessBanner
 
Posts: 2
Joined: Sat Jan 31, 2009 7:10 am

Re: setting max bandwidth not working

Postby Joksi » Sat Jan 31, 2009 10:15 am

The only way to have the limit beeing held is to have a CPU that can handle it, the lower profile the bigger chance. As you limit higher bitrate videos it will get harder and harder for your CPU.
Joksi
 
Posts: 146
Joined: Sun Jan 18, 2009 11:32 pm

Re: setting max bandwidth not working

Postby shagrath » Sat Jan 31, 2009 11:24 am

if your transcode buffer is empty, that has nothing to do with bandwidth issue... it's your cpu who can't handle real time encoding under 15mbps
shagrath
Project Lead
 
Posts: 2668
Joined: Wed Jan 14, 2009 1:39 pm

Re: setting max bandwidth not working

Postby StainlessBanner » Sun Feb 01, 2009 3:14 am

My buffer is over half full and I'm running an Intel Core2Duo with 2GB of RAM. I'm still getting the fluctuations.
StainlessBanner
 
Posts: 2
Joined: Sat Jan 31, 2009 7:10 am

Re: setting max bandwidth not working

Postby shagrath » Sun Feb 01, 2009 11:48 am

ok, try playing with the quality setting:

put keyint=25:vqscale=3 for example, or keyint=50:vqscale=3

the greater the keyint value is, the more stable the bitrate should be
shagrath
Project Lead
 
Posts: 2668
Joined: Wed Jan 14, 2009 1:39 pm

Re: setting max bandwidth not working

Postby Joksi » Sun Feb 01, 2009 11:53 am

How much and on what does the keyint affect?
Joksi
 
Posts: 146
Joined: Sun Jan 18, 2009 11:32 pm

Re: setting max bandwidth not working

Postby shagrath » Sun Feb 01, 2009 12:51 pm

Joksi wrote:How much and on what does the keyint affect?


small values (1-10): faster encoding but more bitrate (and more variations)
hugh values (50-250): slower encoding but more accurate bitrate control. I suggest not going higher than 50, cause the streaming mechanism in pms will not work really well
shagrath
Project Lead
 
Posts: 2668
Joined: Wed Jan 14, 2009 1:39 pm

Re: setting max bandwidth not working

Postby Joksi » Sun Feb 01, 2009 4:25 pm

Okey, so a value of 25,1,1 would not suffer on the quality?
Joksi
 
Posts: 146
Joined: Sun Jan 18, 2009 11:32 pm

Re: setting max bandwidth not working

Postby shagrath » Sun Feb 01, 2009 5:25 pm

Joksi wrote:Okey, so a value of 25,1,1 would not suffer on the quality?


it will be the same if you do not restrain the max bitrate too much
shagrath
Project Lead
 
Posts: 2668
Joined: Wed Jan 14, 2009 1:39 pm


Return to Mac OS X Support

Who is online

Users browsing this forum: Google [Bot] and 5 guests