MKV playback with external Subs

For help and support with issues specific to Mac OS X
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

MKV playback with external Subs

Postby cheule » Thu Aug 13, 2009 8:07 am

I'm playing 1080p mkv content (H264) with external subtitles (they are contained in the mkv wrapper, but not hardcoded in the video stream).

It's working fine. No problems, no errors, looks great. So what's the problem? My Mac simply can't transcode fast enough to keep up with realtime playback. If I pause the playback, the buffer eventually fills on PMS (it's set to 400MB default) and will then play for quite a while, but eventually the buffer empties and the video playback stutters until I pause it again.

I have a kickin' Mac serving it up too, so I'm not sure what else I can do to get it to transcode faster. It's a 2009 Intel Mini Mac, 2.4ghz Core 2 duo with 4GB ram, on gigabit ethernet through a Time Capsule (gigabit) to PS3. The mini is only used as a media server, and is running no other software besides PMS.

I've tried the various video quality presets, from Lossless all the way to the lowest. None of them can keep up. Oddly, I've noticed from both the PS3's video bit rate readout as well as PMS's bit rate readout on the status tab that the video bit rate nearly doubles when subtitle encoding is on. I'm not sure why that would be.

Any thoughts, ideas? Anyone get their Mac to actually encode fast enough? Note that my CPUs are NOT pegged when it's transcoding. Which is even more frustrating. It's not like the machine is maxed out CPU-wise. And yes, I have PMS set to 2 cores for Mencoder as well as "experimental multicore build."
cheule
 
Posts: 134
Joined: Wed Jun 24, 2009 4:18 am

Re: MKV playback with external Subs

Postby cheule » Wed Oct 07, 2009 2:20 am

As a follow up to my own post:

Pranck found a solution to my problem: viewtopic.php?f=7&t=3610#p17042
Pranck wrote:I have selected 4 numbers of cores for transcoding (even though i have two).
It utilizes much more % of the processor this way. I was able to play a 1080p file normally.
cheule
 
Posts: 134
Joined: Wed Jun 24, 2009 4:18 am


Return to Mac OS X Support

Who is online

Users browsing this forum: Yahoo [Bot] and 3 guests