Pausing at the end of playback

For help and support with issues specific to Mac OS X
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Pausing at the end of playback

Postby Nuurd » Sat Aug 08, 2009 5:49 am

Hello, I hope this isn't a repeat question. I searched around a bit and found references to this issue, but couldn't find any real discussion on it.

I've downloaded and have been using PMS for a few days now, and it's a great program. Streams to my PS3 very easily, and I'm quite happy. My only problem is that at the end of the file, the playback pauses and cannot be unpaused. This can happen as much as 8 seconds (in my experience) from the end of the file, as reported by the PS3. Is this some kind of setting, and can I disable it? Ideally playback would end, and I'd go back to the file listing in the PS3 interface.

On a similar note, I find that if I exit the program (when it's paused in the state described above) with the "back" (circle?) button on the PS3 remote, that it leaves an encoding process running, but not if I exit with the "stop" button. Is this also configurable somewhere?

Thanks for your time and help!
Nuurd
 
Posts: 6
Joined: Sat Aug 08, 2009 5:40 am

Re: Pausing at the end of playback

Postby cheule » Wed Aug 12, 2009 6:07 am

This seems like it might be a bug, it's been reported several times in the beta thread. Haven't seen the bug myself however, so maybe it's conditional on some other setup or situation.
cheule
 
Posts: 134
Joined: Wed Jun 24, 2009 4:18 am

Re: Pausing at the end of playback

Postby Nuurd » Wed Aug 12, 2009 6:14 am

I see, I guess I didn't find that discussion in searches -- my bad. Thanks for the info :)
Nuurd
 
Posts: 6
Joined: Sat Aug 08, 2009 5:40 am

Re: Pausing at the end of playback

Postby cheule » Wed Aug 12, 2009 6:18 am

Actually, I can't find the other posts about this either... but I know this has been reported before. I recall someone else reporting exactly what you did, the video pausing 8 sec before the end, and a zombie process created when you "circle" out of the video.

I'll watch for this behavior on my end. This is with mkvs only right?
cheule
 
Posts: 134
Joined: Wed Jun 24, 2009 4:18 am

Re: Pausing at the end of playback

Postby Nuurd » Wed Aug 12, 2009 7:08 am

I'm not positive that it's MKV only, but MKV is pretty much all I've been streaming. I can't test it with a non-MKV at the moment because the software has picked right this minute to stop talking to the PS3 at all. Figures.

Thanks for your help!
Nuurd
 
Posts: 6
Joined: Sat Aug 08, 2009 5:40 am

Re: Pausing at the end of playback

Postby cheule » Wed Aug 12, 2009 7:46 pm

Why don't you post some data on your setup. Everything you got, Computer type, OS, Ver of PMS, type of connection, etc.

Did some testing of my own on mkvs, couldn't get it to pause or create zombie processes.
cheule
 
Posts: 134
Joined: Wed Jun 24, 2009 4:18 am

Re: Pausing at the end of playback

Postby Nuurd » Thu Aug 13, 2009 2:08 am

I'm running on an original Intel iMac (3.5 years old, 2.0 GHz Core Duo, 2GB RAM), on the latest OS X 10.5, with the most-recently-posted OS X beta build of PMS. My previously referenced connection issues seem to have been transient, having to do with my connection path. While I had originally been connecting via the PS3 wireless, at some point I had shifted to having the PS3 connected via CAT6 to one of my wireless access points. This was giving me better performance. Why? I don't know, but it was working. Apparently that was no longer working properly, so I just ran a length of CAT6 from the next room to the PS3, so now the PS3 is connected in a solely wired fashion to the iMac and PMS and the PS3 can talk without problem. I will test non-MKV files tonight to see if they pause.

Thanks for your attention and your testing!
Nuurd
 
Posts: 6
Joined: Sat Aug 08, 2009 5:40 am

Re: Pausing at the end of playback

Postby cheule » Thu Aug 13, 2009 7:34 am

Running the latest beta (as you are) is a good idea. As well as moving to a wired connection. Many issues stem from wireless connectivity. Let's face it; HD video doesn't fit over a 10Mbit connection well. And don't believe the hype about 802.11g/n being 54Mbit or faster. It turns out that those speeds are only ever achieved if the client and AP are within 10' or so. At distances that close, might as well run a gigabit cable, eh?

P.S., Oh and just because I think it's interesting how market hype works... 802.11g is called 54Mbit, but that includes error correction data which is irrelevant to throughput. Turns out actual throughput it around 20Mbit on 802.11g as a best case scenario.
cheule
 
Posts: 134
Joined: Wed Jun 24, 2009 4:18 am

Re: Pausing at the end of playback

Postby cheule » Mon Aug 17, 2009 6:37 pm

Good news for you, bad news for the latest beta, I have some mkvs that do what you describe. They stop playback at around 10 sec before the end of the file.
cheule
 
Posts: 134
Joined: Wed Jun 24, 2009 4:18 am

Re: Pausing at the end of playback

Postby Nuurd » Mon Aug 17, 2009 6:39 pm

Gah, sorry. I guess I jinxed it ;)
Nuurd
 
Posts: 6
Joined: Sat Aug 08, 2009 5:40 am

Next

Return to Mac OS X Support

Who is online

Users browsing this forum: No registered users and 1 guest

cron