Mencoder crashes when transcoding 1080p MKV's

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Mencoder crashes when transcoding 1080p MKV's

Postby eruarg » Thu Jul 09, 2009 6:58 pm

System info:

CPU: Intel E8500 @ 3,16 GHz
Memory: 4 GB
PMS version: 1.10.51
Engine: Mencoder
OS: Win Vista x64

When I transcode hi-res movies, such as 1080p, Mencoder crashes for no apparent reason. This is what the log tells me:

[win32/mencoder_mt.exe] TRACE 19:20:59.934 Process C:\Program Files (x86)\PS3 \PS3 Media Server\win32\mencoder_mt.exe has a return code of -1073741819! Maybe an error occured... check the log file

The crashes are completely random and the buffer is always full. I'm suspicious that this may be related to the high bitrates (often up to 150 Mbit/s) that my network can't handle, I'm wired with 100 Mbit/s. I've tried to lower the maximum bandwidth to 70, yet it sometimes bursts up to 100+ during certain scenes. Is this caused by the high bitrate or is it something else (seeing as 720p and other low-res movies works fine, I'm kind of certain it's the bitrate that casuses this)? If so, the best solution would be to upgrade to a gigabit connection, right?
eruarg
 
Posts: 5
Joined: Thu Jul 09, 2009 6:39 pm

Re: Mencoder crashes when transcoding 1080p MKV's

Postby shagrath » Thu Jul 09, 2009 8:32 pm

check the debug.log (viewtopic.php?f=6&t=496 ), maybe there's something more in it
shagrath
Project Lead
 
Posts: 2668
Joined: Wed Jan 14, 2009 1:39 pm

Re: Mencoder crashes when transcoding 1080p MKV's

Postby NaweG » Thu Jul 09, 2009 8:47 pm

eruarg wrote:When I transcode hi-res movies, such as 1080p, Mencoder crashes for no apparent reason. This is what the log tells me:

[win32/mencoder_mt.exe] TRACE 19:20:59.934 Process C:\Program Files (x86)\PS3 \PS3 Media Server\win32\mencoder_mt.exe has a return code of -1073741819! Maybe an error occured... check the log file


By any chance do these MKVs have subtitles? If so, you may be running into a problem I had where sometimes the subtitle is left as the default "Unknown" or "unk", and the default mencoder dies on that. Fix then is to add "unk" as an option in your list of which subtitles to use.
User avatar
NaweG
 
Posts: 39
Joined: Sun Jun 21, 2009 7:37 pm
Location: San Antonio, TX

Re: Mencoder crashes when transcoding 1080p MKV's

Postby eruarg » Fri Jul 10, 2009 12:56 am

shagrath wrote:check the debug.log (viewtopic.php?f=6&t=496 ), maybe there's something more in it


I hope someone can make sense out of this :)

Code: Select all
[Thread-13] DEBUG 01:44:56.598 Receiving a NOTIFY from [192.168.0.1:1900]
[Thread-13] DEBUG 01:44:56.599 Receiving a NOTIFY from [192.168.0.1:1900]
[Thread-13] DEBUG 01:44:56.600 Receiving a NOTIFY from [192.168.0.1:1900]
[Thread-13] DEBUG 01:44:56.600 Receiving a NOTIFY from [192.168.0.1:1900]
[Thread-13] DEBUG 01:44:56.601 Receiving a NOTIFY from [192.168.0.1:1900]
[Thread-13] DEBUG 01:44:56.602 Receiving a NOTIFY from [192.168.0.1:1900]
[Thread-13] DEBUG 01:44:56.603 Receiving a NOTIFY from [192.168.0.1:1900]
[Thread-13] DEBUG 01:44:56.604 Receiving a NOTIFY from [192.168.0.1:1900]
[Thread-13] DEBUG 01:44:56.605 Receiving a NOTIFY from [192.168.0.1:1900]
[Thread-13] DEBUG 01:44:56.606 Receiving a NOTIFY from [192.168.0.1:1900]
[Timer-49] DEBUG 01:44:57.706 Buffered Space: 411858944 bytes / inputs: 1
[Timer-49] DEBUG 01:44:59.706 Buffered Space: 410583040 bytes / inputs: 1
[Timer-49] DEBUG 01:45:01.706 Buffered Space: 402718720 bytes / inputs: 1
[Timer-49] DEBUG 01:45:03.706 Buffered Space: 395935744 bytes / inputs: 1
[Timer-49] DEBUG 01:45:05.706 Buffered Space: 388628480 bytes / inputs: 1
[Timer-49] DEBUG 01:45:07.707 Buffered Space: 381681664 bytes / inputs: 1
[Timer-49] DEBUG 01:45:09.707 Buffered Space: 372572160 bytes / inputs: 1
[Timer-49] DEBUG 01:45:11.707 Buffered Space: 360841216 bytes / inputs: 1
[Thread-12] TRACE 01:45:12.872 Sending ALIVE...
[Thread-12] DEBUG 01:45:12.872 Searching network interface for 192.168.0.5
[Thread-12] DEBUG 01:45:12.962 Sending message from multicast socket on network interface: name:eth3 (Realtek RTL8168B/8111B Family PCI-E Gigabit Ethernet NIC (NDIS 6.0)) index: 10 addresses:
/192.168.0.5;

[Thread-12] DEBUG 01:45:12.962 Multicast socket is on interface: /192.168.0.5
[Thread-12] DEBUG 01:45:12.962 Socket Timeout: 0
[Thread-12] DEBUG 01:45:12.962 Socket TTL: 32
[Thread-13] DEBUG 01:45:12.963 Receiving a NOTIFY from [192.168.0.5:57378]
[Thread-13] DEBUG 01:45:13.136 Receiving a NOTIFY from [192.168.0.5:57378]
[Timer-49] DEBUG 01:45:13.707 Buffered Space: 350289920 bytes / inputs: 1
[Thread-13] DEBUG 01:45:13.791 Receiving a NOTIFY from [192.168.0.5:57378]
[Thread-13] DEBUG 01:45:14.298 Receiving a NOTIFY from [192.168.0.5:57378]
[Thread-13] DEBUG 01:45:14.740 Receiving a NOTIFY from [192.168.0.5:57378]
[Thread-13] DEBUG 01:45:14.744 Receiving a NOTIFY from [192.168.0.5:57378]
[Thread-13] DEBUG 01:45:15.100 Receiving a NOTIFY from [192.168.0.5:57378]
[Thread-13] DEBUG 01:45:15.224 Receiving a NOTIFY from [192.168.0.5:57378]
[Timer-49] DEBUG 01:45:15.707 Buffered Space: 334856192 bytes / inputs: 1
[Thread-13] DEBUG 01:45:16.081 Receiving a NOTIFY from [192.168.0.5:57378]
[Thread-13] DEBUG 01:45:16.146 Receiving a NOTIFY from [192.168.0.5:57378]
[Thread-487] DEBUG 01:45:16.427 EOF
[win32/mencoder_mt.exe] DEBUG 01:45:16.434 EOF
[win32/mencoder_mt.exe] TRACE 01:45:16.434 Process C:\Program Files (x86)\PS3 Media Server Beta\PS3 Media Server\win32\mencoder_mt.exe has a return code of -1073741819! Maybe an error occured... check the log file
[Thread-494] DEBUG 01:45:16.707 Opened handler on socket Socket[addr=/192.168.0.29,port=58831,localport=5001]
[Thread-494] DEBUG 01:45:16.707 Received on socket: GET /description/fetch HTTP/1.1
[Thread-494] DEBUG 01:45:16.707 Received on socket: Host: 192.168.0.5:5001
[Thread-494] DEBUG 01:45:16.707 Received on socket: Date: Fri, 10 Jul 2009 00:43:58 GMT
[Thread-494] DEBUG 01:45:16.707 Received on socket: User-Agent: UPnP/1.0
[Thread-494] DEBUG 01:45:16.707 Received on socket: X-AV-Client-Info: av=5.0; cn="Sony Computer Entertainment Inc."; mn="PLAYSTATION 3"; mv="1.0";
[Thread-494] INFO  01:45:16.715 HTTP: description/fetch / 0-0
[Thread-494] DEBUG 01:45:16.715 Wrote on socket: HTTP/1.1 200 OK
[Thread-494] DEBUG 01:45:16.715 Wrote on socket: Content-Type: text/xml
[Thread-494] DEBUG 01:45:16.715 Wrote on socket: Cache-Control: no-cache
[Thread-494] DEBUG 01:45:16.715 Wrote on socket: Expires: 0
[Thread-494] DEBUG 01:45:16.715 Wrote on socket: Accept-Ranges: bytes
[Thread-494] DEBUG 01:45:16.715 Wrote on socket: Connection: keep-alive
[Thread-494] DEBUG 01:45:16.721 Wrote on socket: Server: Windows_Vista-x86-6.0, UPnP/1.0, PMS/1.10.51
[Thread-494] DEBUG 01:45:16.721 Available Content-Length: 1777
[Thread-494] DEBUG 01:45:16.721 Wrote on socket: Content-Length: 1777
[Thread-494] DEBUG 01:45:16.721 Wrote on socket:
[Thread-494] DEBUG 01:45:16.721 Sending stream: 1777 bytes of description/fetch
[Thread-494] DEBUG 01:45:16.721 Close Connection
[Timer-49] DEBUG 01:45:17.707 Buffered Space: 325124096 bytes / inputs: 1
[Timer-49] DEBUG 01:45:19.707 Buffered Space: 315916288 bytes / inputs: 1
[Timer-49] DEBUG 01:45:21.708 Buffered Space: 300810240 bytes / inputs: 1
[Timer-49] DEBUG 01:45:23.708 Buffered Space: 284229632 bytes / inputs: 1
[Timer-49] DEBUG 01:45:25.708 Buffered Space: 275841024 bytes / inputs: 1
[Timer-49] DEBUG 01:45:27.708 Buffered Space: 260112384 bytes / inputs: 1
[Timer-49] DEBUG 01:45:29.708 Buffered Space: 253820928 bytes / inputs: 1
[Timer-49] DEBUG 01:45:31.708 Buffered Space: 242221056 bytes / inputs: 1
[Timer-49] DEBUG 01:45:33.708 Buffered Space: 231833600 bytes / inputs: 1
[Timer-49] DEBUG 01:45:35.708 Buffered Space: 225837056 bytes / inputs: 1
[Timer-49] DEBUG 01:45:37.709 Buffered Space: 216072192 bytes / inputs: 1
[Timer-49] DEBUG 01:45:39.709 Buffered Space: 205586432 bytes / inputs: 1
[Timer-49] DEBUG 01:45:41.709 Buffered Space: 188874752 bytes / inputs: 1
[Timer-49] DEBUG 01:45:43.709 Buffered Space: 177307648 bytes / inputs: 1
[Timer-49] DEBUG 01:45:45.709 Buffered Space: 161185792 bytes / inputs: 1
[Timer-49] DEBUG 01:45:47.709 Buffered Space: 145227776 bytes / inputs: 1
[Timer-49] DEBUG 01:45:49.709 Buffered Space: 132251648 bytes / inputs: 1
[Timer-49] DEBUG 01:45:51.710 Buffered Space: 121700352 bytes / inputs: 1
[Timer-49] DEBUG 01:45:53.710 Buffered Space: 106168320 bytes / inputs: 1
[Timer-49] DEBUG 01:45:55.710 Buffered Space: 89817088 bytes / inputs: 1
[Thread-13] DEBUG 01:45:56.636 Receiving a NOTIFY from [192.168.0.1:1900]
[Thread-13] DEBUG 01:45:56.637 Receiving a NOTIFY from [192.168.0.1:1900]
[Thread-13] DEBUG 01:45:56.638 Receiving a NOTIFY from [192.168.0.1:1900]
[Thread-13] DEBUG 01:45:56.639 Receiving a NOTIFY from [192.168.0.1:1900]
[Thread-13] DEBUG 01:45:56.640 Receiving a NOTIFY from [192.168.0.1:1900]
[Thread-13] DEBUG 01:45:56.641 Receiving a NOTIFY from [192.168.0.1:1900]
[Thread-13] DEBUG 01:45:56.642 Receiving a NOTIFY from [192.168.0.1:1900]
[Thread-13] DEBUG 01:45:56.643 Receiving a NOTIFY from [192.168.0.1:1900]
[Thread-13] DEBUG 01:45:56.644 Receiving a NOTIFY from [192.168.0.1:1900]
[Thread-13] DEBUG 01:45:56.645 Receiving a NOTIFY from [192.168.0.1:1900]
[Timer-49] DEBUG 01:45:57.710 Buffered Space: 73596928 bytes / inputs: 1
[Timer-49] DEBUG 01:45:59.710 Buffered Space: 65667072 bytes / inputs: 1
[Timer-49] DEBUG 01:46:01.710 Buffered Space: 57769984 bytes / inputs: 1
[Timer-49] DEBUG 01:46:03.710 Buffered Space: 46858240 bytes / inputs: 1
[Timer-49] DEBUG 01:46:05.710 Buffered Space: 36765696 bytes / inputs: 1
[Timer-49] DEBUG 01:46:07.711 Buffered Space: 30474240 bytes / inputs: 1
[Timer-49] DEBUG 01:46:09.711 Buffered Space: 24182784 bytes / inputs: 1
[Timer-49] DEBUG 01:46:11.711 Buffered Space: 16842752 bytes / inputs: 1
[Timer-49] DEBUG 01:46:13.711 Buffered Space: 9502720 bytes / inputs: 1
[Timer-49] DEBUG 01:46:15.711 Buffered Space: 2490368 bytes / inputs: 1
[Thread-485] DEBUG 01:46:16.036 Ready to Stop: true
[Thread-485] DEBUG 01:46:16.036 Sending stream: -1909227520 bytes of get/0$0$1$1$29/movie.mkv
[Thread-485] DEBUG 01:46:16.036 Close Connection
[Timer-49] DEBUG 01:46:17.711 Buffered Space: 2385707008 bytes / inputs: 0
[Thread-497] DEBUG 01:46:18.468 Opened handler on socket Socket[addr=/192.168.0.29,port=58827,localport=5001]
[Thread-497] DEBUG 01:46:18.468 Received on socket: GET /get/0$0$1$1$29/thumbnail0000movie.mkv HTTP/1.1
[Thread-497] DEBUG 01:46:18.468 Received on socket: Host: 192.168.0.5:5001
[Thread-497] DEBUG 01:46:18.468 Received on socket: User-Agent: PLAYSTATION 3
[Thread-497] DEBUG 01:46:18.474 Received on socket: Connection: Keep-Alive
[Thread-497] DEBUG 01:46:18.474 Received on socket: Accept-Encoding: identity
[Thread-497] DEBUG 01:46:18.474 Received on socket: transferMode.dlna.org: Interactive
[Thread-497] INFO  01:46:18.474 HTTP: get/0$0$1$1$29/thumbnail0000movie.mkv / 0-0
[Thread-497] DEBUG 01:46:18.474 Wrote on socket: HTTP/1.1 200 OK
[Thread-497] DEBUG 01:46:18.474 Searching for objectId: 0$0$1$1$29 with children option: false
[Thread-497] DEBUG 01:46:18.474 Wrote on socket: Content-Type: image/png
[Thread-497] DEBUG 01:46:18.474 Wrote on socket: Accept-Ranges: bytes
[Thread-497] DEBUG 01:46:18.474 Wrote on socket: Expires: Mon, 02 Nov 2009 17:32:58 GMT
[Thread-497] DEBUG 01:46:18.474 Wrote on socket: Connection: keep-alive
[Thread-497] DEBUG 01:46:18.474 Wrote on socket: Server: Windows_Vista-x86-6.0, UPnP/1.0, PMS/1.10.51
[Thread-497] DEBUG 01:46:18.474 Available Content-Length: 673
[Thread-497] DEBUG 01:46:18.474 Wrote on socket: Content-Length: 673
[Thread-497] DEBUG 01:46:18.474 Wrote on socket:
[Thread-497] DEBUG 01:46:18.474 Sending stream: 673 bytes of get/0$0$1$1$29/thumbnail0000movie.mkv
[Thread-497] DEBUG 01:46:18.474 Close Connection
[Thread-495] INFO  01:46:18.536 Stopping process: win32/mencoder_mt.exe
[Thread-496] INFO  01:46:18.536 Stopping process: win32/mencoder_mt.exe
[Thread-496] INFO  01:46:18.536 Destroying buffer
[Thread-495] INFO  01:46:18.536 Destroying buffer
eruarg
 
Posts: 5
Joined: Thu Jul 09, 2009 6:39 pm

Re: Mencoder crashes when transcoding 1080p MKV's

Postby Barbastark » Thu Jul 16, 2009 10:29 am

I have the same problem, does anyone know the solution?
Seems to me it crasher only on 1080p wit external subs

Debug log:
[Thread-98] DEBUG 00:02:43.375 Resume Read: readCount=298745856 / writeCount=299630592
[Thread-98] DEBUG 00:02:43.468 Ready to Stop: true
[Thread-98] DEBUG 00:02:43.593 Sending stream: 299663360 bytes of get/0$4$2$11$1$0$0/japhson-saints.mkv
[Thread-98] DEBUG 00:02:43.593 Close Connection
[Thread-109] DEBUG 00:02:44.170 Opened handler on socket Socket[addr=/192.168.0.100,port=53037,localport=5001]
[Thread-109] DEBUG 00:02:44.170 Received on socket: GET /get/0$4$2$11$1$0$0/thumbnail0000japhson-saints.mkv HTTP/1.1
[Thread-109] DEBUG 00:02:44.170 Received on socket: Host: 192.168.0.102:5001
[Thread-109] DEBUG 00:02:44.170 Received on socket: User-Agent: PLAYSTATION 3
[Thread-109] DEBUG 00:02:44.217 Received on socket: Connection: Keep-Alive
[Thread-109] DEBUG 00:02:44.217 Received on socket: Accept-Encoding: identity
[Thread-109] DEBUG 00:02:44.217 Received on socket: transferMode.dlna.org: Interactive
[Thread-109] INFO 00:02:44.217 HTTP: get/0$4$2$11$1$0$0/thumbnail0000japhson-saints.mkv / 0-0
[Thread-109] DEBUG 00:02:44.217 Wrote on socket: HTTP/1.1 200 OK
[Thread-109] DEBUG 00:02:44.217 Searching for objectId: 0$4$2$11$1$0$0 with children option: false
[Thread-109] DEBUG 00:02:44.217 Wrote on socket: Content-Type: image/png
[Thread-109] DEBUG 00:02:44.217 Wrote on socket: Accept-Ranges: bytes
[Thread-109] DEBUG 00:02:44.217 Wrote on socket: Expires: Mon, 09 Nov 2009 15:49:24 GMT
[Thread-109] DEBUG 00:02:44.217 Wrote on socket: Connection: keep-alive
[Thread-109] DEBUG 00:02:44.217 Wrote on socket: Server: Windows_XP-x86-5.1, UPnP/1.0, PMS/1.10.51
[Thread-109] DEBUG 00:02:44.217 Available Content-Length: 1961
[Thread-109] DEBUG 00:02:44.217 Wrote on socket: Content-Length: 1961
[Thread-109] DEBUG 00:02:44.217 Wrote on socket:
[Thread-109] DEBUG 00:02:44.217 Sending stream: 1961 bytes of get/0$4$2$11$1$0$0/thumbnail0000japhson-saints.mkv
[Thread-109] DEBUG 00:02:44.217 Close Connection
[Timer-1] DEBUG 00:02:45.091 Buffered Space: 299630592 bytes / inputs: 0
[Thread-107] INFO 00:02:46.105 Stopping process: win32/mencoder_mt.exe
[Thread-108] INFO 00:02:46.105 Stopping process: win32/mencoder_mt.exe
[Thread-107] INFO 00:02:46.105 Destroying buffer
[Thread-108] INFO 00:02:46.105 Destroying buffer
Barbastark
 
Posts: 10
Joined: Thu Jun 18, 2009 7:18 pm

Re: Mencoder crashes when transcoding 1080p MKV's

Postby eruarg » Sat Jul 25, 2009 10:08 pm

Seems like I found the solution. First I upgraded my network from 100 mbit to gigabit, still no change. Then I did some (alot) of browsing in these forums to look for people with similar problems, then I found this link: http://ps3mediaserver.googlecode.com/sv ... der_mt.exe

Which I replaced with the old mencoder_mt.exe, now it can play all my 1080p MKV's both with and without subtitles at very high bitrates (using PMS 1.11.350) without crashing.
eruarg
 
Posts: 5
Joined: Thu Jul 09, 2009 6:39 pm

Re: Mencoder crashes when transcoding 1080p MKV's

Postby shagrath » Sun Jul 26, 2009 12:32 am

this more recent mencoder build is not included in the releases, because some users have reported bad behavior about sync, lag and colors (while I have seen none if this but...)
shagrath
Project Lead
 
Posts: 2668
Joined: Wed Jan 14, 2009 1:39 pm

Re: Mencoder crashes when transcoding 1080p MKV's

Postby muchgooder.com » Mon Sep 28, 2009 2:57 pm

I've seen the exact same error recentlly in my setup. It only happens on some files. I'm not sure if this has anything to do with it but I've only seen it since I upgraded to 8 gig of RAM in my server. I also have a quad core cpu. Is it possible that my server is just too fast for mencoder? I installed the file .exe found in the link above but that didn't seem to help. The only thing that seemed to help was to disable multicore support in mencoder.
muchgooder.com
 
Posts: 32
Joined: Thu Aug 06, 2009 7:02 pm

Re: Mencoder crashes when transcoding 1080p MKV's

Postby meskibob » Mon Sep 28, 2009 3:46 pm

Maybe it's related to the new memory you installed?
I provide NO application support via PM or email, so please post your question to the forum per the Forum Rules.
meskibob
Moderator
 
Posts: 4788
Joined: Mon Jan 19, 2009 4:11 pm

Re: Mencoder crashes when transcoding 1080p MKV's

Postby muchgooder.com » Mon Sep 28, 2009 5:07 pm

You may be right but I thought it would mention it. I have no problem playing everything I've thrown at it but I did have the issue reported by OP while playing Master and Commander m2ts file. Unfortunately I did not try that file with my old memory but it played just fine once I removed the enhanced multi-core support. I'll try "How the West Was Won" later on as I've seen bit rates at almost 400k bps with that one.
muchgooder.com
 
Posts: 32
Joined: Thu Aug 06, 2009 7:02 pm

Next

Return to General Help and Support

Who is online

Users browsing this forum: Google [Bot], Yahoo [Bot] and 13 guests