mencoder and "unknown suboption"

For help and support with issues specific to Linux/Unix
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

mencoder and "unknown suboption"

Postby frang » Mon May 25, 2009 10:24 pm

Hey there,

When I'm trying to play some of my .avi or .mov files I get the error "Data defect" on my PS3. I've digged into the debug.log and I found some issues with mencoder. This is the command ps3mediaserver is trying to run and fails:
mencoder -ss 0 -quiet /ps3server/shared/billeder/TTVideo.avi -quiet -quiet -oac lavc -of mpeg -lavfopts format=asf -mpegopts format=mpeg2:muxrate=500000:vbuf_size=1194:abuf_size=64 -ovc lavc -channels 6 -lavdopts debug=0:threads=2 -lavcopts autoaspect=1:vcodec=mpeg2video:acodec=ac3:abitrate=384:threads=2:keyint=1:vqscale=1:vqmin=2 -quiet -quiet -subdelay 20000 -quiet -quiet -ofps 24000/1001 -quiet -quiet -af lavcresample=48000 -srate 48000 -o /tmp/javaps3media/mencoder1243284775662


When I run this command in bash I get the following error:
MEncoder 1.0rc1-4.1.2 (C) 2000-2006 MPlayer Team
CPU: Intel(R) Pentium(R) 4 CPU 3.00GHz (Family: 15, Model: 4, Stepping: 3)
CPUflags: Type: 15 MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx SSE SSE2

Option mpegopts: Unknown suboption vbuf_size
Error parsing option on the command line: -mpegopts

Exiting... (error parsing command line)


I've looked this up and as far as I can see my mencoder is too old and don't support vbuf_size and abuf_size. And if I remove these two options from mpegopts it works like a charm (in my prompt). I'm running a very new install of CentOS 5.3 with the newest update of the mplayer and mencoder that my repos got, but no luck.

My question is: Is there a way (maybe as an option in PMS.conf) to disable the usage of vbuf_size and abuf_size when ps3mediaserver is starting mencoder, or is it mandatory for a good video result (being a complete newbie on mencoder here)? Or does anyone know a way for me to get a newer version of mencoder for CentOS 5.3 without getting the newest snapshot from mplayerhq.hu, compiling it etc.?

/Frang
frang
 
Posts: 1
Joined: Mon May 25, 2009 10:12 pm

Re: mencoder and "unknown suboption"

Postby shagrath » Mon May 25, 2009 11:02 pm

MEncoder 1.0rc1-4.1.2 (C) 2000-2006 MPlayer Team


is waaaay too old... you will achieve nothing with this version :o (vbuf_size missing is only the beginning of your troubles :p)
I hope Linux experts will pass by cause I don't know much about CentOS :p
shagrath
Project Lead
 
Posts: 2667
Joined: Wed Jan 14, 2009 1:39 pm

Re: mencoder and "unknown suboption"

Postby kruijf » Tue May 26, 2009 9:40 am

Take a look at this site: http://www.mplayerhq.hu/design7/dload.html i think you can find a new version there.
kruijf
 
Posts: 9
Joined: Thu May 07, 2009 9:59 pm

Re: mencoder and "unknown suboption"

Postby cmccallu » Tue May 26, 2009 12:29 pm

Hi,
Just got this going myself on CentOS 5.3. The best bet is to build mplayer/x264/ffmpeg directly from the svn/git repositories. I found the rpm's around
including those on rpmforge just too old. I also needed to replace tsMuxeR found in the linux directory of the PMS distribution to the latest one from
smlabs website. Let me know if you need info on how I configured the builds.

Cheers
Chris
cmccallu
 
Posts: 2
Joined: Tue May 26, 2009 12:18 pm

Re: mencoder and "unknown suboption"

Postby jozua » Tue May 26, 2009 5:54 pm

I've been trying to compile ffmpeg and mencoder on an Ubuntu and Debian machine, both times mencoder would segfault when playing ASS/SSA subtitles. Without them it would work fine.
In the end i've installed most of the packages from the Medibuntu repository and the rest from https://launchpad.net/~rvm/+archive/ppa.

Cmccallu, have you run into the same problem on CentOS? i'd be very interested anyway to hear what options you enabled for compiling.
jozua
 
Posts: 11
Joined: Sat May 16, 2009 4:23 pm

Re: mencoder and "unknown suboption"

Postby cmccallu » Fri May 29, 2009 3:16 am

jozua wrote:I've been trying to compile ffmpeg and mencoder on an Ubuntu and Debian machine, both times mencoder would segfault when playing ASS/SSA subtitles. Without them it would work fine.
In the end i've installed most of the packages from the Medibuntu repository and the rest from https://launchpad.net/~rvm/+archive/ppa.

Cmccallu, have you run into the same problem on CentOS? i'd be very interested anyway to hear what options you enabled for compiling.


mplayer
./configure --prefix=/usr; make; make install

x264
./configure --prefix=/usr --enable-shared; make; make install
Had to manually move the shared libs to lib64 as I'm running x86_64 on an AMD Quad Core

ffmpleg
./configure --prefix=/usr --enable-gpl; make; make install

Seems to work fine on things I have tried not sure I have anything with ASS/SSA subtitles maybe give me a title of something and I can if I have it to try. BTW this is my secondary media center for the kids
as I use a macmini + plex as the primary so not tested as well.

Hope this helps
Chris
cmccallu
 
Posts: 2
Joined: Tue May 26, 2009 12:18 pm


Return to Linux/Unix Support

Who is online

Users browsing this forum: No registered users and 9 guests