External Subtitles Not Working

For help and support with issues specific to Mac OS X
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

External Subtitles Not Working

Postby twistymcgee » Wed May 20, 2009 8:43 pm

I have a file with the following name: JCVD.avi. Two files came with it: JCVD.idx and JCVD.sub. On my PS3 I can see the file show up with [MEncoder] {External Subtitles}. However, when I play the file, I don't get subtitles and my audio is out of sync. Any help with this would be appreciated since I don't really know a lot about how the subtitles work with the various codecs.

Thanks
twistymcgee
 
Posts: 5
Joined: Wed May 20, 2009 8:39 pm

Re: External Subtitles Not Working

Postby shagrath » Wed May 20, 2009 8:57 pm

unfortunately idx/sub is not supported on osx
shagrath
Project Lead
 
Posts: 2668
Joined: Wed Jan 14, 2009 1:39 pm

Re: External Subtitles Not Working

Postby twistymcgee » Wed May 20, 2009 11:04 pm

So what about Windows? I have a Windows virtual machine that has access to the files from the Mac. I can go that way if it will accomplish what I'm trying to do.
twistymcgee
 
Posts: 5
Joined: Wed May 20, 2009 8:39 pm

Re: External Subtitles Not Working

Postby shagrath » Wed May 20, 2009 11:06 pm

idx/sub is only supported on Windows, with the AviSynth/Mencoder transcoding engine
shagrath
Project Lead
 
Posts: 2668
Joined: Wed Jan 14, 2009 1:39 pm

Re: External Subtitles Not Working

Postby tigermann » Thu May 21, 2009 4:42 pm

Will it be supported in the future?
tigermann
 
Posts: 2
Joined: Thu May 21, 2009 4:41 pm

Re: External Subtitles Not Working

Postby pmos69 » Thu May 21, 2009 6:31 pm

Hard.
idx/sub are graphical, not text based. (Actually, an mpeg stream, I think).
Only with some kind of video overlaying it's possible to support it. I think that's what AviSynth does.

Even tools that convert from idx/sub to srt have to use things like assisted OCR to do their job.
pmos69
 
Posts: 147
Joined: Mon Jan 19, 2009 3:37 pm

Re: External Subtitles Not Working

Postby tigermann » Thu May 21, 2009 10:27 pm

Shouldn't it then be possible to decode the stream, add the text layer and then encode it?

Using menucoder ofc..
tigermann
 
Posts: 2
Joined: Thu May 21, 2009 4:41 pm

Re: External Subtitles Not Working

Postby pmos69 » Thu May 21, 2009 10:53 pm

hummm, actually, mplayer suports idx/subs in OS X (-vobsub) so piping mplayer's output to mencoder should make this possible...

- EDIT -
Yup, should be possible. Take a look at this example:
http://lists.mplayerhq.hu/pipermail/mpl ... 76699.html

Haven't tested it.
Anyway, using mkfifo instead of temp files could be even better.
pmos69
 
Posts: 147
Joined: Mon Jan 19, 2009 3:37 pm


Return to Mac OS X Support

Who is online

Users browsing this forum: Yahoo [Bot] and 4 guests