Strange Data Not Supported problem

For help and support with issues specific to Mac OS X
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Strange Data Not Supported problem

Postby cheule » Thu Jan 14, 2010 6:17 am

I've tried to help many on this board, now it's my turn to ask for guidance :)

I have a .mkv that refuses to transcode when I play it. I see the buffer start to fill, nothing bad shows in the trace log, but then the PS3 reports "Data Not Supported" and the file stops transcoding.

Now I might just chock it up to a bad encode except;

1) The movie plays fine in a myriad of other players including stand alone MEncoder and VLC.

2) The movie WILL transcode through PMS if I enter the #transcode# folder and select the subtitle track. Then the movie plays fine, but also displays subs, which I do not want. (note this the status on PMS reports using the MEncoder engine at this point)

However, if I choose any other item inside #transcode#, I get the Data not Supported error on the PS3. This includes selecting the video track as MEcoder, TSMuxer, and the various audio tracks (which there are two of).

This really confuses me as to why the video will play fine if the subs are forced on. It seems related to this post I had, where I noted that there was a huge video flub at a certain point in playing a very long movie that was NOT evident if I forced the subs on. So what is this monkey business with things working if subs are on, but not otherwise?

Please realize I have over 200 movies in .mkv on my hard drive, and 99% of them are A-OK. just these two are having issues. But I'd love to know why they are having issues, and why transcoding with subs solves the issues?

Some specs about my setup:

Using latest OS X beta of PMS, Version 1.20.0 r369
Mac OS X 10.6.2
Intel Core 2 Duo 2ghz / 4GB ram
Full Gigabit through a Apple switch to the PS3

I have PMS set to use the experimental enhanced multicore h264 engine for MEncoder, but that doesn't seem to make any difference if it's not selected. Same results without it on. I also have multiple cores selected, again no difference without it. I have tried "definitely disabling subtitles" with no positive results. As I say, it's only when I force subs on through #transcode# that it plays at all, even though theoretically (and proven by other movies I have) subs should automatically play when I choose the movie outside the #transcode# folder.

I will post a trace if someone thinks it'll help, but nothing is showing up strange in what I've seen in the trace log.
cheule
 
Posts: 134
Joined: Wed Jun 24, 2009 4:18 am

Re: Strange Data Not Supported problem

Postby meskibob » Thu Jan 14, 2010 3:02 pm

Try unchecking the "switch to TSmuxer ..." checkbox under the MEncoder settings.
I provide NO application support via PM or email, so please post your question to the forum per the Forum Rules.
meskibob
Moderator
 
Posts: 4768
Joined: Mon Jan 19, 2009 4:11 pm

Re: Strange Data Not Supported problem

Postby cheule » Fri Jan 15, 2010 2:34 am

meskibob wrote:Try unchecking the "switch to TSmuxer ..." checkbox under the MEncoder settings.


As soon as I read this, I knew you were right. But to be sure I ran to my media center, unchecked that option, and tested both movies I had problems with. Voila, everything is fine! I had completely forgotten that the "switch to TSmuxer" option was there.

So I assume this means that compiled version of TSMuxer included is a tad buggy...
cheule
 
Posts: 134
Joined: Wed Jun 24, 2009 4:18 am

Re: Strange Data Not Supported problem

Postby meskibob » Fri Jan 15, 2010 2:39 am

Or that your specific mkv can't be remuxed for the PS3 or it is getting messed up in the remux process (not sure how/why the latter would occur)
I provide NO application support via PM or email, so please post your question to the forum per the Forum Rules.
meskibob
Moderator
 
Posts: 4768
Joined: Mon Jan 19, 2009 4:11 pm

Re: Strange Data Not Supported problem

Postby MKUltra » Fri Jan 15, 2010 5:13 am

meskibob wrote:Try unchecking the "switch to TSmuxer ..." checkbox under the MEncoder settings.


Good call on this. I had a similar issue with an .MKV file. The only way I could it to work was thru MEncoder chapters and skipping the first 5 minutes. The file works now.
Mac Mini 2.26 GHz Intel Core 2 Duo 4 GB RAM OS 10.7.2/Airport Extreme Basestation (Early 2009) Wireless N/PS3-Fatboy 40GB/1Gibps via Cat 6 LAN connection w/ Airport Extreme/PS3 connected via HDMI to Denon AVR-3808CI
MKUltra
 
Posts: 75
Joined: Sun Aug 30, 2009 10:41 pm


Return to Mac OS X Support

Who is online

Users browsing this forum: No registered users and 3 guests