The 1080p problem - stuttering and PMS buffer starvation

For help and support with issues specific to Mac OS X
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

The 1080p problem - stuttering and PMS buffer starvation

Postby etsiot » Mon Sep 07, 2009 1:25 pm

Hi all,

Just writing to check whether I am the only one having this specific problem (although by looking at the forum it seems I am in good company):

my setup is based on the latest PMS version (r356) with 1 Gbps LAN switched end-to-end.
OSX 10.5.6 dual core @ 2.4 GHz with 8 GB RAM
1080p movie simply cannot be watched. It starts playing and will go into stuttering very early into the movie. Even if you let the buffer fill-up and then start playing it slowly empties.

Investigating the CPU activity monitoring it gives the hint to the problem: mencoder doesn't fully use the CPU cores; mencoder_mt will only use ~40% of the CPU and tsMuxer will get a 20% of CPU cycles even when deactivated in the PMS transcoding options. The rest 30-40% sits idle!
So, even I have the CPU power to transcode a 1080p movie I simply cannot.
The questions I would appreciate your feedback are whether:
- there is a way to permanently de-activate tsMuxer ( even if I do it in the GUI it still runs and steals CPU cycles)
- there is a workaround in making mencoder_mt to fully use the 2 cores? ( enhanced multicore support is of course enabled.)
- there is another transcoding option for 1080p content that also allows subtitles.

I need the subtitles so tsmuxer alone is not an option for me

Any help appreciated.
etsiot
 
Posts: 9
Joined: Mon Jan 19, 2009 1:32 pm

Re: The 1080p problem - stuttering and PMS buffer starvation

Postby meskibob » Mon Sep 07, 2009 3:33 pm

viewtopic.php?f=6&t=496

And I'm guessing this is probably a VC-1 1080P, which does not have the enhanced multicore support through MEncoder like H264 does, so you're stuck. viewtopic.php?f=6&t=3584&p=15795
I provide NO application support via PM or email, so please post your question to the forum per the Forum Rules.
meskibob
Moderator
 
Posts: 4760
Joined: Mon Jan 19, 2009 4:11 pm

Re: The 1080p problem - stuttering and PMS buffer starvation

Postby etsiot » Wed Sep 09, 2009 3:15 pm

@meskibob: Yes, I have read all the related posts, but almost all of them relate to the wireless b/w limitations; and I am talking about mkv content in x.264, not VC-1, of course.

I haven't seen any post address the real issue of stuttering which is menconder_mt and its poor use of CPU resources as well as the frequent crashes.

ps3mediaserver is a great concept and works very nicely for 720p content but unfortunately falls short for 1080p content due to those issues.

I am afraid that many users will get the same disappointment as I am feeling and eventually have to buy some h/w based media server; which is a pity because ps3mediaserver trully stands out from the rest.

If the developer team need to focus to something, I feel it should be those issues; new features can come later, when the important bugs have been sorted out.

Thanks,

etsiot.
etsiot
 
Posts: 9
Joined: Mon Jan 19, 2009 1:32 pm

Re: The 1080p problem - stuttering and PMS buffer starvation

Postby meskibob » Wed Sep 09, 2009 4:06 pm

Did you look at the first post I linked, which tells you what is required to properly start investigating a problem? The devs can't really do much when they don't have the proper materials to diagnose what's going on. And to note, you had most of it as far as your setup, but not the debug.log and MediaInfo output that are crucial in determining what is wrong.
I provide NO application support via PM or email, so please post your question to the forum per the Forum Rules.
meskibob
Moderator
 
Posts: 4760
Joined: Mon Jan 19, 2009 4:11 pm

Re: The 1080p problem - stuttering and PMS buffer starvation

Postby etsiot » Thu Sep 10, 2009 10:22 pm

Here you are... the latest movie I tried to play was Deception.
started playing well, but after a couple of minutes stuttering begins
CPU has 20-30% more power not used; mencoder_mt uses 40-50%, tsmuxer 20-30% although it does nothing - movie is subbed with external subtitles.
I am also attaching the debug.log for anyone patient enough to take a look.

the output by handbrake:
Deception.1080p.BluRay.x264 (GR).COM/1920-deception.mkv, title_index=0
[00:12:46] scan: trying to open with libdvdread
[00:12:46] dvd: not a dvd - trying as a stream/file instead
Input #0, matroska, from '/Users/henribresson/Movies/Deception.1080p.BluRay.x264 (GR).COM/1920-deception.mkv':
Duration: 01:47:49.47, start: 0.000000, bitrate: N/A
Stream #0.0(eng): Video: h264, yuv420p, 1920x800, 23.98 tb(r)
Stream #0.1(eng): Audio: dca, 48000 Hz, 5:1, s16
[00:12:46] scan: decoding previews for title 1
[00:12:46] scan: audio 0x1: DCA, rate=48000Hz, bitrate=1536000 English (DTS) (5.1 ch)
[00:12:48] scan: 10 previews, 1920x800, 23.976 fps, autocrop = 0/0/0/0, aspect 2.40:1, PAR 1:1
[00:12:48] scan: title (0) job->width:1920, job->height:800
[00:12:48] libhb: scan thread found 1 valid title(s)
[00:12:48] macgui: ScanDone state received from fHandle
Attachments
debug.log.zip
(29.28 KiB) Downloaded 52 times
etsiot
 
Posts: 9
Joined: Mon Jan 19, 2009 1:32 pm

Re: The 1080p problem - stuttering and PMS buffer starvation

Postby shagrath » Fri Sep 11, 2009 10:15 pm

I cannot speak for Redlum (the osx package maintainer) but I think the mencoder mt build on osx is a little more buggy than the one on Windows ? (or maybe new ones have been made ?).
shagrath
Project Lead
 
Posts: 2667
Joined: Wed Jan 14, 2009 1:39 pm

Re: The 1080p problem - stuttering and PMS buffer starvation

Postby etsiot » Wed Sep 16, 2009 8:03 pm

So, while waiting for fixes/updates to mencoder, is there a way to permanently turn off tsmuxer? Even if you disable it in the GUI, it still takes 20% of CPU resources.
Can anybody share whether work is being done on mencoder that will enable watching 1080p?
I mean, if the multi-threaded osx build of mencoder is not being taken care of, then perhaps we have to think of alternatives.

Any response appreciated.

Regards,

etsiot
etsiot
 
Posts: 9
Joined: Mon Jan 19, 2009 1:32 pm

Re: The 1080p problem - stuttering and PMS buffer starvation

Postby Redlum » Thu Sep 17, 2009 1:48 pm

It will hopefully be taken care of with new builds that I'll make before a new PMS release. You are using a beta version of PMS and the multi-threaded version of ffmpeg/mencoder is an unofficial patch that's not likely to be tested a lot on OS X. Some problems are to be expected at this stage ;).
Redlum
Project Member
 
Posts: 371
Joined: Mon Jan 12, 2009 9:13 pm

Re: The 1080p problem - stuttering and PMS buffer starvation

Postby Pranck » Sun Sep 20, 2009 11:23 pm

Hello,

I'm having the same exact problem here.
On the mac mini Core2Duo 2GHz, i can only play 720p files (but only on "Good Quality" setting, i get shuttering on Best Quality setting).
But it won't 1080p files. It is not a bandwidth issue, since I have a gigabit LAN.

I also tried playing 1080p files on my brand new Macbook Pro 2,66ghz with no success...

It's the only thing that's missing... from the OS X version at least.
Other than that, it's a great application.
Pranck
 
Posts: 3
Joined: Sun Sep 20, 2009 11:17 pm

Re: The 1080p problem - stuttering and PMS buffer starvation

Postby Pranck » Tue Sep 29, 2009 6:47 pm

I may have found a way to temporarily play 1080p files.

I have selected 4 numbers of cores for transcoding (even though i have two).
It utilizes much more % of the processor this way. I was able to play a 1080p file normally.
I can't fast forward nor rewind though...
Pranck
 
Posts: 3
Joined: Sun Sep 20, 2009 11:17 pm

Next

Return to Mac OS X Support

Who is online

Users browsing this forum: Google [Bot], Yahoo [Bot] and 4 guests