the application mencoder unexpectedly quit.

For help and support with issues specific to Mac OS X
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Re: the application mencoder unexpectedly quit.

Postby adamprocter » Thu Jun 04, 2009 12:10 am

I select carbonfootprint.mov in XMB
Settings
Buffer 600
Cores 4
keyint=1:vqscale=1:vqmin=2

[Thread-536] TRACE 00:04:34.955 Starting transcode/remux of carbonfootprint.mov
[Thread-633] TRACE 00:04:38.945 Starting transcode/remux of growing.fla
[osx/mencoder] TRACE 00:04:40.427 Process /Applications/PS3 Media Server.app/Contents/Resources/Java/osx/mencoder has a return code of 138! Maybe an error occured... check the log file

Just change
Cores 1

works fine (although still traces odd .fla file)

Changed Cores to
Cores 2 - crashes like above

I guess Mencoder on mac can only use 1 core - now that is darn shame.
adamprocter
 
Posts: 20
Joined: Mon Apr 06, 2009 7:22 pm

Re: the application mencoder unexpectedly quit.

Postby pmos69 » Thu Jun 04, 2009 2:33 pm

no problem with 2 cores here...
pmos69
 
Posts: 147
Joined: Mon Jan 19, 2009 3:37 pm

Re: the application mencoder unexpectedly quit.

Postby adamprocter » Sat Jun 06, 2009 5:08 pm

Is yours an intel duo

I am running Latest mac beta r337
on Mac Pro
Dual-Core Intel Xeon
Processor Speed: 2.66 GHz
adamprocter
 
Posts: 20
Joined: Mon Apr 06, 2009 7:22 pm

Re: the application mencoder unexpectedly quit.

Postby pmos69 » Sun Jun 07, 2009 3:02 am

24'' iMac
2.66GHz Intel Core 2 Duo
pmos69
 
Posts: 147
Joined: Mon Jan 19, 2009 3:37 pm

Re: the application mencoder unexpectedly quit.

Postby NonBorn » Thu Jun 18, 2009 10:06 am

I have problems too when i choose more than 1 core to transcode... Probably this is not an issue of PMS... Its actually a big problem, i cannot transcode 1080p with high bitrate at all because of 1 core...

Mac Pro 2008 here...
NonBorn
 
Posts: 12
Joined: Thu Apr 23, 2009 12:44 pm

Re: the application mencoder unexpectedly quit.

Postby cheule » Wed Jun 24, 2009 4:30 am

Thought this might help.

I too have had problems with Mencoder unexpectedly quitting while doing transcoding from a .mkv file.

Here's is what I found:

On my older Macbook Pro (first gen) with Intel Core Duo 2.0ghz processors (2 of them) everything works fine, no crashes even with cores set to 2.

On my new Mac mini (2009 version w/ 5 usbs and Nvidia grphx) which has Intel Core 2 Duo 2ghz processors, mencoder crashes if I select more than 1 core. 1 core seems to work better, but I still get mencoder crashes. Let's say when it's sent to 2 cores, I get them every 5 min or so. When set to 1 core, I get them every 45 min.
cheule
 
Posts: 134
Joined: Wed Jun 24, 2009 4:18 am

Re: the application mencoder unexpectedly quit.

Postby cheule » Wed Jun 24, 2009 5:37 am

Might be too early to tell, but so far I've had no mencoder crashes with the beta version of PS3 Media Server found here: viewtopic.php?f=7&t=1635

As said on that page, one of the changes is:
"OSX: Updated mencoder/mplayer/ffmpeg builds, support for FriBidi"

If I get some mencoder crashes, I'll post, but so far so good after 1 hour transcoding Harry Potter Order of the Phoenix, 720 mkv
cheule
 
Posts: 134
Joined: Wed Jun 24, 2009 4:18 am

Re: the application mencoder unexpectedly quit.

Postby NonBorn » Wed Jun 24, 2009 7:21 pm

Do you enable FriBidi support as an option somewhere?? Im trying right now 1080p LOTR 3 and so far no problem too with the new beta 334... I hope everything is OK now :D :D
NonBorn
 
Posts: 12
Joined: Thu Apr 23, 2009 12:44 pm

Re: the application mencoder unexpectedly quit.

Postby cheule » Thu Jun 25, 2009 8:21 am

Ok, two days of playing all sorts of movies with the latest beta (r334), and no problems with mencoder quitting. I also love the new DTS support. Although I have to have "Keep DTS audio in stream" checked, or all the sounds comes from the right channel.
cheule
 
Posts: 134
Joined: Wed Jun 24, 2009 4:18 am

Re: the application mencoder unexpectedly quit.

Postby lamosas » Sat Jan 02, 2010 4:52 pm

I am still having problems with the application crashing. Any ideas?
Did anyone solve this anyhow?
Thankz in advance!
lamosas
 
Posts: 1
Joined: Sat Jan 02, 2010 4:50 pm

Previous

Return to Mac OS X Support

Who is online

Users browsing this forum: Google [Bot] and 4 guests