the application mencoder unexpectedly quit.

For help and support with issues specific to Mac OS X
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

the application mencoder unexpectedly quit.

Postby blackpants » Tue Jan 27, 2009 2:17 pm

Hi after about 3 mins I get the above message and shortly after the film I am watching stops.

This is happening at the same place both wired network and wirelessly.

The file I am tryng to play is a 720p .mkv

My comp is a 2.4 Dual Core MacBook, with 2gB of RAM

All other file types work fine.divx or .avi.

Any ideas?
blackpants
 
Posts: 1
Joined: Tue Jan 27, 2009 2:12 pm

Re: the application mencoder unexpectedly quit.

Postby acemt » Sat Jan 31, 2009 5:58 am

Similar to what I am seeing
acemt
 
Posts: 24
Joined: Wed Jan 28, 2009 6:26 pm

Re: the application mencoder unexpectedly quit.

Postby acemt » Mon Feb 09, 2009 6:19 pm

Actually I am having worse luck with the new build (1.04) than I did with the previous on OSX. If the file is a larger .mkv, I am getting MEncoder crashes almost immediately.
acemt
 
Posts: 24
Joined: Wed Jan 28, 2009 6:26 pm

Re: the application mencoder unexpectedly quit.

Postby acemt » Tue Feb 10, 2009 2:52 am

Curious as to the build date and source of the MEncoder version you are using for OSX. Thanks
acemt
 
Posts: 24
Joined: Wed Jan 28, 2009 6:26 pm

Re: the application mencoder unexpectedly quit.

Postby Redlum » Wed Feb 11, 2009 1:07 pm

It's the one from 1 february if I remember correctly.
Redlum
Project Member
 
Posts: 371
Joined: Mon Jan 12, 2009 9:13 pm

Re: the application mencoder unexpectedly quit.

Postby shaj » Sat Feb 21, 2009 7:06 pm

Not sure if you managed toi fix this black pants. For me it seems the problem was using the 2 cores. I changed it to one and all was fine.
shaj
 
Posts: 1
Joined: Sat Feb 21, 2009 4:12 pm

Re: the application mencoder unexpectedly quit.

Postby NonBorn » Sun May 24, 2009 8:48 pm

I got the same problem with the last builds of ps3mediaserver... When I have more than one core transcoding mencoder quits... Is there a way to fix it?? Its probably something with the mencoder...I cannot stream with only one core :(
NonBorn
 
Posts: 12
Joined: Thu Apr 23, 2009 12:44 pm

Re: the application mencoder unexpectedly quit.

Postby AjzRide » Mon May 25, 2009 3:15 pm

Try reducing your maximum buffer size. I experienced this on my mac. The default of 400 caused mencoder to quit. I changed it to 375 and no more problems. You may want to start at 256 and work your way up until it starts quitting on you again.
AjzRide
 
Posts: 14
Joined: Thu May 21, 2009 1:56 am
Location: Deep South

Re: the application mencoder unexpectedly quit.

Postby NonBorn » Mon May 25, 2009 7:59 pm

AjzRide wrote:Try reducing your maximum buffer size. I experienced this on my mac. The default of 400 caused mencoder to quit. I changed it to 375 and no more problems. You may want to start at 256 and work your way up until it starts quitting on you again.


Tried it... Doesnt seem to fix it completely but it does work for some movies... Do anybody know how many cores mencoder can utilize? Because I cannot see menocder to use more than 2 cores in my mac pro... Even If i choose 8 cores from ps3mediaserver.
Last edited by NonBorn on Tue May 26, 2009 3:27 pm, edited 1 time in total.
NonBorn
 
Posts: 12
Joined: Thu Apr 23, 2009 12:44 pm

Re: the application mencoder unexpectedly quit.

Postby NonBorn » Tue May 26, 2009 3:26 pm

Any idea??

In debug.log i get this:
[osx/mencoder_mt] TRACE 18:17:45.116 Process /Applications/PS3 Media Server.app/Contents/Resources/Java/osx/mencoder_mt has a return code of 139! Maybe an error occured... check the log file
NonBorn
 
Posts: 12
Joined: Thu Apr 23, 2009 12:44 pm

Next

Return to Mac OS X Support

Who is online

Users browsing this forum: No registered users and 5 guests