PS3 Mavericks

For help and support with issues specific to Mac OS X
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Re: PS3 Mavericks

Postby frenchepaul » Wed Oct 30, 2013 4:41 pm

Hello, for me PS3 Media Server won't quit under Mavericks.
If I close, either via the quit button in the app window, or via finder menu, the icon disappear from the task bar but the opened indicator in the dock stays.
Finder (via right click on the app icon in the dock) is telling me the Application is not responding.

Weird part is force quit menu won't open, and I can't find PMS process in Activity Monitor. There are no logs in the console as well. :(

Everytime I need to force reboot my mac . I tried uninstalling and reinstalling, it worked for a little while then started bugging again.

Anyone has an idea ? or a similar problem ?
Posts: 1
Joined: Wed Oct 30, 2013 4:37 pm

Re: PS3 Mavericks

Postby rpcsilva » Wed Oct 30, 2013 6:14 pm

ps3 media server won't quit under mavericks.
when trying to install 1.90.1 the installation setup won't get past the final (7/7) step and won't finalize the setup.
when opening the application I get a -600 error
Posts: 1
Joined: Wed Oct 30, 2013 6:11 pm

Re: PS3 Mavericks

Postby Irbow » Thu Oct 31, 2013 12:21 am

I just wanted to add that I am also having problems with Mavericks. I was able to install the latest version of PMS and it seems to work on smaller .avi type files but with larger MP4 or DVD Iso it freezes and as mentioned crashes my mac where it won't force quit. The PS3 also seems to need a re-start to see the server again.
All was okay with ML and I upgraded PMS 2 days ago hoping for a fix.

Cheers, iain.
Posts: 1
Joined: Thu Oct 31, 2013 12:10 am

Re: PS3 Mavericks

Postby psralk » Fri Nov 01, 2013 9:12 pm

I have also a problem.

When I start the stream the buffer builds up a little bit, cpu workload goes up as well and a couple of seconds later the buffer goes down and the cpu is doing nothing and than it stops.

Another movie: the buffer is full to the max, but it stops every 2 second
Posts: 1
Joined: Fri Nov 01, 2013 9:04 pm

Re: PS3 Mavericks

Postby tekyguy » Fri Nov 01, 2013 11:32 pm

For me, I updated to the latest PS3MS 1.90.1 with no issue. My problem is that even without any transposing my movies are freezing up and dropping audio and video for several seconds. When I go to my Mac I see that the Java application is using about 100% of one core during these freezes. The rest of the time it is using about 1-15%.
Posts: 4
Joined: Fri Nov 01, 2013 11:27 pm

Re: PS3 Mavericks

Postby tekyguy » Fri Nov 01, 2013 11:33 pm

I also noticed that when I start interacting with the PS3MS UI it causes the Java application to max out one core again.
Posts: 4
Joined: Fri Nov 01, 2013 11:27 pm

Re: PS3 Mavericks

Postby tekyguy » Sat Nov 02, 2013 5:37 pm

I think I fixed my CPU usage and freezing issue. I upgraded to Jave 1.7 and had to install the JDK 7 to get v 1.7 to go active on my system. So far so good, no CPU usage problems or streaming freezes.
Posts: 4
Joined: Fri Nov 01, 2013 11:27 pm

Re: PS3 Mavericks

Postby Raptor399 » Sun Nov 03, 2013 9:56 am

Chaos23 wrote:Having problems too....

Something to do with the iPhoto Upgrade?

Code: Select all
Something went wrong with the iPhoto Library scan:
xmlwise.XmlParseException: Failed to parse: <dict>
<key>Application Version</key><string>9.4</string><key>Archive Path</key><string>/Users/jna/Pictures/JnA iPhoto library.photolibrary</string><key>ArchiveId</key><string>1</string><key>Major Version</key><integer>2</integer><key>Minor Version</key><integer>0</integer><key>List of Albums</key><array>


It appears that your iPhoto database is somehow corrupted. That is why an exception is thrown when the file is being loaded. According to the parser there is something wrong in the "<dict>" tag.

The debug.log should contain a line:

Code: Select all
Resolved URL to file: ... -> ...

right before the exception. That is the file that is being opened. You could try open it in an editor and see if you can spot the corruption in the file.
Project Member
Posts: 1916
Joined: Thu Mar 10, 2011 12:06 am

Re: PS3 Mavericks

Postby jimilyon » Mon Nov 04, 2013 4:53 pm

I have been having trouble with pms ever since I upgraded to Mavericks. Lost packets screen freezing ect.. I found the 1.9 upgrade as I am on 1.8 something. the installer for 1.9 will not run. I get the message box for osX that it is downloaded
from an unknown site and do I want to continue. I continue and it immediately closes. I understand that this is not effecting everyone. Any suggestions for a work around will be appreciated

Posts: 1
Joined: Mon Nov 04, 2013 4:48 pm

Re: PS3 Mavericks

Postby ciarals » Tue Nov 05, 2013 2:21 pm

Raptor399 wrote:It appears that MEncoder is having problems finding fonts; errors appear when running the command line manually.

As a workaround until we can find a solution, try using FFmpeg as top video file engine on the 'Transcoding Settings' panel: it seems to pick up subtitles just fine.

Hello Raptor. Thanks for your hint, but this seems to not working for me. Before going to this, here are all the previously problems that I had with Mavericks and that I've solved, somehow.

1) As other users reported, I tried to uninstall an reinstall the latest version of PMS and it stopped at step 6/7. I quitted the install process and PMS was successfully installed (I think).

2) After clicking on the icon, PMS wasn't appearing. The Java installed on my Mac was the latest version found on website. I checked with "java -version" and it said that Java wasn't installed on my Mac! So I clicked on the linked displayed on the warning message and I installed the Java Platform (JDK) 7u45 from Oracle website: after this install, the PMS was working again.

And here we come to the not-solved problem: subtitles not displaying. I tried your solution with FFmpeg but it didn't work: no audio or video on the PS3, just an error. Tried switching off and on PS3 and PMS without success.

I also had VLC as Video File Engine. So I tried with it and it worked, but not so well: audio and subtitles are ok but video is vary bad with big pixels everywhere.

So now what can I/we do? Up to now, FFmpeg was the worst solution. Why it didn't worked? Do I have to install FFmpeg or update it?

Thanks for all your help :)
Posts: 3
Joined: Tue Nov 05, 2013 12:28 pm


Return to Mac OS X Support

Who is online

Users browsing this forum: No registered users and 1 guest