Unable to play rm/rmvb file

For help and support with issues specific to Mac OS X
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Unable to play rm/rmvb file

Postby craz » Wed Jul 31, 2013 1:38 pm

I have downloaded the latest stable build pms-macosx-1.82.0.dmg. I am streaming to my PS3 wirelessly. I have not been able to play any rm/rmvb files. Any attempt to play rm/rmvb files on PS3 will yield a 'The data is corrupted' message on PS3.

I have attempted to use the latest snapshot build as well (pms-1.90.0-SNAPSHOT-jar-with-dependencies.jar). I am getting the same result. My debug.log:
http://pastebin.com/URVfALx1

I am running Mac OS X 10.8.4 with latest version of Java.

Any ideas? Happy to provide more information if required
craz
 
Posts: 1
Joined: Wed Jul 31, 2013 1:29 pm

Re: Unable to play rm/rmvb file

Postby Raptor399 » Wed Jul 31, 2013 7:09 pm

Looks like mencoder isn't happy with the .rm files and doesn't produce any output for PMS to send.

You could try opening a Terminal and executing the mencoder command manually to inspect what it produces.

From your log:

Code: Select all
INFO  2013-07-31 22:24:16.283 [New I/O server worker #1-4] Starting transcode/remux of 蜡笔小新全集_蜡笔小新全集_094.rm
DEBUG 2013-07-31 22:24:16.327 [mencoder-7] Starting "/Applications/PS3 Media Server.app/Contents/Resources/Java/osx/mencoder" -ss 0 /Users/chinhui/Movies/QvodPlayer/蜡笔小新全集_蜡笔小新全集_094.rm -msglevel statusline=2 -oac lavc -of mpeg -mpegopts format=mpeg2:muxrate=500000:vbuf_size=1194:abuf_size=64 -ovc lavc -channels 6 -lavdopts debug=0:threads=2 -lavcopts autoaspect=1:vcodec=mpeg2video:acodec=ac3:abitrate=448:threads=2:keyint=25:vqscale=1:vqmin=2:vqmax=3:vrc_maxrate=499000:vrc_buf_size=1835 -nosub -noautosub -ofps 30 -lavdopts fast -mc 0.1 -af lavcresample=48000 -srate 48000 -o - -really-quiet -msglevel statusline=2
WARN  2013-07-31 22:24:16.560 [New I/O server worker #1-4] External input stream instance is null... sounds not good, waiting 500ms

So the command line would be something like this:

Code: Select all
"/Applications/PS3 Media Server.app/Contents/Resources/Java/osx/mencoder" -ss 0 /Users/chinhui/Movies/QvodPlayer/蜡笔小新全集_蜡笔小新全集_094.rm -msglevel statusline=2 -oac lavc -of mpeg -mpegopts format=mpeg2:muxrate=500000:vbuf_size=1194:abuf_size=64 -ovc lavc -channels 6 -lavdopts debug=0:threads=2 -lavcopts autoaspect=1:vcodec=mpeg2video:acodec=ac3:abitrate=448:threads=2:keyint=25:vqscale=1:vqmin=2:vqmax=3:vrc_maxrate=499000:vrc_buf_size=1835 -nosub -noautosub -ofps 30 -lavdopts fast -mc 0.1 -af lavcresample=48000 -srate 48000 -o testoutput.mpg -msglevel statusline=2
Raptor399
Project Member
 
Posts: 1916
Joined: Thu Mar 10, 2011 12:06 am

Re: Unable to play rm/rmvb file

Postby elfie13 » Thu Sep 12, 2013 1:44 am

I have the same issue, and I manually ran the command in Terminal and got the following (new to MAC OS so not sure how to interpret). Seems like a codec is missing or something...

Alainas-iMac:~ alaina$ "/Applications/PS3 Media Server.app/Contents/Resources/Java/osx/mencoder" -ss 0 /Users/alaina/Movies/Brain/[TSKS][Brain][001][KO_CN].rmvb -msglevel statusline=2 -oac lavc -of mpeg -mpegopts format=mpeg2:muxrate=500000:vbuf_size=1194:abuf_size=64 -ovc lavc -channels 6 -lavdopts debug=0:threads=2 -lavcopts autoaspect=1:vcodec=mpeg2video:acodec=ac3:abitrate=448:threads=2:keyint=25:vqscale=1:vqmin=2:vqmax=3:vrc_maxrate=499000:vrc_buf_size=1835 -nosub -noautosub -ofps 30 -lavdopts fast -mc 0.1 -af lavcresample=48000 -srate 48000 -o testoutput.mpg -msglevel statusline=2
MEncoder UNKNOWN-4.2.1 (C) 2000-2012 MPlayer Team
success: format: 0 data: 0x0 - 0x10e2bfa0
libavformat version 54.29.105 (internal)
REAL file format detected.
Stream description: Audio Stream
Stream mimetype: audio/x-pn-realaudio
[real] Audio stream found, -aid 0
Stream description: Video Stream
Stream mimetype: video/x-pn-realvideo
[real] Video stream found, -vid 1
Stream mimetype: logical-fileinfo
VIDEO: [RV40] 640x360 24bpp 29.000 fps 0.0 kbps ( 0.0 kbyte/s)
[V] filefmt:11 fourcc:0x30345652 size:640x360 fps:29.000 ftime:=0.0345
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
libavcodec version 54.61.100 (internal)
AUDIO: 44100 Hz, 2 ch, floatle, 44.1 kbit/1.56% (ratio: 5512->352800)
Selected audio codec: [ffcook] afm: ffmpeg (FFmpeg COOK audio)
==========================================================================
PACKET SIZE: 2048 bytes, deltascr: 884
Opening video filter: [expand osd=1]
Expand: -1 x -1, -1 ; -1, osd: 1, aspect: 0.000000, round: 1
==========================================================================
Opening video decoder: [realvid] RealVideo decoder
WARNING: Attempting to use DLL codecs but environment variable
DYLD_BIND_AT_LAUNCH not set. This will likely crash.
Win32 LoadLibrary failed to load: /Users/patricka/work/ps3mediaserver-maven/i386/target/bin-tools/target/lib/codecs/drvc.dll
Error loading dll
ERROR: Could not open required DirectShow codec drvc.dll.
Read the RealVideo section of the DOCS!
VDecoder init failed :(
Opening video decoder: [realvid] RealVideo decoder
WARNING: Attempting to use DLL codecs but environment variable
DYLD_BIND_AT_LAUNCH not set. This will likely crash.
Win32 LoadLibrary failed to load: /Users/patricka/work/ps3mediaserver-maven/i386/target/bin-tools/target/lib/codecs/drv43260.dll
Error loading dll
ERROR: Could not open required DirectShow codec drv43260.dll.
Read the RealVideo section of the DOCS!
VDecoder init failed :(
Opening video decoder: [realvid] RealVideo decoder
Error: dlopen(/Users/patricka/work/ps3mediaserver-maven/i386/target/bin-tools/target/lib/codecs/drvc.bundle/Contents/MacOS/drvc, 1): image not found
WARNING: Attempting to use DLL codecs but environment variable
DYLD_BIND_AT_LAUNCH not set. This will likely crash.
Win32 LoadLibrary failed to load: /Users/patricka/work/ps3mediaserver-maven/i386/target/bin-tools/target/lib/codecs/drvc.bundle/Contents/MacOS/drvc
Error loading dll
ERROR: Could not open required DirectShow codec drvc.bundle/Contents/MacOS/drvc.
Read the RealVideo section of the DOCS!
VDecoder init failed :(
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffrv40] vfm: ffmpeg (FFmpeg RV40)
==========================================================================
[ac3 @ 0xee7160]channel_layout not specified
[ac3 @ 0xee7160]No channel layout specified. The encoder will guess the layout, but it might be incorrect.
Limiting audio preload to 0.4s.
Increasing audio density to 4.
Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
videocodec: libavcodec (640x360 fourcc=3267706d [mpg2])
[VE_LAVC] Using constant qscale = 1.000000 (VBR).
New_Face failed. Maybe the font path is wrong.
Please supply the text font file (~/.mplayer/subfont.ttf).
subtitle font: load_sub_face failed.
New_Face failed. Maybe the font path is wrong.
Please supply the text font file (~/.mplayer/subfont.ttf).
subtitle font: load_sub_face failed.
[VD_FFMPEG] DRI failure.

Skipping frame!

Skipping frame!

Skipping frame!

Skipping frame!

Skipping frame!

Skipping frame!

Skipping frame!

Skipping frame!

Skipping frame!

Skipping frame!
Writing header...
INITV: 0.200, 0.167, fps: 30.000

Skipping frame!

Skipping frame!

Skipping frame!

Skipping frame!



Raptor399 wrote:Looks like mencoder isn't happy with the .rm files and doesn't produce any output for PMS to send.

You could try opening a Terminal and executing the mencoder command manually to inspect what it produces.

From your log:

Code: Select all
INFO  2013-07-31 22:24:16.283 [New I/O server worker #1-4] Starting transcode/remux of 蜡笔小新全集_蜡笔小新全集_094.rm
DEBUG 2013-07-31 22:24:16.327 [mencoder-7] Starting "/Applications/PS3 Media Server.app/Contents/Resources/Java/osx/mencoder" -ss 0 /Users/chinhui/Movies/QvodPlayer/蜡笔小新全集_蜡笔小新全集_094.rm -msglevel statusline=2 -oac lavc -of mpeg -mpegopts format=mpeg2:muxrate=500000:vbuf_size=1194:abuf_size=64 -ovc lavc -channels 6 -lavdopts debug=0:threads=2 -lavcopts autoaspect=1:vcodec=mpeg2video:acodec=ac3:abitrate=448:threads=2:keyint=25:vqscale=1:vqmin=2:vqmax=3:vrc_maxrate=499000:vrc_buf_size=1835 -nosub -noautosub -ofps 30 -lavdopts fast -mc 0.1 -af lavcresample=48000 -srate 48000 -o - -really-quiet -msglevel statusline=2
WARN  2013-07-31 22:24:16.560 [New I/O server worker #1-4] External input stream instance is null... sounds not good, waiting 500ms

So the command line would be something like this:

Code: Select all
"/Applications/PS3 Media Server.app/Contents/Resources/Java/osx/mencoder" -ss 0 /Users/chinhui/Movies/QvodPlayer/蜡笔小新全集_蜡笔小新全集_094.rm -msglevel statusline=2 -oac lavc -of mpeg -mpegopts format=mpeg2:muxrate=500000:vbuf_size=1194:abuf_size=64 -ovc lavc -channels 6 -lavdopts debug=0:threads=2 -lavcopts autoaspect=1:vcodec=mpeg2video:acodec=ac3:abitrate=448:threads=2:keyint=25:vqscale=1:vqmin=2:vqmax=3:vrc_maxrate=499000:vrc_buf_size=1835 -nosub -noautosub -ofps 30 -lavdopts fast -mc 0.1 -af lavcresample=48000 -srate 48000 -o testoutput.mpg -msglevel statusline=2
elfie13
 
Posts: 2
Joined: Wed Jun 19, 2013 10:05 pm


Return to Mac OS X Support

Who is online

Users browsing this forum: Yahoo [Bot] and 4 guests