problem with large directory of files

For help and support with issues specific to Mac OS X
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

problem with large directory of files

Postby hot_ham_water » Sat Jan 26, 2013 4:47 pm

Hi all, I've searched the forums for this but didn't find anything specifically about this problem. I should say that I've gotten the whole system set up and am successfully streaming media files from my MBP (10.8.2) to my LG Bluray player (BD570). The LG is using a wired connection, and its firmware is up to date. I'm running version 1.72.0 of PMS.

What's happening is that when I try to steam a file from a directory that contains a large number of files (400+, many of which are very large files themselves) the LG shows its 'thinking' icon (a rotating star shape) and then nothing happens. the 'thinking' icon will alternate between the 'play' icon (a small triangle) and this process will continue for about 10 minutes until an error comes up saying 'cannot play this file'. so I tried two things: I copied the file to its own directory in the root of the disc, and also into its own directory a few levels deep in the same folder with the 400+ files. both of these files, when copied to their own directory, then play just fine.

I noticed something odd in the PMS interface when I would try to play the file from the large directory: when I would select it on the LG, the PMS window would show a message 'serving xxxxxxxxxxxxxxxxx' at the bottom of the window, and the xxxxxx would state the name of a file it was 'serving' which is actually not the file I had requested. additionally, the file I had requested, when it's in the large directory, would show the word [MEncoder] after it in the LG interface, but that word isn't in the file itself on the disc. when I select that file from the smaller directory (where it's the only file), [MEncoder] word isn't there.

If I've just detailed a 'know issue' or if there's an article on here that covers this, please point me to it and I'm happy to take it from there. if there is simply a directory size limit, or if there's a setting I can adjust in the PMS, then I'll do that. I'm a pretty techie guy and I think I might just be missing a setting somewhere. Thanks!
Posts: 1
Joined: Sat Jan 26, 2013 4:28 pm

Re: problem with large directory of files

Postby fluuu » Mon Jan 28, 2013 7:54 pm

Hi folks,

would like to confirm for Sony Bravia EX and Samsung UE40C8790.
I also suspect a PMS problem because WildMediaServer, Twonky, Serviio and MediaTomb works fine.

Update-Package from (issue 737, 755 - 2011), disabling subtitles and miniatures without any effect.

Thanks in advance for any advice...
Posts: 2
Joined: Mon Jan 28, 2013 7:34 pm

Re: problem with large directory of files

Postby fluuu » Wed Jan 30, 2013 8:56 pm

hi hot_ham_water, hi folks,

I've got a workaround for our problem:
As described in issue 737 ( ... ail?id=737) I also suppose
the rub in scanning processes.

I observed, that scanning in the Folders Sharing Tab does not analyze the directories.
It starts for the whole directory (not just one file) on demand of my devices (Samsung UE40C8790 -AllShare, Sony Bravia EX) and stops with
loading timeout of the device.
I tried several times ... and on every attempt loading timeout takes a little longer.
Probably the scan-results are stored in the Database and further scans are skipped.

20 times later, i guess it was 20000, scanning of my 2TB-share-network-folder was complete.
(Take a look at debug.log after every timeout)

That worked for me:
- disable all subtitles, even in transcoding-engines if present
- disable all miniatures
- open your folder at the device until timeout
- repeat 20000 times, until filetree is visible
- enjoy :)

Side effect: If you scan once all other devices can further use and list immediately.

If you change files in your directories a re-opening will analyze only changed files (and within timeout, if you change moderate). :)

Good luck! (And sorry for my bad german english - hope you could understand me)
Please let me know if that worked for you also. Thanks!

@developers: Great PMS, but please check occasional.
Posts: 2
Joined: Mon Jan 28, 2013 7:34 pm

Return to Mac OS X Support

Who is online

Users browsing this forum: No registered users and 2 guests