Sony Bravia KDL-40EX713 .mkv issues.

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Sony Bravia KDL-40EX713 .mkv issues.

Postby spoon » Sun Feb 13, 2011 6:11 pm

Error I'm getting on some .mkv files:

Code: Select all
[New I/O server worker #1-2] TRACE 16:57:11.070 Starting transcode/remux of 100 Feet.mkv
[Thread-281] TRACE 16:57:19.616 Exception in thread "Thread-281" java.lang.NullPointerException
[Thread-281] TRACE 16:57:19.616    at net.pms.io.PipeIPCProcess.run(PipeIPCProcess.java:86)


Any ideas what's causing it?

Its roughly 50/50 i.e. half .mkvs will play just fine, half will not work throwing above error in the log files...




1- Your computer specs (cpu, memory, O/S) and the precise server version you're using (eg 1.10.51 or r409, not "latest version")

Code: Select all
cat /proc/cpuinfo
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 23
model name      : Pentium(R) Dual-Core  CPU      E5300  @ 2.60GHz
stepping        : 10
cpu MHz         : 2592.987
cache size      : 2048 KB


2- Device you are streaming to (PS3, XBox360, etc) and the .conf file if using a custom renderer profile

Sony Bravia KDL-40EX713 DLNA enabled TV, standard render for EX series TVs included.

3- Your local network setup (WAN/ISP bandwidth does not matter) including connection type (Wifi, homeplugs, 100mbit ethernet, gigabit) and what you're connected through (direct connection, switch, router) --> e.g. PC <-Wifi G-> Linksys WRT54G Router <-100mbps-> PS3


Gigabit throughout, TV --> D-Ling DIR 825 DD-WRT --> HP Procurve 1810G --> Linux box.

4- Which engine you are using if you're transcoding (MEncoder, AviSynth/MEncoder, TSmuxer)

MEncoder.

5- Detailed information on what is not working

As above.

6- A debug.log file excerpt or the whole file - viewtopic.php?f=6&t=3507&start=90#p38484

http://dl.dropbox.com/u/1471771/Forums/PMS/pms-2011-02-13.log

http://dl.dropbox.com/u/1471771/Forums/PMS/debug.log

7- The text output from MediaInfo (it's a program, click the link) can usually help figure out what's going on if you're having issues with a specific file or file type.

http://dl.dropbox.com/u/1471771/Forums/PMS/Amelia.txt

http://dl.dropbox.com/u/1471771/Forums/PMS/100%20Feet.txt
spoon
 
Posts: 18
Joined: Wed Mar 11, 2009 1:13 am

Re: Sony Bravia KDL-40EX713 .mkv issues.

Postby chocolateboy » Sun Feb 13, 2011 7:37 pm

Is your temp folder mounted on an external drive (or on any drive rather than tmpfs (i.e. RAM))? Looks like a named pipe is being read before mkfifo has finished creating it:

Code: Select all
[mkfifo] INFO  16:57:18.666 Starting mkfifo --mode=777 /tmp/javaps3media/1297616238572ffmpegvideo
[Thread-281] DEBUG 16:57:19.332 Opening file /tmp/javaps3media/1297616238572ffmpegvideo for reading...
[Thread-281] INFO  16:57:19.333 Error :/tmp/javaps3media/1297616238572ffmpegvideo (No such file or directory)


Failing that, try a more recent build (better diagnostics). The latest commit fixes that NullPointerException (though not the underlying issue), so you could start there. :-)
chocolateboy
Project Member
 
Posts: 2580
Joined: Wed Sep 16, 2009 10:05 am

Re: Sony Bravia KDL-40EX713 .mkv issues.

Postby spoon » Sun Feb 13, 2011 9:47 pm

chocolateboy wrote:Is your temp folder mounted on an external drive (or on any drive rather than tmpfs (i.e. RAM))? Looks like a named pipe is being read before mkfifo has finished creating it:

Code: Select all
[mkfifo] INFO  16:57:18.666 Starting mkfifo --mode=777 /tmp/javaps3media/1297616238572ffmpegvideo
[Thread-281] DEBUG 16:57:19.332 Opening file /tmp/javaps3media/1297616238572ffmpegvideo for reading...
[Thread-281] INFO  16:57:19.333 Error :/tmp/javaps3media/1297616238572ffmpegvideo (No such file or directory)



It looks that way...

Code: Select all
df -h
Filesystem                Size      Used Available Use% Mounted on
/dev/ram                124.0M    107.2M     16.7M  86% /
tmpfs                    32.0M    744.0k     31.3M   2% /tmp
/dev/sda4               310.0M    140.9M    169.0M  45% /mnt/ext


Is there any way to stop this from happening?

chocolateboy wrote:Failing that, try a more recent build (better diagnostics). The latest commit fixes that NullPointerException (though not the underlying issue), so you could start there. :-)


How do I apply this fix?

Thanks for your help.

Adrian
spoon
 
Posts: 18
Joined: Wed Mar 11, 2009 1:13 am

Re: Sony Bravia KDL-40EX713 .mkv issues.

Postby chocolateboy » Mon Feb 14, 2011 12:10 am

spoon wrote:How do I apply this fix?


viewtopic.php?f=3&t=4253

Or wait:

chocolateboy
Project Member
 
Posts: 2580
Joined: Wed Sep 16, 2009 10:05 am


Return to General Help and Support

Who is online

Users browsing this forum: Google [Bot], Topken and 4 guests