Web content will not stream

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Re: Cannot watch streams using PMS

Postby probotzor » Mon Jun 10, 2013 6:21 pm

thx but i still have the same problem

i downloaded required plugin and placed jar in plugins folder but it still says "this file cannot be played" or something like that :(
Posts: 4
Joined: Mon Jun 10, 2013 3:42 pm

Re: Cannot watch streams using PMS

Postby probotzor » Mon Jun 10, 2013 7:22 pm

sorry for double posting

here is debug.log https://mega.co.nz/#!s4QFCBbC!dz1MRxJJy ... rMZr_S-mc8

only youtube videos can be played
i hope you understand what is happening in that log ;(
Posts: 4
Joined: Mon Jun 10, 2013 3:42 pm

Re: Web content will not stream

Postby chocolateboy » Mon Jun 10, 2013 8:30 pm

I can't access that. Upload the debug.log and pmsencoder.log (and any relevant WEB.conf entries) to pastebin.com as requested in the instructions:

https://github.com/chocolateboy/pmsenco ... ing-issues
Project Member
Posts: 2581
Joined: Wed Sep 16, 2009 10:05 am

Re: Web content will not stream

Postby probotzor » Mon Jun 10, 2013 9:38 pm

i dont have pmsencoder.log
i searched everywhere and cant seem to find it

i uploaded my file to mega because pastebin wond let me do a thing...it just says "Oops! Google Chrome could not connect to pastebin.com"
i tried to play more videos and i could play only videos from youtube and some from other sites
but i cant manage to get tv streams working :(

can you maybe upload your web.conf? maybe there is problem with my links or something?
Posts: 4
Joined: Mon Jun 10, 2013 3:42 pm

Re: Web content will not stream

Postby marutzteo » Thu Jul 11, 2013 6:20 pm


I have a problem with playing youtube videos (the TED videos work)
I have looked through the troubleshooting steps adn could not fix the problem on my own
I am sorry I could not load the log files on pastebin (it doesn't respond).

I have uploaded an archive with the debu.log, pmsencoder.log and the WEB.conf I am using:
http://www.mediafire.com/download/och62 ... d_conf.zip
Posts: 1
Joined: Thu Jul 11, 2013 5:48 pm

PMSencoder and PMS 1.90.0

Postby Manco » Sat Aug 03, 2013 3:06 am

Does PMSencoder 1.6.3 work with PMS 1.90? I put it in the plugin folder but its not appearing in the engines list.
Posts: 20
Joined: Sat May 09, 2009 9:59 pm

PMS 1.90 and pmsencoder-1.6.3.jar

Postby keroppi » Sat Aug 03, 2013 3:39 am

i was using the old version with no complaint, but after upgrading, the follow exception appeared.

ERROR 2013-08-03 10:29:11.027 [main] PMSEncoder: error loading scripts
groovy.lang.MissingMethodException: No signature of method: net.pms.PMS.isWindows() is applicable for argument types: () values: []
at org.codehaus.groovy.runtime.ScriptBytecodeAdapter.unwrap(ScriptBytecodeAdapter.java:54) ~[pmsencoder-1.6.3.jar:na]
at org.codehaus.groovy.runtime.callsite.PojoMetaClassSite.call(PojoMetaClassSite.java:46) ~[pmsencoder-1.6.3.jar:na]
at org.codehaus.groovy.runtime.callsite.CallSiteArray.defaultCall(CallSiteArray.java:40) ~[pmsencoder-1.6.3.jar:na]

later on it gives "this file format is not recognized/supported" for youtube video, i am not sure this error was caused by the above "loading scripts" error as root cause.
please help

DEBUG 2013-08-03 10:38:19.444 [mencoder.exe-1] Starting "C:\Program Files\PS3 Media Server\win32\mencoder.exe" http://www.youtube.com/watch?v=L67800Bn ... tube_gdata -msglevel all=2 -quiet -prefer-ipv4 -cache 16384 -oac lavc -of lavf -lavfopts format=dvd -ovc lavc -lavcopts vcodec=mpeg2video:vbitrate=4096:threads=4:acodec=ac3:abitrate=128 -vf harddup -ofps 25 -o \\.\pipe\mencoder1375497499381
DEBUG 2013-08-03 10:38:19.444 [mencoder.exe-1] Reading pipe: \\.\pipe\mencoder1375497499381
INFO 2013-08-03 10:38:19.537 [mencoder.exe-1] Successfully initialized buffer to 50,000,000 bytes.
DEBUG 2013-08-03 10:38:19.537 [mencoder.exe-1] Attaching thread: mencoder.exe-1
DEBUG 2013-08-03 10:38:19.537 [Thread-18] MEncoder SB41 (C) 2000-2012 MPlayer Team
DEBUG 2013-08-03 10:38:19.537 [Thread-18] Custom build by SubJunk, http://www.spirton.com
DEBUG 2013-08-03 10:38:19.537 [Thread-18]
DEBUG 2013-08-03 10:38:19.959 [Thread-15] ============ Sorry, this file format is not recognized/supported =============
Posts: 5
Joined: Tue Jul 10, 2012 9:39 am

Re: PMS 1.90 and pmsencoder-1.6.3.jar

Postby Raptor399 » Sat Aug 03, 2013 9:29 am

Thanks for the heads up!

Looks like pmsencoder hasn't been updated to compensate for the breaking changes in the latest PMS yet.
I have committed a fix. It should be picked up by the snapshot build soon.
Project Member
Posts: 1916
Joined: Thu Mar 10, 2011 12:06 am

Re: PMSencoder and PMS 1.90.0

Postby Raptor399 » Sat Aug 03, 2013 9:31 am

Looks like it's not happy with one of our breaking changes. I have committed a fix that ought to be picked up by the snapshot build soon.
Project Member
Posts: 1916
Joined: Thu Mar 10, 2011 12:06 am

Re: Web content will not stream

Postby dsuchter » Mon Aug 05, 2013 12:03 am

I can't seem to get web streaming of any kind (audio or video) to work. Per the instructions at https://github.com/chocolateboy/pmsenco ... leshooting :

As you can see my WEB.conf contains quite a few examples I've found on the Internet, however, most of them are commented out. I've tried all of them and commented them out after failure in an attempt to keep my tests nice and clean. I'm using the PMSEncoder-tested Video Feeds as my general testbed.

As you can see from my logs I'm on the latest PMS and Java. I don't think you can see that my current VLC is Version 2.0.7 Twoflower (Intel 64bit). I'm streaming to an actual PS3 running v4.46 firmware, but I also have a Samsung PN59D7000 "Smart TV" and I see analogous errors when trying to view the PMS there via the Allshare app.

Interestingly the thumbnailing works just fine, as does the XML/RSS reading, so clearly my WEB.conf file format is at least somewhat reasonable.

I'm extremely confused about what the external dependencies are ("external" being defined as "things that didn't automagically come in the file pms-1.90.0-setup-macosx.tar.gz"). I notice the binary install method seems to have changed since my previous PMS install, which came in a file "pms-macosx-1.82.0.dmg". I have downloaded the ps3mencoder jar file and attempted to install it, however, I found the install instructions somewhat ambiguous for a novice like myself. For example, when the instructions say, "add mencoder_path" as follows to your PMS.conf it doesn't specify if one should be using absolute paths or relative ones. It also doesn't specify if I need to single, double, or no-quote the path string. Also, the file I downloaded is called "pmsencoder-1.6.3.jar" so do I need to rename it to just plain "pmsencoder.jar"?

I've pretty much experienced all the error messages I'm familiar with on my TV screen, but at the moment I'm getting "This content cannot be played. 800288E1" (previous I got the generic "data is corrupted" error).

Please halp? Thanks!
Posts: 16
Joined: Mon Feb 02, 2009 9:40 am


Return to General Help and Support

Who is online

Users browsing this forum: Google [Bot] and 12 guests