Web content will not stream

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Re: Web content will not stream

Postby chocolateboy » Sat Jan 23, 2010 4:48 pm

Patience :-) I'll release a new version later today with new installation instructions.
chocolateboy
Project Member
 
Posts: 2580
Joined: Wed Sep 16, 2009 10:05 am

Re: Web content will not stream

Postby shadowfire » Sat Jan 23, 2010 9:48 pm

Config: Win7 running on E8500/4GB/2x ATI5700, with ps3mencoder.bat+config installed and PS3MS 1.10.1 installed.

In which config file do I have problems when I start PS3MS and click on a youtube feed in the PS3 and get data corrupted on the PS3?
Debug log says:

Code: Select all
[Thread-60] DEBUG 21:42:44.932 Asked stream chunk [0-100000000000] timeseek: 0.0 of Dual Commentary :: Hutch and...Hutch's Mom? and player MEncoder Web
[Thread-60] TRACE 21:42:44.932 Starting transcode/remux of Dual Commentary :: Hutch and...Hutch's Mom?
[Thread-60] INFO  21:42:44.948 Creating pipe \\.\pipe\mencoder1264279364932
[Thread-62] INFO  21:42:44.948 Waiting for pipe connection \\.\pipe\mencoder1264279364932
[D:\PS3 Media Server\win32\ps3mencoder.bat] INFO  21:42:45.041 Starting D:\PS3 Media Server\win32\ps3mencoder.bat http://www.youtube.com/watch?v=C5m5Yx_amCw&feature=youtube_gdata -prefer-ipv4 -quiet -oac lavc -of lavf -lavfopts format=dvd -ovc lavc -lavcopts vcodec=mpeg2video:vbitrate=4096:threads=2:acodec=ac3:abitrate=128 -ofps 24000/1001 -o \\.\pipe\mencoder1264279364932
[D:\PS3 Media Server\win32\ps3mencoder.bat] INFO  21:42:45.072 Reading pipe: \\.\pipe\mencoder1264279364932
[Timer-0] DEBUG 21:42:45.182 Buffered Space: 0 bytes
[D:\PS3 Media Server\win32\ps3mencoder.bat] INFO  21:42:45.182 Attaching thread: D:\PS3 Media Server\win32\ps3mencoder.bat
[Timer-0] DEBUG 21:42:46.196 Buffered Space: 0 bytes
[Thread-63] DEBUG 21:42:46.461 D:\PS3 Media Server\win32\ps3mencoder.bat: 0.20: 2464: ERROR: can't find mencoder
[Thread-63] DEBUG 21:42:46.476 'feature' is not recognized as an internal or external command,
[Thread-63] DEBUG 21:42:46.476 operable program or batch file.
[Timer-0] DEBUG 21:42:47.210 Buffered Space: 0 bytes
[D:\PS3 Media Server\win32\ps3mencoder.bat] DEBUG 21:42:47.491 EOF
[D:\PS3 Media Server\win32\ps3mencoder.bat] TRACE 21:42:47.491 Process D:\PS3 Media Server\win32\ps3mencoder.bat has a return code of 1! Maybe an error occured... check the log file


Mencoder logfile says:
Code: Select all
2010-01-23 21:49:25: 0.20: 2804: D:\PS3 Media Server\win32\ps3mencoder.bat http://www.youtube.com/watch?v=13g_G3NJi0o
2010-01-23 21:49:25: 0.20: 2804: loading config: ps3mencoder.conf
2010-01-23 21:49:25: 0.20: 2804: matched profile: Global
2010-01-23 21:49:25: 0.20: 2804: adding -cache 16384
2010-01-23 21:49:25: 0.20: 2804: ERROR: can't find mencoder
shadowfire
 
Posts: 2
Joined: Sat Jan 23, 2010 9:12 pm

Re: Web content will not stream

Postby shadowfire » Sat Jan 23, 2010 10:03 pm

Additional info: I've tried adding the path to the ps3mencoder.conf without success.

I opened the conf file and entered:

Code: Select all
mencoder_path: D:\PS3 Media Server\win32\mencoder.exe
shadowfire
 
Posts: 2
Joined: Sat Jan 23, 2010 9:12 pm

Re: Web content will not stream

Postby chocolateboy » Sun Jan 24, 2010 10:25 am

New version (0.40) uploaded. Please read the installation instructions carefully as they've changed significantly since the last version(s).

http://github.com/chocolateboy/ps3mencoder

Note: Apple Trailers don't currently work. It's not a ps3mencoder/mencoder issue; I can't even get them to work with Apple's QuickTime player at the moment...
chocolateboy
Project Member
 
Posts: 2580
Joined: Wed Sep 16, 2009 10:05 am

Re: Web content will not stream

Postby freddo1981 » Sun Jan 24, 2010 12:17 pm

Thanks Chocolateboy for the updates.

However whilst i can get PMS to work for local streaming from my Laptop the web streaming does not work. I am a complete novice with code etc. I have tried to follow the instructions and think i get what i need to do especially with the new updated method.

I do not have a PMS.conf file in the PMS Media Server directory. I have looked everywhere for it to no avail. Is there somewhere i can get an original working file?

When i get one i take it all i need do is use a text editor to add that extra line of code into the PMS.conf file.

mencoder_path = C:\\Program Files\\PS3MEncoder\\ps3mencoder.exe

Literally just paste is in anywhere???

Many thanks for anyones help.
freddo1981
 
Posts: 5
Joined: Thu Jan 21, 2010 8:14 pm

Re: Web content will not stream

Postby chocolateboy » Sun Jan 24, 2010 5:13 pm

freddo1981 wrote:I do not have a PMS.conf file in the PMS Media Server directory. I have looked everywhere for it to no avail.


Try following the instructions here. If you can't find it, it may be that the account you're using doesn't have permission to create the file in the PMS directory. You could try following the installation instructions while logged in as Administrator.

When i get one i take it all i need do is use a text editor to add that extra line of code into the PMS.conf file.

mencoder_path = C:\\Program Files\\PS3MEncoder\\ps3mencoder.exe

Literally just paste is in anywhere???


If it doesn't exist already, add it at the end so you can easily find and remove it if you need to. You can also add a short comment if you like. Comments should appear on separate lines with a hash (#) character at the start of the line e.g.

Code: Select all
thumbnails = true
alternativeffmpegpath = C:\\Program Files\\PS3 Media Server\\win32\\dvrms\\ffmpeg_MPGMUX.exe
# added by freddo1981: use ps3mencoder for web video streaming
mencoder_path = C:\\Program Files\\PS3MEncoder\\ps3mencoder.exe


From this thread:

freddo1981 wrote:I have ConTEXT to edit script.


You don't need a special text editor to edit a configuration file. You can use Notepad or Wordpad. If you know how to post a comment here then you know how to edit a simple text file.

Don't just copy and paste a PMS.conf, though. You'll need to follow the instructions to set MEncoder as your default Web streaming engine in PMS. A copied PMS.conf may not have the same list of "engines" in the same order. Likewise, someone else's PMS.conf may have network or sharing options that are different to yours. You're better off letting PMS create the file, and then adding the single option for mencoder_path.
Last edited by chocolateboy on Sun Jan 24, 2010 7:37 pm, edited 1 time in total.
chocolateboy
Project Member
 
Posts: 2580
Joined: Wed Sep 16, 2009 10:05 am

Re: Web content will not stream

Postby spiders » Sun Jan 24, 2010 6:07 pm

hmm with this new ps3 mencoder installer I still cannot get youtube videos to work :(

i can see youtube and can see the image of the video, when I click on it to play I just get a blank screen.

also now the ps3 media server says it cannot find my ps3, even though the ps3 can see the media server and plays movies fine.

config is as follows :

thumbnails = true
alternativeffmpegpath = h:\\ps3m\\win32\\dvrms\\ffmpeg_MPGMUX.exe
mencoder_path = C:\\Program Files (x86)\\PS3MEncoder\\ps3mencoder.exe
mencoder_ass = true
engines = mencoder,avsmencoder,tsmuxer,mplayeraudio,ffmpegaudio,tsmuxeraudio,mencoderwebvideo,vlcvideo,mplayervideodump,mplayerwebaudio,vlcaudio,ffmpegdvrmsremux,rawthumbs


have looked at the debug.log and cannot find any errors in there about youtube playback

I am now confused
spiders
 
Posts: 9
Joined: Tue Jan 19, 2010 8:01 pm

Re: Web content will not stream

Postby chocolateboy » Sun Jan 24, 2010 7:07 pm

spiders wrote:have looked at the debug.log and cannot find any errors in there about youtube playback


Try it from the command line. Copy the options ps3mencoder was called with from the debug.log or ps3mencoder.log (change the output file i.e. the -o option) and see what it says. e.g.

Code: Select all
> cd h:\ps3m
> "C:\Program Files (x86)\PS3MEncoder\ps3mencoder.exe" "http://www.youtube.com/watch?v=5jPZpptlABM&feature=youtube_gdata" -prefer-ipv4 -nocache -quiet -oac lavc -of lavf -lavfopts format=dvd -ovc lavc -lavcopts vcodec=mpeg2video:vbitrate=4096:threads=2:acodec=ac3:abitrate=128 -ofps 24000/1001 -o deleteme.mpg


Failing that: Close PMS. Delete the debug log and ps3mencoder.log. Start PMS and try to play a YouTube video. Upload the debug.log and ps3mencoder.log.
chocolateboy
Project Member
 
Posts: 2580
Joined: Wed Sep 16, 2009 10:05 am

Re: Web content will not stream

Postby spiders » Sun Jan 24, 2010 8:36 pm

ok from the command line it works fine

2010-01-24 19:30:14: 0.40: 4228: C:/PROGRA~2/PS3MEN~1/ps3mencoder.exe http://www.youtube.com/watch?v=5jPZpptl ... tube_gdata -prefer-ipv4 -nocache -quiet -oac lavc -of lavf -lavfopts format=dvd -ovc lavc -lavcopts vcodec=mpeg2video:vbitrate=4096:threads=2:acodec=ac3:abitrate=128 -ofps 24000/1001 -o deleteme.mpg
2010-01-24 19:30:14: 0.40: 4228: loading config: C:/PROGRA~2/PS3MEN~1/res/ps3mencoder.conf
2010-01-24 19:30:14: 0.40: 4228: matched profile: Global
2010-01-24 19:30:14: 0.40: 4228: adding -vf harddup
2010-01-24 19:30:14: 0.40: 4228: removing -nocache
2010-01-24 19:30:14: 0.40: 4228: setting -ofps to 24
2010-01-24 19:30:14: 0.40: 4228: removing -quiet
2010-01-24 19:30:14: 0.40: 4228: adding -cache 32768
2010-01-24 19:30:16: 0.40: 4228: exec: C:/PROGRA~2/PS3MEN~1/res/mencoder.exe "http://www.youtube.com/get_video?fmt=18&video_id=5jPZpptlABM&t=vjVQa1PpcFNF5ujHhSbw980t2UPpXqr60NRPBTHcHBs%3D" -prefer-ipv4 -oac lavc -of lavf -lavfopts format=dvd -ovc lavc -lavcopts vcodec=mpeg2video:vbitrate=4096:threads=2:acodec=ac3:abitrate=128 -ofps 24 -o deleteme.mpg -vf harddup -cache 32768
2010-01-24 19:35:40: 0.40: 4228: ok

will delete the log files and try a youtube video
spiders
 
Posts: 9
Joined: Tue Jan 19, 2010 8:01 pm

Re: Web content will not stream

Postby freddo1981 » Sun Jan 24, 2010 9:19 pm

The ps3mencoder installer seems to be corrupt. I managed to download it earlier but deleted it and now after downloading it when i go to install it it says it is corrupt and to get another copy.

Anyone else find this?
freddo1981
 
Posts: 5
Joined: Thu Jan 21, 2010 8:14 pm

PreviousNext

Return to General Help and Support

Who is online

Users browsing this forum: Bing [Bot] and 17 guests