Web content will not stream

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Re: Web content will not stream

Postby lovswr » Sun Jan 10, 2010 2:48 pm

chocolateboy, thanks for all your help. With your latest version of ps3mencoder, everything works. I am now streaming from the Apple-HD movie trailer site & just about everywhere else too. Again thank you! :)
lovswr
 
Posts: 31
Joined: Mon Jan 19, 2009 5:00 pm

Re: Web content will not stream

Postby beagle » Mon Jan 11, 2010 12:40 am

Since downloading the latest .exe of ps3mencoder all files that require encoding including videos have stopped working. It appears to be a problem with the new .exe

When running ps3mencoder at the cmd prmpt it gives:

Code: Select all
Can't locate URI.pm in @INC (@INC contains: CODE(0x13fc2a4) C:\DOCUME~1\Steven\L
OCALS~1\Temp\par-Steven\cache-408a604d86181d5a2d2eb53e2bf37efffad45eda\inc\lib C
:\DOCUME~1\Steven\LOCALS~1\Temp\par-Steven\cache-408a604d86181d5a2d2eb53e2bf37ef
ffad45eda\inc CODE(0xdf80ac) CODE(0xdf83ac)) at (eval 25) line 3.
Compilation failed in require at HTTP/Request.pm line 3.
Compilation failed in require at LWP/UserAgent.pm line 10.
BEGIN failed--compilation aborted at LWP/UserAgent.pm line 10.
Compilation failed in require at LWP/Simple.pm line 26.
BEGIN failed--compilation aborted at LWP/Simple.pm line 26.
Compilation failed in require at script/ps3mencoder line 11.
BEGIN failed--compilation aborted at script/ps3mencoder line 11.


The previous .exe that required the perl file worked, is it possible to make this one accessable again as I've deleted it while we try to identify the issue with this version.
beagle
 
Posts: 15
Joined: Fri Dec 18, 2009 10:25 am

Re: Web content will not stream

Postby chocolateboy » Mon Jan 11, 2010 12:57 am

beagle wrote:is it possible to make this one accessable again as I've deleted it while we try to identify the issue with this version.


Sure is.

You can get any old versions on GitHub by clicking "history" and selecting the appropriate "tree" link. To download the file, click "raw". There's also a "Download Source" link at the top of each page if you want to download a .zip file or tarball of the repository.
Last edited by chocolateboy on Mon Jan 11, 2010 1:17 am, edited 1 time in total.
chocolateboy
Project Member
 
Posts: 2580
Joined: Wed Sep 16, 2009 10:05 am

Re: Web content will not stream

Postby beagle » Mon Jan 11, 2010 1:15 am

Interestingly the same is now occuring when I run the old version in cmd.

I've unistalled and reinstalled perl but no change. It was all working well before. Not sure whats happened, any ideas??????
beagle
 
Posts: 15
Joined: Fri Dec 18, 2009 10:25 am

Re: Web content will not stream

Postby beagle » Tue Jan 12, 2010 12:52 pm

Has anybody else come across the problem I am experiencing and more importantly how to solve it.

I have even tried installing URI.pm in the location that its is looking but even this fails to resolve the problem. I've uninstalled and re-installed Java, Ps3media and Perl with no results.

The error is occuring for both the .exe ps3mencoder versions.

Arrrrrgggghhhh it was working before!!!!!
beagle
 
Posts: 15
Joined: Fri Dec 18, 2009 10:25 am

Re: Web content will not stream

Postby lovswr » Sat Jan 16, 2010 3:52 am

Well Windows guys you are not alone. The lastest ps3mencoder for linux (from 9 Jan 2010) is not working either. I had to revert back to an older source also.
lovswr
 
Posts: 31
Joined: Mon Jan 19, 2009 5:00 pm

Re: Web content will not stream

Postby chocolateboy » Sat Jan 16, 2010 3:57 am

lovswr wrote:Well Windows guys you are not alone. The lastest ps3mencoder for linux (from 9 Jan 2010) is not working either. I had to revert back to an older source also.


You said it was working for you last week. What error did you get?

Note: if PMS behaves unpredictably, the best bet is to restart PMS. ps3mencoder is just a simple wrapper around mencoder that fixes and optimizes the command line options supplied by PMS, and adds some special handling for YouTube videos. It shouldn't introduce behaviour that isn't already there with mencoder, and won't fix issues that are unrelated to mencoder web video streaming.
Last edited by chocolateboy on Sat Jan 16, 2010 4:41 am, edited 2 times in total.
chocolateboy
Project Member
 
Posts: 2580
Joined: Wed Sep 16, 2009 10:05 am

Re: Web content will not stream

Postby chocolateboy » Sat Jan 16, 2010 4:07 am

beagle wrote:Has anybody else come across the problem I am experiencing and more importantly how to solve it.

I have even tried installing URI.pm in the location that its is looking but even this fails to resolve the problem. I've uninstalled and re-installed Java, Ps3media and Perl with no results.

The error is occuring for both the .exe ps3mencoder versions.

Arrrrrgggghhhh it was working before!!!!!


I haven't had a chance to run ps3mencoder.exe with Strawberry Perl completely uninstalled. But it runs fine for me if I rename the perl directory e.g. C:\strawberry.old, so it's not relying on perl or any Perl libraries. I'll have a go at running the .exe on a clean XP at some stage, but I doubt it'll make a difference.
chocolateboy
Project Member
 
Posts: 2580
Joined: Wed Sep 16, 2009 10:05 am

Re: Web content will not stream

Postby otmanix » Sat Jan 16, 2010 9:09 am

I provide NO application support via PM, so please post your question to the forum.
PS3 Media Server related articles on my blog: http://otmanix.de/?cat=11&lang=en
User avatar
otmanix
 
Posts: 528
Joined: Fri Jan 30, 2009 12:40 am
Location: Bavaria, Germany

Re: Web content will not stream

Postby lovswr » Sat Jan 16, 2010 1:02 pm

chocolateboy wrote:
lovswr wrote:Well Windows guys you are not alone. The lastest ps3mencoder for linux (from 9 Jan 2010) is not working either. I had to revert back to an older source also.


You said it was working for you last week. What error did you get?

Note: if PMS behaves unpredictably, the best bet is to restart PMS. ps3mencoder is just a simple wrapper around mencoder that fixes and optimizes the command line options supplied by PMS, and adds some special handling for YouTube videos. It shouldn't introduce behaviour that isn't already there with mencoder, and won't fix issues that are unrelated to mencoder web video streaming.



Well, the software updater kept bugging me for several days & I finally let it upgrade to a new kernel. After that the ps3mencoder of Jan 9th kept returning the error that it did not recognize that file type whenever I tried to play .MOV files. When I went back to the previous version of ps3mencoder, everything was good again.

example:

when I run the following from a terminal with the Jan 9th ver of ps3mencoder
Code: Select all
ps3mencoder http://movies.apple.com/movies/wb/inception/inception-tlr2_h640w.mov -prefer-ipv4 -nocache -quiet -oac lavc -of lavf -lavfopts format=dvd -ovc lavc -lavcopts vcodec=mpeg2video:vbitrate=4096:threads=2:acodec=ac3:abitrate=128 -ofps 24000/1001 -o deleteme.mov



I get the following:
Code: Select all
MEncoder SVN-r30314-4.4.1 (C) 2000-2009 MPlayer Team
Resolving movies.apple.com for AF_INET...
Connecting to server movies.apple.com[204.2.254.106]: 80...
Resolving www.apple.com for AF_INET...
Connecting to server www.apple.com[96.16.37.15]: 80...
Cache size set to 16384 KBytes
success: format: 0  data: 0x0 - 0x5e7b

============ Sorry, this file format is not recognized/supported =============
=== If this file is an AVI, ASF or MPEG stream, please contact the author! ===
Cannot open demuxer


when I use the previous version of ps3mencoder, I get no errors & that file is encoded/created.
lovswr
 
Posts: 31
Joined: Mon Jan 19, 2009 5:00 pm

PreviousNext

Return to General Help and Support

Who is online

Users browsing this forum: Alexa [Bot] and 14 guests