Web content will not stream

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Re: Web content will not stream

Postby chocolateboy » Sun Feb 27, 2011 9:42 pm

pmsencoder.log

Twosheds wrote:
Code: Select all
setting global variable: SOPCAST = null
[...]
0 matches for: http://127.0.0.1:8902/stream



If you want to start/stop SopCast.exe for each request, you'll need to a) set sopcast.path as per the release notes and b) set the WEB.conf entry to e.g.:

Code: Select all
videostream.Web,SopCast=SopCast,sop://sop.sopcast.org:1234/5678


(These don't apply if you've already started/configured the SopCast server manually.)

debug.log

Code: Select all
Starting PS3 Media Server (SubJunk Build) 1.21.0-SB15
[...]
Process C:\Program Files\PS3 Media Server\win32\ffmpeg.exe has a return code of 255!



There's a known issue with ffmpeg on Windows in recent (i.e. post-beta) builds. See the new Known Issues section of the release notes.
chocolateboy
Project Member
 
Posts: 2579
Joined: Wed Sep 16, 2009 10:05 am

Re: Web content will not stream

Postby grolschie » Mon Feb 28, 2011 5:52 am

Hello. The new version of pmsencoder doesn't work for me. Well it does, but I suspect that the format being sent to my blu-ray player isn't recognised. The logs seem fine, and running the ffmpeg command from the commandline works. Is there any way to set the output format in pmsencoder?
grolschie
 
Posts: 263
Joined: Thu Jun 10, 2010 7:05 am

Re: Web content will not stream

Postby brotherjohn » Mon Feb 28, 2011 8:20 am

OK, I understand. No one even choc has a solution to my error- So I switched back to 1.4.0 which works for me. I will wait. :(
brotherjohn
 
Posts: 146
Joined: Wed Sep 15, 2010 9:13 am

Re: Web content will not stream

Postby brotherjohn » Mon Feb 28, 2011 5:56 pm

brotherjohn wrote:Hi chocolateboy,
I always get the same error with playing videos from Gamestar, Gameswelt, PCGames, WinFuture, GameTrailers.
Here is the snippet from debug.log:
Code: Select all
[New I/O server worker #1-4] TRACE 23:37:24.088 Starting transcode/remux of Crysis 2 - »Be Invisible«-Trailer
[New I/O server worker #1-4] INFO  23:37:24.090 Creating pipe \\.\pipe\pmsencoder_transcoder_out_1298759844088_36
[Thread-19] INFO  23:37:24.093 Waiting for pipe connection \\.\pipe\pmsencoder_transcoder_out_1298759844088_36
[win32\ffmpeg.exe] INFO  23:37:25.670 Starting C:\Program Files\PS3 Media Server\win32\ffmpeg.exe -v 0 -y -threads 2 -i "http://download.gamestar.de/public/53500/53577/Crysis-2-Be-Invisible-Trailer.mp4" -threads 2 -target pal-dvd \\.\pipe\pmsencoder_transcoder_out_1298759844088_36
[win32\ffmpeg.exe] INFO  23:37:25.678 Reading pipe: \\.\pipe\pmsencoder_transcoder_out_1298759844088_36
[win32\ffmpeg.exe] INFO  23:37:25.795 Attaching thread: win32\ffmpeg.exe
[Timer-1] DEBUG 23:37:25.800 Buffered Space: 0 bytes / inputs: 0
[New I/O server worker #1-4] DEBUG 23:37:25.870 Sleeping for 6000 milliseconds
[Timer-1] DEBUG 23:37:27.804 Buffered Space: 0 bytes / inputs: 0
[Timer-1] DEBUG 23:37:29.804 Buffered Space: 0 bytes / inputs: 0
[Timer-1] DEBUG 23:37:31.804 Buffered Space: 0 bytes / inputs: 0
[New I/O server worker #1-4] DEBUG 23:37:31.871 Finished sleeping for 6000 milliseconds
[New I/O server worker #1-4] DEBUG 23:37:31.871 Ready to Stop: true
[New I/O server worker #1-4] DEBUG 23:37:31.871 Sent to socket: Accept-Ranges: bytes
[New I/O server worker #1-4] DEBUG 23:37:31.871 Sent to socket: Connection: keep-alive
[New I/O server worker #1-4] DEBUG 23:37:31.871 Sent to socket: Content-Type: video/mpeg
[New I/O server worker #1-4] DEBUG 23:37:31.871 Sent to socket: ContentFeatures.DLNA.ORG: DLNA.ORG_PN=MPEG_PS_NTSC;DLNA.ORG_OP=01;DLNA.ORG_CI=0;DLNA.ORG_FLAGS=01700000000000000000000000000000
[New I/O server worker #1-4] DEBUG 23:37:31.871 Sent to socket: Server: Windows_7-x86-6.1, UPnP/1.0, PMS/1.21.0
[New I/O server worker #1-4] DEBUG 23:37:31.871 Sent to socket: TransferMode.DLNA.ORG: Streaming
[New I/O server worker #1-1] DEBUG 23:37:31.881 Opened request handler on socket /192.168.178.90:57771 // Sony Bravia EX
[New I/O server worker #1-1] DEBUG 23:37:31.881 Request: HTTP/1.1 : GET : get/0$8$4$0$0/Crysis+2+-+%C2%BBBe+Invisible%C2%AB-Trailer
[New I/O server worker #1-1] DEBUG 23:37:31.881 Received on socket: getcontentFeatures.dlna.org: 1
[New I/O server worker #1-1] DEBUG 23:37:31.881 Received on socket: Host: 192.168.178.109:5001
[New I/O server worker #1-1] DEBUG 23:37:31.881 Received on socket: Pragma: getIfoFileURI.dlna.org
[New I/O server worker #1-1] DEBUG 23:37:31.881 Received on socket: Range: bytes=0-
[New I/O server worker #1-1] DEBUG 23:37:31.881 Received on socket: transferMode.dlna.org: Streaming
[New I/O server worker #1-1] DEBUG 23:37:31.881 Received on socket: X-AV-Client-Info: av=5.0; cn="Sony Corporation"; mn="BRAVIA KDL-40EX505"; mv="1.7";
[New I/O server worker #1-1] DEBUG 23:37:31.881 Received on socket: X-AV-Physical-Unit-Info: pa="BRAVIA KDL-40EX505";
[New I/O server worker #1-1] INFO  23:37:31.881 HTTP: get/0$8$4$0$0/Crysis+2+-+%C2%BBBe+Invisible%C2%AB-Trailer / 0-100000000000
[New I/O server worker #1-1] DEBUG 23:37:31.881 Searching for objectId: 0$8$4$0$0 with children option: false
[New I/O server worker #1-1] DEBUG 23:37:31.881 Asked stream chunk [0-100000000000] timeseek: 0.0 of Crysis 2 - »Be Invisible«-Trailer and player PMSEncoder
[New I/O server worker #1-1] DEBUG 23:37:31.881 Ready to Stop: false
[New I/O server worker #1-1] DEBUG 23:37:31.881 Suspend Read: readCount=0 / writeCount=0
[Timer-1] DEBUG 23:37:33.804 Buffered Space: 0 bytes / inputs: 1
[Timer-1] DEBUG 23:37:35.804 Buffered Space: 0 bytes / inputs: 1
[Timer-1] DEBUG 23:37:37.804 Buffered Space: 0 bytes / inputs: 1
[New I/O server worker #1-1] DEBUG 23:37:39.381 Resume Read: readCount=0 / writeCount=0
[New I/O server worker #1-1] DEBUG 23:37:39.381 Suspend Read: readCount=1 / writeCount=0
[Timer-1] DEBUG 23:37:39.804 Buffered Space: -1 bytes / inputs: 1
[Timer-1] DEBUG 23:37:41.804 Buffered Space: -1 bytes / inputs: 1
[Timer-1] DEBUG 23:37:43.804 Buffered Space: -1 bytes / inputs: 1
[win32\ffmpeg.exe] DEBUG 23:37:45.735 EOF
[win32\ffmpeg.exe] TRACE 23:37:45.735 Process C:\Program Files\PS3 Media Server\win32\ffmpeg.exe has a return code of -1073741819! Maybe an error occured... check the log file

Another thing is, in the log tab, I can't see the messages of loading the .groovy scripts. Could you please help me?
EDIT: I've taken the scripts from here.
EDIT 2.: I see. The messages of loading the scripts is now in the pmsencoder.log. But the ffmpeg error is still present.

:D It works with 1.21.0 r509.
brotherjohn
 
Posts: 146
Joined: Wed Sep 15, 2010 9:13 am

Re: Web content will not stream

Postby genie » Mon Feb 28, 2011 6:07 pm

Using the default sopcast.groovy file when I try to play the stream I get:

Code: Select all
2011-02-28 12:06:59 [INFO|PMSEncoder|launchTranscode|New I/O server worker #1-2]: invoking matcher for: sop://broker1.sopcast.com:3912/85856
2011-02-28 12:06:59 [DEBUG|Matcher|match|New I/O server worker #1-2]: matching URI: sop://broker1.sopcast.com:3912/85856
2011-02-28 12:06:59 [DEBUG|Profile|match|New I/O server worker #1-2]: matching profile: navix://
2011-02-28 12:06:59 [DEBUG|Profile|runPatternBlock|New I/O server worker #1-2]: match navix://: failure
2011-02-28 12:06:59 [DEBUG|Profile|match|New I/O server worker #1-2]: matching profile: Chase Redirects
2011-02-28 12:06:59 [DEBUG|Matcher|matchString|New I/O server worker #1-2]: matching sop://broker1.sopcast.com:3912/85856 against ^https?://(\w+\.)*rss\.feedsportal\.com(/|$)
2011-02-28 12:06:59 [ERROR|PMSEncoder|launchTranscode|New I/O server worker #1-2]: match error: org.codehaus.groovy.runtime.InvokerInvocationException: java.lang.ExceptionInInitializerError


My web.conf line has:

Code: Select all
videostream.Web: Video,Sopcast,Test=Sopcast,sop://broker1.sopcast.com:3912/85856


Am I doing anything wrong?
genie
 
Posts: 35
Joined: Mon Dec 07, 2009 8:33 pm

Re: Web content will not stream

Postby chocolateboy » Mon Feb 28, 2011 6:26 pm

chocolateboy
Project Member
 
Posts: 2579
Joined: Wed Sep 16, 2009 10:05 am

Re: Web content will not stream

Postby genie » Mon Feb 28, 2011 7:11 pm

Please see attached the logs, conf files and sopcast.groovy
Attachments
pmsencoder.zip
(12.44 KiB) Downloaded 61 times
genie
 
Posts: 35
Joined: Mon Dec 07, 2009 8:33 pm

Re: Web content will not stream

Postby chocolateboy » Mon Feb 28, 2011 8:33 pm

genie wrote:Please see attached the logs, conf files and sopcast.groovy


Please remove sopcast.groovy. I've updated the Release Notes to make it even more clear that people should stop doing something they were never told to do.

As for the error: I can't reproduce it on Windows or Linux. Are you using a custom build of PMSEncoder? If so, it's corrupt/broken. Try (re-)downloading the PMSEncoder .jar file.
chocolateboy
Project Member
 
Posts: 2579
Joined: Wed Sep 16, 2009 10:05 am

Re: Web content will not stream

Postby sesemin » Mon Feb 28, 2011 8:47 pm

Hi Infidle,

Can you tell me how pmsencoder calls the script. I followed your instruction but it does not seem to work! Thanks

Here's a generic script (place inside your pmsencoder folder and edit its rtmpdump path as appropriate) to launch rtmpdump commands from WEB.conf :
sesemin
 
Posts: 9
Joined: Sat Jul 10, 2010 5:17 am

Re: Web content will not stream

Postby infidel » Mon Feb 28, 2011 11:12 pm

sesemin wrote: I followed your instruction but it does not seem to work!
Can you attach a zip containing your whatever.groovy+debug.log+pmsencoder.log+WEB.conf+PMS.conf? Without that it's difficult to know what the precise problem might be. PMSEncoder is in a constant state of flux thanks to chocolateboy's ongoing improvements, so it may just be due to version incompatibility. Or of course it could be the the commandline itself.
infidel
 
Posts: 278
Joined: Sun Aug 15, 2010 4:56 pm

PreviousNext

Return to General Help and Support

Who is online

Users browsing this forum: Google [Bot] and 8 guests