Can't get Web TV to work < no errors in the trace log

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Can't get Web TV to work < no errors in the trace log

Postby buju » Sun Feb 22, 2009 7:14 am

This is what I see in the log: [Thread-69] TRACE 01:05:05.140 Starting transcode/remux of France 24
As you can see I get no error, but I see no pic on PS3, "the data is corrupted" message on PS3, 0 kbps bitrate in PMS status, YET, I CAN see the video in VLC.
I have tried using as web streaming engines both VLS and mencoder/ mplayer - nothing works - same result.

What gives? Since these are the default URL's used in PMS I was sure they'd be working..
Any help would be greatly appreciated. I am a big consumer of Internet TV..

Thanks.
Windows XP SP3, Intel Core 2 T5600 1.83 GHz, 1GB
LAN: 1 Gbps + 11N (oodles of throughput), WAN: 5.14/.580 Mbps <consistent
PMS 1.10, VLC web streaming
Video file engines: 1) TSMuxer, 2) MEncoder
Audio file engines: 1) MPlayer Audio, 2) FFmpeg Audio
buju
 
Posts: 37
Joined: Tue Feb 10, 2009 6:25 pm

Re: Can't get Web TV to work < no errors in the trace log

Postby buju » Mon Feb 23, 2009 5:29 am

Anyone?
Windows XP SP3, Intel Core 2 T5600 1.83 GHz, 1GB
LAN: 1 Gbps + 11N (oodles of throughput), WAN: 5.14/.580 Mbps <consistent
PMS 1.10, VLC web streaming
Video file engines: 1) TSMuxer, 2) MEncoder
Audio file engines: 1) MPlayer Audio, 2) FFmpeg Audio
buju
 
Posts: 37
Joined: Tue Feb 10, 2009 6:25 pm

Re: Can't get Web TV to work < no errors in the trace log

Postby whome » Mon Feb 23, 2009 8:53 am

Do not count on default URLs working properly, web sources come and go. Please tell us an exact url you use.
* exact url address
* your system props (OS, VLC version, ps3ms version, ..)

Try this one: videofeed.Web=http://koti.mbnet.fi/akini/ps3/rss-simple_video.xml

Not all links work outside Finland, but third one "Yle Extrat Sirkus, Uutisvuoto, Jääkiekko, Kuudes aisti, Reinikainen" video stream should work. It's wmv using a mms:// protocol.

I have quite many web sources that work fine in VLC standalone player, but VLC streaming does not work. One think I know is .asx sources play fine in VLC but unable to stream from .asx urls. Streaming requires us to use a direct ref address found inside the .asx file.

Examples from http://areena.yle.fi media site (for finnish people really):
http://areena.yle.fi/toista?id=1582073
- main page has MSMediaPlayer plugin stream, uses .asx url

http://www.yle.fi/java/areena/dispatche ... ?bitrate=1
- this is what MSMediaPlayer is using, this .asx file is actually a XML document

http://mediak.yle.fi/media/areena/1/58/ ... 962975.wmv
- this is an actual asx reference within .asx file

mms://mediak.yle.fi/media/areena/1/58/2 ... 962975.wmv
- but to make VLC streaminig work properly we must give it as mms:// protocol url :-(

YleAreena streaming converter
Converter graps html page and creates rss-feed document at runtime, using mms:// url reference. This is just to make an example that VLC standalone may work fine but streaming is a whole new beast :-(
whome
 
Posts: 113
Joined: Tue Jan 20, 2009 12:26 am

Re: Can't get Web TV to work < no errors in the trace log

Postby buju » Mon Feb 23, 2009 6:38 pm

[A few edits, after seeing that I did not address a couple of points in your message]

Thanks for your reply whome.

The streams are the default PMS ones:
#internet tvs
videostream.Web,TVs=France 24,mms://stream1.france24.yacast.net/f24_liveen,http://www.france24.com/en/sites/all/themes/france24/en/images/brand.gif
videostream.Web,TVs=BFM TV (French TV),mms://vipmms9.yacast.net/bfm_bfmtv,http://upload.wikimedia.org/wikipedia/fr/3/30/Bfm_tv.jpg

OS: XP SP3

I have tried the mplayer/ mencoder engines as well. I normally stick with VLC, as I know that the streams work in it, and eventually, once I get the basic streaming figured out, I will try more fancy streams (maybe even nsv).

The links above are not asx streams. At this point I am just trying to get to stream any TV stream...
With TVersity I can stream any TV stream. But I want to dump TVersity so that I can use just one server - and that is surely PMS.

I will do some testing later on, using your links. Thanks.

PS: The XML file will surely get my creative juices flowing, for sure :D But that is for later on.


Thanks.
Windows XP SP3, Intel Core 2 T5600 1.83 GHz, 1GB
LAN: 1 Gbps + 11N (oodles of throughput), WAN: 5.14/.580 Mbps <consistent
PMS 1.10, VLC web streaming
Video file engines: 1) TSMuxer, 2) MEncoder
Audio file engines: 1) MPlayer Audio, 2) FFmpeg Audio
buju
 
Posts: 37
Joined: Tue Feb 10, 2009 6:25 pm

Re: Can't get Web TV to work < no errors in the trace log

Postby whome » Mon Feb 23, 2009 7:20 pm

I tried both videostream you gave in a post and worked fine here. My setup:
WinXP-SP3, VLC0.9.8a, PS3MS is taken and compiled from cvs (=should not matter much in this case?).

Is it you have installed VLC from setup.exe so its registered. PS3MS finds a location of the vlc.exe using a winregistry.
whome
 
Posts: 113
Joined: Tue Jan 20, 2009 12:26 am

Re: Can't get Web TV to work < no errors in the trace log

Postby buju » Mon Feb 23, 2009 7:34 pm

You raised a very good point - with regards to the VLC install.
I did have initial issues with that - the VLC would not be sensed as an available engine in PMS, but that was when I was using the portable VLC version.
Since I have installed/ registered the latest 0.98 from the VLC webpage and VLC is seen just OK.
Is there any way to debug this?

The engine is seen, I have it set as top priority for both video and audio and it does not work.
Thanks.
Windows XP SP3, Intel Core 2 T5600 1.83 GHz, 1GB
LAN: 1 Gbps + 11N (oodles of throughput), WAN: 5.14/.580 Mbps <consistent
PMS 1.10, VLC web streaming
Video file engines: 1) TSMuxer, 2) MEncoder
Audio file engines: 1) MPlayer Audio, 2) FFmpeg Audio
buju
 
Posts: 37
Joined: Tue Feb 10, 2009 6:25 pm

Re: Can't get Web TV to work < no errors in the trace log

Postby GreenWave7 » Tue Feb 24, 2009 1:34 am

I'm having the exact same problem no errors in the debug log yet when I go to watch or listen to anything streaming from the web I get data is corrupted message. I can watch all kinds of media if i stream it from my pc hard drive.
GreenWave7
 
Posts: 2
Joined: Mon Jan 19, 2009 2:38 am

Re: Can't get Web TV to work < no errors in the trace log

Postby buju » Thu Feb 26, 2009 5:53 am

UPDATE: Judging by the absence of similar reports, other than yours - greenwave, I have concluded that there must be an issue with the proper registration of VLC, despite the fact that VLC's engine was detected and it was opening files just nicely.

I have uninstalled and reinstalled VLC. This solved the problem. I am now watching France 24 and I will proceed with testing all the other links that I normally use for watching Internet TV.

I hope that this will help you as well, greenwave

Great SW! Cheers.
Windows XP SP3, Intel Core 2 T5600 1.83 GHz, 1GB
LAN: 1 Gbps + 11N (oodles of throughput), WAN: 5.14/.580 Mbps <consistent
PMS 1.10, VLC web streaming
Video file engines: 1) TSMuxer, 2) MEncoder
Audio file engines: 1) MPlayer Audio, 2) FFmpeg Audio
buju
 
Posts: 37
Joined: Tue Feb 10, 2009 6:25 pm

Re: Can't get Web TV to work < no errors in the trace log

Postby babaracus » Thu Feb 26, 2009 1:55 pm

Glad to hear web tv is working for you buju... if you get NSV streams working let me know. It is something I am actively working on at the minute.
babaracus
 
Posts: 10
Joined: Thu Feb 05, 2009 10:57 pm

Re: Can't get Web TV to work < no errors in the trace log

Postby GreenWave7 » Thu Feb 26, 2009 11:16 pm

Reinstalled but still not working. Was there anything else you did Buju when installing vlc? I'm using PS3MS 1.04 Windows XP SP3 and VLC 0.9.8a
GreenWave7
 
Posts: 2
Joined: Mon Jan 19, 2009 2:38 am

Next

Return to General Help and Support

Who is online

Users browsing this forum: Bing [Bot] and 14 guests