Cyrillic subtitles displayed incorrectly

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Cyrillic subtitles displayed incorrectly

Postby Seff » Tue Jan 20, 2009 8:36 am

Good day to all.
Just wanted to mention that in newer versions (1.02 and 1.03) some ASS/SSA subtitles, encoded in cyrillic, are totally unreadable. Thinking that this may be a Windows problem (we ARE talking about Windows here), i tried to roll back to earlier version (1.00) and it worked just fine. Please, take some time and look into this problem, 'cause i think it's really important for some people (including me).

Also is there any way to correct the timing of the subtitles?
Seff
 
Posts: 12
Joined: Tue Jan 20, 2009 7:53 am

Re: Cyrillic subtitles displayed incorrectly

Postby shagrath » Tue Jan 20, 2009 9:14 am

nothing have changed on the subtitles codepage handling ... which one are you using ? Also, if something is wrong with latest versions, try switching of mencoder.exe with the one from the 1.00 (win32 folder)
shagrath
Project Lead
 
Posts: 2667
Joined: Wed Jan 14, 2009 1:39 pm

Re: Cyrillic subtitles displayed incorrectly

Postby Seff » Tue Jan 20, 2009 11:14 am

Replaced mencoder.exe, works flawlessly, thank you very much.
I'm using cp1251 BTW. Absolutely no clue as of why 1.00 mencoder works and 1.02 and 1.03 don't.

Anyway, thanks for the quick solution :)

And still... is there any way to correct the timing of the subtitles in case they don't match the video? In the earlier versions it could be done via ffdshow, but now, as far as i can see, there is an internal subtitle engine. Am i missing something?
Seff
 
Posts: 12
Joined: Tue Jan 20, 2009 7:53 am


Return to General Help and Support

Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 13 guests