PMS not closing DLNA connection on shutdown.

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

PMS not closing DLNA connection on shutdown.

Postby Dean » Sun Feb 15, 2009 11:36 am

Hi,

I'm using PMS 1.04 on Vista X64 (not as a service.. It's run from my Startup folder), connected to a PS3 running 2.60 firmware.

After a connection has been established with the PS3 (ie: PS3 Media Server shows up within the XMB), if I close down PMS the 'PS3 Media Server' entry remains on the XMB. If I restart PMS then I get another PS3 Media Server entry displayed. If I rescan for media servers on the PS3, then only a single (ie: the currently running) PMS entry is displayed, as I would expect.

I only found out about this when I'd been streaming from PMS to my PS3, then had to reboot my PC after installing something. My PS3 remained on, and showed two PS3 Media Server entries within the XMB.

It's almost like it's not properly closing down/unregistering the current DLNA connection when the PMS application is shut down.

Regards,
Dean
Dean
 
Posts: 6
Joined: Mon Jan 19, 2009 8:50 pm

Re: PMS not closing DLNA connection on shutdown.

Postby ExSport » Sun Feb 15, 2009 11:49 am

Sometimes when you close PMS, it is not correctly closed(javaw.exe process still remains) so you have to kill this process to "correctly" exit PMS ;)
ExSport
 
Posts: 2168
Joined: Mon Jan 19, 2009 5:40 pm

Re: PMS not closing DLNA connection on shutdown.

Postby Dean » Sun Feb 15, 2009 2:18 pm

Thanks, that's interesting.. I'll keep an eye open for that occurring. Unfortunately that's not likely to be the cause of the issue I've raised, as I'm pretty sure that the Java process is fully terminated during a PC reboot.. ;)

Dean
Dean
 
Posts: 6
Joined: Mon Jan 19, 2009 8:50 pm

Re: PMS not closing DLNA connection on shutdown.

Postby shagrath » Sun Feb 15, 2009 3:00 pm

the "byebye" ssdp message is sometimes lost (like the alive) when quitting... do you always reproduce thie behavior ?
besides the upnp discovery has been modified for next version, so maybe there will be some improvment
shagrath
Project Lead
 
Posts: 2667
Joined: Wed Jan 14, 2009 1:39 pm

Re: PMS not closing DLNA connection on shutdown.

Postby Dean » Sun Feb 15, 2009 8:57 pm

Hi Shagrath,

Yup.. I seem to always get this behaviour. I'll report back again if it continues to be a problem after the next version is released.

Thanks!
Dean
Dean
 
Posts: 6
Joined: Mon Jan 19, 2009 8:50 pm


Return to General Help and Support

Who is online

Users browsing this forum: Google [Bot] and 16 guests