[BUG]: Transcoder profiles not loaded

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

[BUG]: Transcoder profiles not loaded

Postby ExSport » Thu Feb 12, 2009 7:32 pm

Hi Shagrath
Few times I spotted that PMS will not load correctly and doesn't work because it will not detect some or all of encoding profiles.
It seems to me that it is affected by load of the system. When system is less responsive, greater chance that PMS will not load correctly.
It is big problem when you start PMS automatically when system is started--->there is a big chance that PMS will not be fully functional.
My system is Q6600 so it is not about performance.
Here you can see wrongly started PMS:
Code: Select all
[main] TRACE 07:58:02.687 http://ps3mediaserver.blogspot.com
[main] TRACE 07:58:02.687
[main] TRACE 07:58:02.687 Java 1.6.0_11-Sun Microsystems Inc.
[main] TRACE 07:58:02.687 OS Windows XP x86 5.1
[main] TRACE 07:58:02.687 Encoding: Cp1250
[main] TRACE 07:58:03.171 Temp folder: C:\DOCUME~1\xyz\LOCALS~1\Temp\javaps3media
[main] 07:58:05.671 Cannot launch FFmpeg / Check the presence of C:\Program Files\PS3 Media Server\win32\ffmpeg.exe ...: process has not exited
[main] 07:58:07.968 Cannot launch MPlayer / Check the presence of C:\Program Files\PS3 Media Server\win32\mplayer.exe ...: process has not exited
[main] 07:58:10.046 Cannot launch MEncoder / Check the presence of C:\Program Files\PS3 Media Server\win32\mencoder.exe ...: process has not exited
[main] TRACE 07:58:12.359 Found AviSynth plugins dir: C:\Program Files\AviSynth 2.5\plugins
[main] TRACE 07:58:12.390 !!! It seems VSFilter.dll is not installed into the AviSynth plugins dir ! It could be troublesome for playing subtitled videos with AviSynth !!!
[main] TRACE 07:58:12.406 Found VideoLAN version 0.9.8a at: C:\Program Files\VideoLAN\VLC\vlc.exe
[main] TRACE 07:58:12.640 Executable of transcoder profile AviSynth/FFmpeg not found!
[main] TRACE 07:58:12.640 Executable of transcoder profile FFmpeg Audio not found!
[main] TRACE 07:58:12.828 Executable of transcoder profile MEncoder not found!
[main] TRACE 07:58:12.828 Executable of transcoder profile Avisynth/MEncoder not found!
[main] TRACE 07:58:12.828 Executable of transcoder profile MPlayer Audio not found!
[main] TRACE 07:58:12.828 Executable of transcoder profile MEncoder Web not found!
[main] TRACE 07:58:12.828 Executable of transcoder profile MPlayer Video Dump not found!
[main] TRACE 07:58:12.828 Executable of transcoder profile MPlayer Web not found!
[main] TRACE 07:58:12.828 Registering transcoding engine TsMuxer
[main] TRACE 07:58:12.828 Registering transcoding engine Audio High Fidelity
[main] TRACE 07:58:12.828 Executable of transcoder profile VideoLan Audio Streaming not found!
[main] TRACE 07:58:12.828 Executable of transcoder profile VideoLan Video Streaming not found!
[main] TRACE 07:58:12.828 Executable of transcoder profile FFmpeg DVR-MS Remux not found!
[main] TRACE 07:58:12.859 Registering transcoding engine Raws Thumbnailer
[main] TRACE 07:58:13.750 Scanning network interface eth1 / Realtek RTL8168/8111 PCI-E Gigabit Ethernet NIC
[main] TRACE 07:58:13.750 Using address /192.168.1.2 found on network interface: name:eth1 (Realtek RTL8168/8111 PCI-E Gigabit Ethernet NIC) index: 65540 addresses: /192.168.1.2;
[main] TRACE 07:58:13.750 Created socket: /192.168.1.2:5001
[Thread-16] TRACE 07:58:14.640 Starting DLNA Server on host 192.168.1.2 and port 5001...
[main] TRACE 07:58:14.890 Using database located at : C:\Program Files\PS3 Media Server\database
[main] TRACE 07:58:26.703 Using following UUID: fc886fb5-a7d1-38bd-b1c5-f225a437760a
[main] TRACE 07:58:27.296 It's ready! You should see the server appears on XMB

And here you can see correctly loaded app, no change was made, only new start of application:
Code: Select all
[main] TRACE 19:18:39.203 Starting Java PS3 Media Server v1.04
[main] TRACE 19:18:39.203 by shagrath / 2008
[main] TRACE 19:18:39.203 http://ps3mediaserver.blogspot.com
[main] TRACE 19:18:39.203
[main] TRACE 19:18:39.203 Java 1.6.0_11-Sun Microsystems Inc.
[main] TRACE 19:18:39.203 OS Windows XP x86 5.1
[main] TRACE 19:18:39.203 Encoding: Cp1250
[main] TRACE 19:18:39.203 Temp folder: C:\DOCUME~1\xyz\LOCALS~1\Temp\javaps3media
[main] TRACE 19:18:39.906 Found AviSynth plugins dir: C:\Program Files\AviSynth 2.5\plugins
[main] TRACE 19:18:39.906 !!! It seems VSFilter.dll is not installed into the AviSynth plugins dir ! It could be troublesome for playing subtitled videos with AviSynth !!!
[main] TRACE 19:18:39.906 Found VideoLAN version 0.9.8a at: C:\Program Files\VideoLAN\VLC\vlc.exe
[main] TRACE 19:18:39.921 Registering transcoding engine AviSynth/FFmpeg
[main] TRACE 19:18:39.921 Registering transcoding engine FFmpeg Audio
[main] TRACE 19:18:39.921 Registering transcoding engine MEncoder
[main] TRACE 19:18:39.921 Registering transcoding engine Avisynth/MEncoder
[main] TRACE 19:18:39.921 Registering transcoding engine MPlayer Audio
[main] TRACE 19:18:39.921 Registering transcoding engine MEncoder Web
[main] TRACE 19:18:39.921 Registering transcoding engine MPlayer Video Dump
[main] TRACE 19:18:39.921 Registering transcoding engine MPlayer Web
[main] TRACE 19:18:39.921 Registering transcoding engine TsMuxer
[main] TRACE 19:18:39.921 Registering transcoding engine Audio High Fidelity
[main] TRACE 19:18:39.921 Registering transcoding engine VideoLan Audio Streaming
[main] TRACE 19:18:39.921 Registering transcoding engine VideoLan Video Streaming
[main] TRACE 19:18:39.921 Registering transcoding engine FFmpeg DVR-MS Remux
[main] TRACE 19:18:39.921 Registering transcoding engine Raws Thumbnailer
[main] TRACE 19:18:40.031 Scanning network interface eth1 / Realtek RTL8168/8111 PCI-E Gigabit Ethernet NIC
[main] TRACE 19:18:40.031 Using address /192.168.1.2 found on network interface: name:eth1 (Realtek RTL8168/8111 PCI-E Gigabit Ethernet NIC) index: 65540 addresses: /192.168.1.2;
[main] TRACE 19:18:40.031 Created socket: /192.168.1.2:5001
[Thread-16] TRACE 19:18:40.031 Starting DLNA Server on host 192.168.1.2 and port 5001...
[main] TRACE 19:18:40.046 Using database located at : C:\Program Files\PS3 Media Server\database
[main] TRACE 19:18:40.328 Using following UUID: fc886fb5-a7d1-38bd-b1c5-f225a437760a
[main] TRACE 19:18:40.890 It's ready! You should see the server appears on XMB

I already mentioned this behavior here in the forum ;)
Thanks
ExSport
 
Posts: 2167
Joined: Mon Jan 19, 2009 5:40 pm

Re: [BUG]: Transcoder profiles not loaded

Postby shagrath » Thu Feb 12, 2009 8:01 pm

that's fixed in the trunk
shagrath
Project Lead
 
Posts: 2667
Joined: Wed Jan 14, 2009 1:39 pm

Re: [BUG]: Transcoder profiles not loaded

Postby ExSport » Thu Feb 12, 2009 8:08 pm

Great!
Many thanks :twisted:
ExSport
 
Posts: 2167
Joined: Mon Jan 19, 2009 5:40 pm

Re: [BUG]: Transcoder profiles not loaded

Postby Bolden » Mon Mar 02, 2009 2:47 am

shagrath wrote:that's fixed in the trunk

Sorry to be a newb, but what does that ^ mean?

I have the same issue, to resolve I ended up using some startup-delay program to start PS3 Media Server 2 minutes after bootup. (I don't need to explain to my wife how to start it, I just need it to be on after she fires up the pc ;).

Thanks in advance.
Bolden
 
Posts: 6
Joined: Sat Feb 21, 2009 9:03 am

Re: [BUG]: Transcoder profiles not loaded

Postby Topguy » Mon Mar 02, 2009 9:10 pm

The "trunk" is a reference to the source code that is going to be the next release. So when he says "fixed on trunk" it means it should be working properly in the next release... which should be 1.10.. which is out today..
Topguy
 
Posts: 219
Joined: Mon Jan 19, 2009 9:27 pm

Re: [BUG]: Transcoder profiles not loaded

Postby Bolden » Mon Mar 02, 2009 10:45 pm

Excellent, thanks for the explanation!
Bolden
 
Posts: 6
Joined: Sat Feb 21, 2009 9:03 am


Return to General Help and Support

Who is online

Users browsing this forum: Bing [Bot] and 12 guests