Judder on NTSC iso/img

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Judder on NTSC iso/img

Postby Veritas » Thu Feb 12, 2009 9:12 am

1- your computer specs (cpu, memory): I have a core2 Quad with 4 GB memory, Windows Vista. PS3 Media Server 1.04
2- the network connection you are using for streaming your files (wifi, homeplugs, ethernet 100Mbits, or gigabit): Crossed ethernet 100 mbit PC<--->PS3.
3- detailed infos on what's not working....


I get judder on NTSC dvd img/iso-files. If I burn the file to DVD-r and play it on the PS3 I do NOT get the same judder. It's worse than the 3:2 pulldown judder (or stutter) that's is native to NTSC-format on film. Anyway, my Toshiba TV can remove "true" 3:2 pulldown judder from NTSC-films.

Something is done during transcoding that causes the judder. After trying different settings I've found that the only thing that removes the judder is if I disable "expert settings" and let PS3 Media Server use "A/V sync alternative method". That completely removes any judder, but there's only one little problem: audio and video is WAY out of sync.

It seems that the transcoding process rebuilds the movies original 24 fps. But with "A/V sync alternative method", the 24 fps is played back at 30 fps, a 125% increase in speeed. The audio though is still playing at normal speed. I have used "Kung Fu Panda" (ntsc dvd-img) as my test-file and When the panda falls out of bed at 2.00 min of the movie, the thump (sound of panda hitting the floor) is coming at 2.30 min.

When "A/V sync alternative method" is disbled by the settings in Mencoder/expert settings (container == iso :: -nosync), A/V sync perfectly, but the judder returns. It seems that frames are added to sync audio and video and that's causing the judder.

I have searched for a solution and tried many different settings and tweaks, for example adding this in mencoder/expert settings:

framerate == 23.976 :: -speed 1.042709376 -ofps 25

and/or

framerate == 23.976 :: -mpegopts tele_src=24000/1001:tele_dest=25
framerate == 24.000 :: -mpegopts tele_src=24000/1001:tele_dest=25


But none of this settings work. I'd rather have a slight speed-up than judder. But I have to say that I have tried so many settings that I'm not sure what the default settings in Mencoder are any longer. Is there a way to return to default settings?

BTW: My PS3 is set to output 50 Hz from XMB. I've tried to set it to "auto" with no change. I have no judder on PAL dvd iso.
Veritas
 
Posts: 5
Joined: Thu Feb 12, 2009 8:12 am

Re: Judder on NTSC iso/img

Postby shagrath » Thu Feb 12, 2009 9:23 am

just try

:: -mpegopts tele_src=24000/1001:tele_dest=25 -ofps 25

that will apply the settings for all your video but it's just for testing purpose
shagrath
Project Lead
 
Posts: 2668
Joined: Wed Jan 14, 2009 1:39 pm

Re: Judder on NTSC iso/img

Postby Veritas » Thu Feb 12, 2009 9:53 am

shagrath wrote:just try

:: -mpegopts tele_src=24000/1001:tele_dest=25 -ofps 25

that will apply the settings for all your video but it's just for testing purpose


Ok, will do so as soon as I get the chance and report back. Thanks!
Veritas
 
Posts: 5
Joined: Thu Feb 12, 2009 8:12 am

Re: Judder on NTSC iso/img

Postby Veritas » Fri Feb 13, 2009 8:35 am

Ok, I have now tried adding the parameters under Mencoder/expert settings/custom parameters, but to stop the judder I had to make a small change (red):

:: -mpegopts tele_src=24000/1001:tele_dest=24 -ofps 25

...but that seems to do the trick, I get much less judder when playing NTSC DVD-img! A/V seems to sync too although I haven't watchad a whole movie yet, just the first 5 minutes of my testfiles. But with these settings A/V on PAL DVD-img is out of sync, but after some testing I found that adding this solved the problem with PAL DVD-img:

framerate == 25 :: -mpegopts tele_src=25:tele_dest=25 -ofps 25

...now both PAL- and NTSC-img files are both judder-free and with A/V in sync! But as I said, I haven't tested that much yet, I will do some more tests to see if I find any unwanted side effects. I tried to play a .mkv file (from SKY HD) and DivX file without any problems.

Please note: "A/V sync alternative method" has to enabled and ALL the "standard" settings in Mencoder/Expert settings has to be disabled and the settings above are added under Mencoder/Expert settings/Cutom parameters.
Veritas
 
Posts: 5
Joined: Thu Feb 12, 2009 8:12 am

Re: Judder on NTSC iso/img

Postby ExSport » Fri Feb 13, 2009 4:51 pm

Did you tried:

Code: Select all
framerate == 29.97 && container == iso :: -mpegopts tele_src=24000/1001:tele_dest=24 -ofps 25
or
framerate == 23.976 && container == iso :: -mpegopts tele_src=24000/1001:tele_dest=24 -ofps 25


This will force framerate change for NTSC ISO images only. I don't know if your NTSC DVD is 29.97 or 23.976, so you can try both separately.
And what about this?
Code: Select all
:: -mpegopts tele_src=25:tele_dest=25 -ofps 25
or
:: -mpegopts tele_src=24000/1001:tele_dest=25 -ofps 25 ---> Edit: this already posted Shagrath and don't work...

This will force any video to be converted to 25fps... Which one will shutter less?
ExSport
 
Posts: 2168
Joined: Mon Jan 19, 2009 5:40 pm

Re: Judder on NTSC iso/img

Postby Veritas » Fri Feb 13, 2009 7:23 pm

ExSport wrote:Did you tried:

Code: Select all
framerate == 29.97 && container == iso :: -mpegopts tele_src=24000/1001:tele_dest=24 -ofps 25
or
framerate == 23.976 && container == iso :: -mpegopts tele_src=24000/1001:tele_dest=24 -ofps 25


This will force framerate change for NTSC ISO images only. I don't know if your NTSC DVD is 29.97 or 23.976, so you can try both separately.
And what about this?
Code: Select all
:: -mpegopts tele_src=25:tele_dest=25 -ofps 25
or
:: -mpegopts tele_src=24000/1001:tele_dest=25 -ofps 25 ---> Edit: this already posted Shagrath and don't work...

This will force any video to be converted to 25fps... Which one will shutter less?


Thanks! I will try those settings! I tried to condition a framerate change only to NTSC ISO, but for some reason it didn't work (=judder came back!). I tried something like this:

framerate == 24 :: -mpegopts tele_src=24000/1001:tele_dest=24 -ofps 25

and....

framerate == 23.976 :: -mpegopts tele_src=24000/1001:tele_dest=24 -ofps 25

and...

framerate == 24000/1001 :: -mpegopts tele_src=24000/1001:tele_dest=24 -ofps 25

I would be great if I could find a way to condition a framrate change for NTSC ISO only.
"A/V Aternative sync method" has to be enabled for NTSC only, but disabled for PAL ISO and other file formats. ("container == iso :: -nosync")

But unfortunately my busy schedule for the weekend won't let me do any more testing until next week... :(
Veritas
 
Posts: 5
Joined: Thu Feb 12, 2009 8:12 am

Re: Judder on NTSC iso/img

Postby Veritas » Fri Feb 20, 2009 7:09 pm

Ok, after some testing I have concluded that these parameters seem to work the best for me:

framerate == 29.97 && container == iso :: -mpegopts tele_src=24000/1001:tele_dest=24 -ofps 25
framerate == 25 && container == iso :: -mpegopts tele_src=25:tele_dest=25 -ofps 25
(container == avi || container == matroska) && vcodec == mpeg4 && acodec == mp3 :: -mc 0.1
container == flv :: -mc 0.1
container == mov :: -mc 0.1 -noass
container == rm :: -mc 0.1


I have added them under "Transcoding settings/Mencoder/Expert Settings:Codecs specific parameters/Custom parameters", "Use application default codecs parameters" must be disabled(!).

"A/V sync alternative method" must be chosen under "Transcoding settings/Mencoder/Video-Audio decoder settings for MEncoder engine only"

By chance I discovered that a .mkv file with DTS sound will loose all sound in the centerchannel if "DTS/FLAC -> LCPM remux" is chosen under "Transcoding settings/General settings.

PS3 Media server is now working like a dream for me :!: Please note that these settings work on my equipment and may not do so for everbody else.
Veritas
 
Posts: 5
Joined: Thu Feb 12, 2009 8:12 am

Re: Judder on NTSC iso/img

Postby rodhull » Mon May 11, 2009 1:51 pm

Thanks a lot for these settings. I had the exact same issue yesterday when trying to watch a DVD ISO for the first time. Very frustrating!

My PS3 is hooked up to my LCD TV at 1080i with an HDMI cable, so not sure why this juddering is happening to be honest. Other SD NTSC content (which was in an AVI container) played back perfectly before adding in these settings, and I've never had any judder on any 720p or 1080p HD material either (encoded at 23.976 or 24fps).

Why exactly does it only happen with DVD ISOs before these settings are applied? It's obviously the transcoding that's affecting things...why does it get it wrong with DVDs but nothing else?

Is there any need to add the extra hassle of even transcoding DVDs? I thought that the PS3 should be able to stream them natively (if they were unpacked from the ISO into a VIDEO_TS folder), or do they have to be encapsulated in a .ts file rather than within VOBs?

EDIT: Seems with a bit of searching that you don't have to transcode DVDs, but you will do if you want any subtitles. If you're not interested in subtitles and you don't want to transcode, then you can just add something like:
Code: Select all
container == iso && vcodec == mpeg2 && srtfile == null :: -ovc copy -nosync
to the "expert settings" to just remux DVDs with no quality loss...
rodhull
 
Posts: 7
Joined: Thu Apr 16, 2009 9:45 am


Return to General Help and Support

Who is online

Users browsing this forum: Bing [Bot], Google [Bot], Yahoo [Bot] and 12 guests