PS3 Media Server 1.11.350

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

PS3 Media Server 1.11.350

Postby richie » Sat Aug 29, 2009 2:44 pm

Anyone else having issues with the Media Library in the latest build? I get the following java exceptions if the Media Library is enabled in Windows 7 x64 (this did not happen with 1.10.5).

[main] TRACE 09:33:08.229 Using database located at : C:\Program Files (x86)\PS3 Media Server\database
[pool-2-thread-1] TRACE 09:33:08.526 Exception in thread "pool-2-thread-1" java.nio.channels.ClosedSelectorException
[pool-2-thread-1] TRACE 09:33:08.527 at sun.nio.ch.SelectorImpl.lockAndDoSelect(Unknown Source)
[pool-2-thread-1] TRACE 09:33:08.527 at sun.nio.ch.SelectorImpl.selectNow(Unknown Source)
[pool-2-thread-1] TRACE 09:33:08.527 at sun.nio.ch.Util.releaseTemporarySelector(Unknown Source)
[pool-2-thread-1] TRACE 09:33:08.527 at sun.nio.ch.ServerSocketAdaptor.accept(Unknown Source)
[pool-2-thread-1] TRACE 09:33:08.528 at org.jboss.netty.channel.socket.nio.NioServerSocketPipelineSink$Boss.run(NioServerSocketPipelineSink.java:215)
[pool-2-thread-1] TRACE 09:33:08.528 at org.jboss.netty.util.ThreadRenamingRunnable.run(ThreadRenamingRunnable.java:110)
[pool-2-thread-1] TRACE 09:33:08.528 at org.jboss.netty.util.internal.IoWorkerRunnable.run(IoWorkerRunnable.java:53)
[pool-2-thread-1] TRACE 09:33:08.529 at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
[pool-2-thread-1] TRACE 09:33:08.529 at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
[pool-2-thread-1] TRACE 09:33:08.529 at java.lang.Thread.run(Unknown Source)
[main] TRACE 09:33:08.557 java.lang.NullPointerException
[main] TRACE 09:33:08.557 at net.pms.dlna.DLNAMediaDatabase.executeUpdate(DLNAMediaDatabase.java:215)
[main] TRACE 09:33:08.558 at net.pms.dlna.DLNAMediaDatabase.init(DLNAMediaDatabase.java:157)
[main] TRACE 09:33:08.558 at net.pms.PMS.getDatabase(PMS.java:260)
[main] TRACE 09:33:08.558 at net.pms.PMS.init(PMS.java:411)
[main] TRACE 09:33:08.558 at net.pms.PMS.get(PMS.java:1029)
[main] TRACE 09:33:08.559 at net.pms.PMS.main(PMS.java:1093)

I'm thinking the Null pointer has to do with it not having a database to write to. Interestingly enough this doesn't happen if I run PMS as administrator, which led me to believe it was a permission issue, however all users have r/w access to the entire installation directory.

Any ideas? I'm thinking of rolling back to an older stable build.
richie
 
Posts: 6
Joined: Sat May 02, 2009 7:41 am

Re: PS3 Media Server 1.11.350

Postby meskibob » Sat Aug 29, 2009 3:26 pm

Try updating to the latest beta build 1.11.356: viewtopic.php?f=2&t=3217
Also, it looks like an access issue, so make sure you run the PMS installer with Run as Administrator from the context menu.
I provide NO application support via PM or email, so please post your question to the forum per the Forum Rules.
meskibob
Moderator
 
Posts: 4779
Joined: Mon Jan 19, 2009 4:11 pm


Return to General Help and Support

Who is online

Users browsing this forum: Google [Bot], Yahoo [Bot] and 10 guests