Movie playback stops after 20 mins on Samsung TV

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Re: Movie playback stops after 20 mins on Samsung TV

Postby ultratoto14 » Sat Oct 10, 2009 2:29 pm

To identify if the problem is in the buffer, resize it to half the current size and re stream the same movie.
ultratoto14
 
Posts: 33
Joined: Wed Mar 04, 2009 2:09 pm

Re: Movie playback stops after 20 mins on Samsung TV

Postby Cim » Sat Oct 10, 2009 6:37 pm

After a lot of testing with PMS and Samsung 32B650 i found out something interesting about MEncoder. With MEncoder (r29238) provided with PMS r363 my test file plays around 3 minutes. It stops exactly at same spot no mater what I set the buffer size to. The buffer fills to around 140 MB and then starts dropping down. It seems that MEncoder is still working something but buffer doesn't fill and CPU used by MEncoder's task drops from around 60% to 50% and usage of one CPU core goes down and other goes up (but nothing else uses CPU than MEncoder). When buffer runs out TV stops playing and tries to skip to the next file, but it can't and gives error: "Request cannot be completed. MEDIA PLAY will return to main screen." However, with the other version of MEncoder downloaded from author's site (r29312) PMS behaves differently. When playing the same file buffer fills to 100% and it plays around 12 minutes before it stops. The buffer doesn't drop and it simply skips to next movie after 12 minutes and plays it. It seems that MEncoder provided with PMS hangs and the one from authors site doesn't. I also tried changing option TranscodedVideoFileSize in Samsung.conf to 0 and 100000000000 with no luck :( I hope someone will figure this out because PMS is really great and we woud like to use it on our Sammys too ;)
I will gladly help with testing and trying things to fix this...
In attachment are debug logs of these situations.
Attachments
debug.rar
(19.22 KiB) Downloaded 43 times
Cim
 
Posts: 5
Joined: Sun Oct 04, 2009 10:44 pm

Re: Movie playback stops after 20 mins on Samsung TV

Postby msurg » Thu Oct 22, 2009 11:50 am

bump!!!
msurg
 
Posts: 16
Joined: Thu Aug 13, 2009 9:04 am

Re: Movie playback stops after 20 mins on Samsung TV

Postby ultratoto14 » Thu Oct 22, 2009 1:09 pm

Just a word to tell you about my findings:

I send a patch to shagrath with:
Native subtitle support for samsung TVs
FF/RW when it's supported by the media.

But, we (I and CIM) also discover that:
MPEG2 generated by mencoder are not well supported by the samsung, but we don't know what. Mpeg2 generated by hcenc works well.
The no audio problem on m2ts generated by tsMuxer is due to the --new-bluray-pes option.
The samsung TV does not support TS(M2TS) with framerate 23.976 (it seems that 25 and 29.97 are ok).

Anyone able to help us on one of these point is welcome.
Don't know if there's free analyzer able to tell the difference between, hcenc generated mpeg2 and mencoder ones.
ultratoto14
 
Posts: 33
Joined: Wed Mar 04, 2009 2:09 pm

Re: Movie playback stops after 20 mins on Samsung TV

Postby ExSport » Thu Oct 22, 2009 4:37 pm

Check TS-Doctor and TS-Packet-Viewer here:
http://www.cypheros.de/dvb_e.html
Also be sure that you don't use this settings in PMS:
Code: Select all
keyint=1:vqscale=1:vqmin=1

I know that when vqmin=1 is used, some renders has problems but with vqmin=2 no problems occurs. I found it on some files on PS3(some parts in video stopped transcoding at all)
Also in render config file check this line:
Code: Select all
#Use default DVD buffer size: false = greater bitrate and faster encoding,
#but can generate incompatible videos, depends of your media renderer
DefaultVBVBufSize=false

Maybe TRUE can help for more compatible files
ExSport
 
Posts: 2168
Joined: Mon Jan 19, 2009 5:40 pm

Re: Movie playback stops after 20 mins on Samsung TV

Postby kilbert » Fri Oct 23, 2009 2:51 am

This site explains the oddities of streaming video to the samsung- He has it working on a mac.
I wish I was able to understand more- It may be of help to someone here.

http://www.thohensee.com/?page_id=106
kilbert
 
Posts: 2
Joined: Mon Oct 05, 2009 4:16 pm

Re: Movie playback stops after 20 mins on Samsung TV

Postby Cim » Sat Oct 24, 2009 9:28 pm

I think I found the solution for waching transcoded movies with MEncoder. In Samsung.conf change TranscodeVideo=MPEGAC3 to TranscodeVideo=MPEGTSAC3. I didn't yet play the whole movie but it pasts the part where it used to stop playing. The only problem is that time counter doesn't work. I tried changing to different DLNA profiles but it didn't help. Does someone know how could we fix that?
Cim
 
Posts: 5
Joined: Sun Oct 04, 2009 10:44 pm

Re: Movie playback stops after 20 mins on Samsung TV

Postby msurg » Sat Oct 24, 2009 10:05 pm

Until today I have always tried movies with subtitles. Today I tried two movies (avi and mkv, around 75 mins each, in my native language) and they played from beginning til end without a glitch.
So I am getting suspicous about that subtitles could be a problem with Samsung.
I will give a try to"TranscodeVideo" thing tomorrow and write down the result.
msurg
 
Posts: 16
Joined: Thu Aug 13, 2009 9:04 am

Re: Movie playback stops after 20 mins on Samsung TV

Postby Cim » Sun Oct 25, 2009 12:23 am

No, I'm afraid it has nothing to do with subtitles, as transcoded movie by hand (with no subtitles) with MEncoder stops as well. TV just doesn't like MPEG PS that MEncoder (and some other encoders) creates, but TS seems to work. Offcourse playing file without transcoding works (if that's what you are talking about). It works even with Samsung's internal subtitles with Ultratoto's modifications.
I guess you have option Autoload *.srt/*.sub subtitles with the same file name under MEncoder settings turned on so PMS automatically uses MEncoder to transcode video and render subtitle. If you want to avoid it and play movies without transcoding (and without subtitles) you can select option Definitely disable subtitles under Common transcode settings.
Cim
 
Posts: 5
Joined: Sun Oct 04, 2009 10:44 pm

Re: Movie playback stops after 20 mins on Samsung TV

Postby msurg » Sun Oct 25, 2009 12:38 pm

Cim wrote:No, I'm afraid it has nothing to do with subtitles, as transcoded movie by hand (with no subtitles) with MEncoder stops as well. TV just doesn't like MPEG PS that MEncoder (and some other encoders) creates, but TS seems to work. Offcourse playing file without transcoding works (if that's what you are talking about). It works even with Samsung's internal subtitles with Ultratoto's modifications.
I guess you have option Autoload *.srt/*.sub subtitles with the same file name under MEncoder settings turned on so PMS automatically uses MEncoder to transcode video and render subtitle. If you want to avoid it and play movies without transcoding (and without subtitles) you can select option Definitely disable subtitles under Common transcode settings.


Well,
I tried the same files with subtitles with Ultratoto's modifications and also with transcoding. Movies stopped playing around 20 mins again.
I tried also TranscodeVideo=MPEGTSAC3 in Samsung.conf. A/V doesn't sync with this option. Video seems speedy.
Tried these tests under linux as well under windows.
msurg
 
Posts: 16
Joined: Thu Aug 13, 2009 9:04 am

PreviousNext

Return to General Help and Support

Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 21 guests