360 not encoding MKV

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

360 not encoding MKV

Postby forcefullpower » Tue Aug 04, 2009 11:32 am

Hi All,

I seem to see that some people are able to transcode .mkv files to the 360. Every-time i try to play these files i get an error on the 360 saying unable to play content. I have not had any issues with any other files that i am trying to play.

All the content i have works fine with the PS3 from streaming to transcoding. Is there a step that i am missing on getting it to transcode mkv to the 360.
TVersity used to transcode to the 360 without any issues but that also does not work when i tested this time(have not used in a while). Also TVersity upscales the image on the 360 but the PS3M does not on the 360 but does on the PS3.

I found the debugging file. looks like this is the error "[Thread-23] DEBUG 12:34:59.529 Couldn't open codec wmav2, br=256." Any help would be grateful.

./Scratching head

[Timer-1] DEBUG 12:34:59.377 Buffered Space: 0 bytes / inputs: 0
[Thread-24] DEBUG 12:34:59.521 AVS file format detected.
[Thread-24] DEBUG 12:34:59.521 VIDEO: [YV12] 1280x720 12bpp 23.976 fps 0.0 kbps ( 0.0 kbyte/s)
[Thread-24] DEBUG 12:34:59.521 [V] filefmt:38 fourcc:0x32315659 size:1280x720 fps:23.976 ftime:=0.0417
[Thread-24] DEBUG 12:34:59.521 ==========================================================================
[Thread-24] DEBUG 12:34:59.521 Opening audio decoder: [pcm] Uncompressed PCM audio decoder
[Thread-24] DEBUG 12:34:59.521 AUDIO: 48000 Hz, 6 ch, s16le, 4608.0 kbit/100.00% (ratio: 576000->576000)
[Thread-24] DEBUG 12:34:59.521 Selected audio codec: [pcm] afm: pcm (Uncompressed PCM)
[Thread-24] DEBUG 12:34:59.521 ==========================================================================
[Thread-23] DEBUG 12:34:59.521 ** MUXER_LAVF *****************************************************************
[Thread-21] INFO 12:34:59.521 Result of \\.\pipe\mencoder1249385695358 : true
[Thread-23] DEBUG 12:34:59.521 REMEMBER: MEncoder's libavformat muxing is presently broken and can generate
[Thread-23] DEBUG 12:34:59.521 INCORRECT files in the presence of B-frames. Moreover, due to bugs MPlayer
[Thread-23] DEBUG 12:34:59.521 will play these INCORRECT files as if nothing were wrong!
[Thread-23] DEBUG 12:34:59.521 *******************************************************************************
[Thread-24] DEBUG 12:34:59.521 OK, exit.
[Thread-24] DEBUG 12:34:59.522 Opening video filter: [expand osd=1]
[Thread-24] DEBUG 12:34:59.522 Expand: -1 x -1, -1 ; -1, osd: 1, aspect: 0.000000, round: 1
[Thread-24] DEBUG 12:34:59.522 ==========================================================================
[Thread-24] DEBUG 12:34:59.523 Opening video decoder: [raw] RAW Uncompressed Video
[Thread-24] DEBUG 12:34:59.523 VDec: vo config request - 1280 x 720 (preferred colorspace: Planar YV12)
[Thread-24] DEBUG 12:34:59.523 VDec: using Planar YV12 as output csp (no 0)
[Thread-24] DEBUG 12:34:59.523 Movie-Aspect is undefined - no prescaling applied.
[Thread-24] DEBUG 12:34:59.523 videocodec: libavcodec (1280x720 fourcc=32564d57 [WMV2])
[Thread-24] DEBUG 12:34:59.523 [VE_LAVC] Using constant qscale = 1.000000 (VBR).
[Thread-24] DEBUG 12:34:59.528 Selected video codec: [rawyv12] vfm: raw (RAW YV12)
[Thread-24] DEBUG 12:34:59.528 ==========================================================================
[Thread-24] DEBUG 12:34:59.529 Exiting...
[Thread-23] DEBUG 12:34:59.529 Couldn't open codec wmav2, br=256.
[Thread-21] DEBUG 12:34:59.544 EOF
[win32/mencoder.exe] DEBUG 12:34:59.559 EOF
[win32/mencoder.exe] TRACE 12:34:59.559 Process C:\Program Files\PS3 Media Server\win32\mencoder.exe has a return code of 1! Maybe an error occured... check the log file
[Timer-1] DEBUG 12:35:01.377 Buffered Space: 0 bytes / inputs: 0
[New I/O server worker #1-1] DEBUG 12:35:01.527 Ready to Stop: true
[New I/O server worker #1-1] DEBUG 12:35:01.527 Sent to socket: Accept-Ranges: bytes
[New I/O server worker #1-1] DEBUG 12:35:01.527 Sent to socket: Connection: keep-alive
[New I/O server worker #1-1] DEBUG 12:35:01.527 Sent to socket: Content-Type: video/x-ms-wmv
[New I/O server worker #1-1] DEBUG 12:35:01.527 Sent to socket: Server: Windows_7-x86-6.1, UPnP/1.0, PMS/1.11.350
[Timer-1] DEBUG 12:35:03.377 Buffered Space: 0 bytes / inputs: 0
[Thread-25] INFO 12:35:04.027 Stopping process: win32/mencoder.exe
[Thread-25] INFO 12:35:04.027 Destroying buffer
forcefullpower
 
Posts: 4
Joined: Tue Aug 04, 2009 11:24 am

Re: 360 not encoding MKV

Postby shagrath » Tue Aug 04, 2009 6:19 pm

AviSynth/mencoder engine on the xbox is not supported at the moment, try the default mencoder engine
shagrath
Project Lead
 
Posts: 2667
Joined: Wed Jan 14, 2009 1:39 pm


Return to General Help and Support

Who is online

Users browsing this forum: No registered users and 12 guests