Another kind of a/v sync issue

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Another kind of a/v sync issue

Postby karine123 » Wed Jul 29, 2009 11:22 am

I would like to let you know what i have found on few on my mkvs original files.
this happens with all the pmsversions then don't depend on it.(using the 350 revision )

Here is the mediainfo log of the original file : (look at the mkvmerge version and the delay "in audio")
the file plays fine on pc but not on pms , the sound is exactly out of synchro of 2 seconds.

Général
Nom complet : E:\HD\fb-17again-720.mkv
Format : Matroska
Taille du fichier : 4,37 Gio
Durée : 1h 41mn
Débit global moyen : 6 141 Kbps
Date d'encodage : UTC 2009-07-27 09:41:52
Application utilisée : mkvmerge v2.7.0 ('Do It Again') built on Apr 15 2009 00:27:10
Bibliothèque utilisée : libebml v0.7.7 + libmatroska v0.8.1

Vidéo
ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Profil du format : High@L4.1
Paramètres du format, CABAC : Oui
Paramètres du format, RefFrames : 5 images
Type de muxing : Container profile=Unknown@4.1
Identifiant du codec : V_MPEG4/ISO/AVC
Durée : 1h 41mn
Débit : 5 378 Kbps
Débit nominal : 5 500 Kbps
Largeur : 1 280 pixels
Hauteur : 536 pixels
Format à l'écran : 2.35
Images par seconde : 23,976 Im/s
Résolution : 24 bits
Colorimétrie : 4:2:0
Type d'image : Progressif
Bits/(Pixel*Image) : 0.327
Taille du flux : 3,82 Gio (87%)
Bibliothèque utilisée : x264 core 67 r1173 f6d3166
Paramètres d'encodage : cabac=1 / ref=5 / deblock=1:0:0 / analyse=0x3:0x113 / me=umh / subme=7 / psy_rd=1.0:0.0 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=1 / 8x8dct=1 / cqm=0 / deadzone=21,11 / chroma_qp_offset=-2 / threads=6 / nr=0 / decimate=1 / mbaff=0 / bframes=3 / b_pyramid=1 / b_adapt=1 / b_bias=0 / direct=3 / wpredb=1 / keyint=250 / keyint_min=25 / scenecut=40 / rc=2pass / bitrate=5500 / ratetol=1.0 / qcomp=0.60 / qpmin=10 / qpmax=51 / qpstep=4 / cplxblur=20.0 / qblur=0.5 / ip_ratio=1.40 / pb_ratio=1.30 / aq=1:1.00
Langue : Anglais

Audio
ID : 2
Format : AC-3
Format/Info : Audio Coding 3
Identifiant du codec : A_AC3
Durée : 1h 41mn
Type de débit : Constant
Débit : 640 Kbps
Canaux : 6 canaux
Position des cannaux : Front: L C R, Surround: L R, LFE
Echantillonnage : 48,0 KHz
Delai par rapport Vidéo : 2s 0ms
Taille du flux : 467 Mio (10%)
Titre : Ac3 640 Kbps
Langue : Français

Texte
ID : 3
Format : UTF-8
Identifiant du codec : S_TEXT/UTF8
Identifiant du codec/Info : UTF-8 Plain Text
Titre : Forced
Langue : Français

Menu
00:00:00.000 : en:00:00:00.000
00:06:42.986 : en:00:06:42.986
00:10:06.773 : en:00:10:06.773
00:16:30.072 : en:00:16:30.072
00:18:24.228 : en:00:18:24.228
00:22:41.068 : en:00:22:41.068
00:25:43.834 : en:00:25:43.834
00:29:37.693 : en:00:29:37.693
00:33:28.215 : en:00:33:28.215
00:36:00.992 : en:00:36:00.992
00:40:16.623 : en:00:40:16.623
00:44:41.345 : en:00:44:41.345
00:49:22.084 : en:00:49:22.084
00:53:09.103 : en:00:53:09.103
00:58:35.011 : en:00:58:35.011
01:03:51.119 : en:01:03:51.119
01:07:36.803 : en:01:07:36.803
01:10:27.473 : en:01:10:27.473
01:16:16.697 : en:01:16:16.697
01:20:28.657 : en:01:20:28.657
01:26:47.953 : en:01:26:47.953
01:30:55.825 : en:01:30:55.825
01:34:44.804 : en:01:34:44.804
01:35:28.389 : en:01:35:28.389

Now i have demuxed the video and audio , applied the same delay as the original ,remuxed with my mkvmerge version :
the file plays fine on pc and pms
Général
Nom complet : E:\HD\17again-720.test demuxe.mkv
Format : Matroska
Taille du fichier : 4,38 Gio
Durée : 1h 41mn
Débit global moyen : 6 146 Kbps
Date d'encodage : UTC 2009-07-29 09:33:58
Application utilisée : mkvmerge v2.2.0 ('Turn It On Again') built on Mar 4 2008 12:58:26
Bibliothèque utilisée : libebml v0.7.7 + libmatroska v0.8.1

Vidéo
ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Profil du format : High@L4.1
Paramètres du format, CABAC : Oui
Paramètres du format, RefFrames : 5 images
Type de muxing : Container profile=Unknown@4.1
Identifiant du codec : V_MPEG4/ISO/AVC
Durée : 1h 41mn
Débit : 5 384 Kbps
Débit nominal : 5 500 Kbps
Largeur : 1 280 pixels
Hauteur : 536 pixels
Format à l'écran : 2.35
Images par seconde : 23,976 Im/s
Résolution : 24 bits
Colorimétrie : 4:2:0
Type d'image : Progressif
Bits/(Pixel*Image) : 0.327
Taille du flux : 3,83 Gio (88%)
Bibliothèque utilisée : x264 core 67 r1173 f6d3166
Paramètres d'encodage : cabac=1 / ref=5 / deblock=1:0:0 / analyse=0x3:0x113 / me=umh / subme=7 / psy_rd=1.0:0.0 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=1 / 8x8dct=1 / cqm=0 / deadzone=21,11 / chroma_qp_offset=-2 / threads=6 / nr=0 / decimate=1 / mbaff=0 / bframes=3 / b_pyramid=1 / b_adapt=1 / b_bias=0 / direct=3 / wpredb=1 / keyint=250 / keyint_min=25 / scenecut=40 / rc=2pass / bitrate=5500 / ratetol=1.0 / qcomp=0.60 / qpmin=10 / qpmax=51 / qpstep=4 / cplxblur=20.0 / qblur=0.5 / ip_ratio=1.40 / pb_ratio=1.30 / aq=1:1.0
Langue : Anglais

Audio
ID : 2
Format : AC-3
Format/Info : Audio Coding 3
Identifiant du codec : A_AC3
Durée : 1h 41mn
Type de débit : Constant
Débit : 640 Kbps
Canaux : 6 canaux
Position des cannaux : Front: L C R, Surround: L R, LFE
Echantillonnage : 48,0 KHz
Taille du flux : 467 Mio (10%)
Delai par rapport Vidéo : 2s 0ms
Titre : Ac3 640 Kbps
Langue : Français

Texte
ID : 3
Format : UTF-8
Identifiant du codec : S_TEXT/UTF8
Identifiant du codec/Info : UTF-8 Plain Text
Titre : Forced
Langue : Français

then just to say we have to take care on what mkvmerge is used when we mux files that need delay.

BR
karine123
 
Posts: 91
Joined: Sat Apr 25, 2009 10:30 am

Re: Another kind of a/v sync issue

Postby shagrath » Wed Jul 29, 2009 6:32 pm

known bug: http://code.google.com/p/ps3mediaserver ... ail?id=181
but no known solution yet
shagrath
Project Lead
 
Posts: 2667
Joined: Wed Jan 14, 2009 1:39 pm

Re: Another kind of a/v sync issue

Postby ExSport » Wed Jul 29, 2009 8:10 pm

I suppose that also tsMuxeR supports delay or not? Did you tried timeshift=XXXms?
ExSport
 
Posts: 2168
Joined: Mon Jan 19, 2009 5:40 pm

Re: Another kind of a/v sync issue

Postby shagrath » Wed Jul 29, 2009 8:17 pm

didn't know there was an option... but I miss the original delay (ffmpeg doesn't provide it), so we are stuck until the server switch to mediainfo for file analyzis (something in consideration)
shagrath
Project Lead
 
Posts: 2667
Joined: Wed Jan 14, 2009 1:39 pm

Re: Another kind of a/v sync issue

Postby ExSport » Wed Jul 29, 2009 9:53 pm

Found it, so approved, timeshift is supported by tsMuxeR: http://forum.doom9.org/showthread.php?t=142559
Also I tried CLI of mediainfo on Windows:
mediainfo --inform=Audio;%Video_Delay% "filename" will give you time in ms so it can be used by mencoder and tsmuxer
Why mediainfo is not used up today? :roll:
Thx for your great work.
P.S.
Also found that latest ffmpeg versions supports subtitle stream (I read somewhere that you said ffmpeg doesn't support it instead of mencoder)
Used latest ffmpeg from http://ffmpeg.arrozcru.org/autobuilds/f ... 32/static/
ExSport
 
Posts: 2168
Joined: Mon Jan 19, 2009 5:40 pm

Re: Another kind of a/v sync issue

Postby shagrath » Wed Jul 29, 2009 10:16 pm

ExSport wrote:Why mediainfo is not used up today? :roll:


easy answer: http://mediainfo.sourceforge.net/en/Download

sometimes Java feels good :p

Also found that latest ffmpeg versions supports subtitle stream (I read somewhere that you said ffmpeg doesn't support it instead of mencoder)
Used latest ffmpeg from http://ffmpeg.arrozcru.org/autobuilds/f ... 32/static/


mmm interesting
shagrath
Project Lead
 
Posts: 2667
Joined: Wed Jan 14, 2009 1:39 pm

Re: Another kind of a/v sync issue

Postby ExSport » Wed Jul 29, 2009 10:25 pm

shagrath wrote:easy answer: http://mediainfo.sourceforge.net/en/Download
sometimes Java feels good :p

Don't understand 8-)
tsMuxer is not java program, same as for ffmpeg so mediainfo equals to these 3rd party utilities. Also I checked downloads and see CLI(command line versions) for all supported OS by PMS(WIN/Linux/OSX) :)
ExSport
 
Posts: 2168
Joined: Mon Jan 19, 2009 5:40 pm

Re: Another kind of a/v sync issue

Postby shagrath » Wed Jul 29, 2009 10:37 pm

mediainfo is not really standard in linux distros, and I can't include a generic mediainfo lib in a standard linux package
shagrath
Project Lead
 
Posts: 2667
Joined: Wed Jan 14, 2009 1:39 pm

Re: Another kind of a/v sync issue

Postby ExSport » Wed Jul 29, 2009 10:49 pm

Oh, now i see. So what about checkbox for mediainfo usage in same way as "Use MPlayer for video thumbs"...something like "use mediainfo instead of ffmpeg if installed in PMS dir"...it could be also detected and enabled/disabled automatically when found in WIN32 dir :mrgreen:
Thx
ExSport
 
Posts: 2168
Joined: Mon Jan 19, 2009 5:40 pm


Return to General Help and Support

Who is online

Users browsing this forum: No registered users and 14 guests