Unable to use tsMuxer for H264 file

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Unable to use tsMuxer for H264 file

Postby abhijeet » Wed Jul 15, 2009 8:20 am

Hi all,

Computer specs:
Core 2 Duo/3.0 Ghz/4GB RAM/Gigabit ethernet
Using latest Windows Server Version (1.10.5) on Windows Vista SP2

I have a mkv file that I'm trying to play. The file info is:
Video Track #1:
FOURCC: "H264" (H.264)
1920x800
Audio Track #1:
FormatTag : "8192" (Dolby AC3 Audio)
6 channels, 48000Hz
Language: eng

I've set tsMuxer as my first video engine to force the server to stream the video without transcoding. However, I get an error before playback can even start. If I use default settings (Mencoder as first engine), the server transcodes video to Mpeg2. I would like to avoid that.

Debug log file:

[Thread-89] DEBUG 00:07:02.861 Asked stream chunk [0-0] timeseek: 0.0 of The.Matrix.1999.1080p.HDDVD.x264-hV.mkv and player TsMuxer
[Thread-89] TRACE 00:07:02.862 Starting transcode/remux of The.Matrix.1999.1080p.HDDVD.x264-hV.mkv
[Thread-89] DEBUG 00:07:02.862 Searching an audio track with lang: jpn
[Thread-89] DEBUG 00:07:02.862 Searching an audio track with lang: fre
[Thread-89] DEBUG 00:07:02.862 Searching an audio track with lang: ger
[Thread-89] DEBUG 00:07:02.863 Searching an audio track with lang: eng
[Thread-89] DEBUG 00:07:02.863 Matched audio track: Audio: AC3 / lang: eng / ID: 0
[Thread-89] DEBUG 00:07:02.863 Search a match for: eng with en and off
[Thread-89] DEBUG 00:07:02.863 Found a match: off
[Thread-89] DEBUG 00:07:02.863 Disabled the subtitles: off
[Thread-89] INFO 00:07:02.866 Creating pipe \\.\pipe\1247641622864ffmpegvideo
[Thread-89] INFO 00:07:02.910 Creating pipe \\.\pipe\1247641622864videoout
[Thread-91] INFO 00:07:02.910 Waiting for pipe connection \\.\pipe\1247641622864ffmpegvideo
[Thread-93] INFO 00:07:02.955 Waiting for pipe connection \\.\pipe\1247641622864videoout
[Thread-89] INFO 00:07:02.956 Starting C:\Program Files (x86)\PS3 Media Server\win32\ffmpeg.exe -vframes 1 -i Z:\Movies\M\The.Matrix.1999.1080p.HDDVD.x264-hV.mkv -vcodec copy -f h264 -vbsf h264_mp4toannexb -an -y pipe:
[Thread-88] INFO 00:07:03.038 HTTP: upnp/control/content_directory / 0-0
[Thread-88] DEBUG 00:07:03.038 Wrote on socket: HTTP/1.1 200 OK
[Thread-88] DEBUG 00:07:03.038 Wrote on socket: CONTENT-TYPE: text/xml; charset="utf-8"
[Thread-88] DEBUG 00:07:03.038 Wrote on socket: Server: Windows_Vista-x86-6.0, UPnP/1.0, PMS/1.10.51
[Thread-88] DEBUG 00:07:03.038 Wrote on socket: Content-Length: 335
[Thread-88] DEBUG 00:07:03.038 Wrote on socket:
[Thread-88] DEBUG 00:07:03.038 Close Connection
[Thread-96] DEBUG 00:07:03.041 Opened handler on socket Socket[addr=/192.168.11.130,port=57164,localport=5001]
[Thread-96] DEBUG 00:07:03.041 Received on socket: POST /upnp/control/content_directory HTTP/1.1
[Thread-96] DEBUG 00:07:03.041 Received on socket: X-AV-Client-Info: av=5.0; cn="Sony Computer Entertainment Inc."; mn="PLAYSTATION 3"; mv="1.0";
[Thread-96] DEBUG 00:07:03.049 Received on socket: Host: 192.168.11.120:5001
[Thread-96] DEBUG 00:07:03.049 Received on socket: User-Agent: UPnP/1.0 DLNADOC/1.50
[Thread-96] DEBUG 00:07:03.049 Received on socket: Content-Length: 906
[Thread-96] DEBUG 00:07:03.049 Received on socket: Content-Type: text/xml; charset="utf-8"
[Thread-96] DEBUG 00:07:03.049 Received on socket: SOAPACTION: "urn:schemas-upnp-org:service:ContentDirectory:1#Browse"
[Thread-89] INFO 00:07:03.225 Attaching thread: win32/ffmpeg.exe
[Thread-96] INFO 00:07:03.242 HTTP: upnp/control/content_directory / 0-0
[Thread-96] DEBUG 00:07:03.242 Wrote on socket: HTTP/1.1 200 OK
[Thread-96] DEBUG 00:07:03.242 Wrote on socket: CONTENT-TYPE: text/xml; charset="utf-8"
[Thread-96] DEBUG 00:07:03.242 Searching for objectId: 0$1$13 with children option: false
[Thread-96] DEBUG 00:07:03.243 Search extension for Mar Adentro.srt
[Thread-96] DEBUG 00:07:03.244 Search extension for Morning Sun.mds
[Thread-96] DEBUG 00:07:03.253 Wrote on socket: Server: Windows_Vista-x86-6.0, UPnP/1.0, PMS/1.10.51
[Thread-96] DEBUG 00:07:03.253 Wrote on socket: Content-Length: 846
[Thread-96] DEBUG 00:07:03.253 Wrote on socket:
[Thread-96] DEBUG 00:07:03.253 Close Connection
[Thread-97] DEBUG 00:07:03.337 FFmpeg version SVN-r16596-Sherpya, Copyright (c) 2000-2009 Fabrice Bellard, et al.
[Thread-97] DEBUG 00:07:03.337 libavutil 49.12. 0 / 49.12. 0
[Thread-97] DEBUG 00:07:03.337 libavcodec 52.10. 0 / 52.10. 0
[Thread-97] DEBUG 00:07:03.337 libavformat 52.23. 1 / 52.23. 1
[Thread-97] DEBUG 00:07:03.337 libavdevice 52. 1. 0 / 52. 1. 0
[Thread-97] DEBUG 00:07:03.337 libavfilter 0. 2. 0 / 0. 2. 0
[Thread-97] DEBUG 00:07:03.337 libswscale 0. 6. 1 / 0. 6. 1
[Thread-97] DEBUG 00:07:03.337 libpostproc 51. 2. 0 / 51. 2. 0
[Thread-97] DEBUG 00:07:03.337 built on Jan 14 2009 07:24:48, gcc: 4.2.5 20080919 (prerelease) [Sherpya]
[Thread-97] DEBUG 00:07:03.337 Input #0, matroska, from 'Z:\Movies\M\The.Matrix.1999.1080p.HDDVD.x264-hV.mkv':
[Thread-97] DEBUG 00:07:03.337 Duration: 02:16:17.82, start: 0.000000, bitrate: N/A
[Thread-97] DEBUG 00:07:03.337 Stream #0.0(eng): Video: h264, yuv420p, 1920x800, 23.98 tb(r)
[Thread-97] DEBUG 00:07:03.337 Stream #0.1(eng): Audio: ac3, 48000 Hz, 5.1, s16
[Thread-97] DEBUG 00:07:03.337 Stream #0.2(eng): Subtitle: 0x0000
[Thread-97] DEBUG 00:07:03.337 Stream #0.3(swe): Subtitle: 0x0000
[Thread-97] DEBUG 00:07:03.337 Output #0, h264, to 'pipe:':
[Thread-97] DEBUG 00:07:03.337 Stream #0.0(eng): Video: libx264, yuv420p, 1920x800 [PAR 1:1 DAR 12:5], q=2-31, 23.98 tb(c)
[Thread-97] DEBUG 00:07:03.337 Stream mapping:
[Thread-97] DEBUG 00:07:03.337 Stream #0.0 -> #0.0
[Thread-97] DEBUG 00:07:03.337 Press [q] to stop encoding
[Thread-97] DEBUG 00:07:03.342 video:1kB audio:0kB global headers:0kB muxing overhead 17.678381%
[Thread-89] DEBUG 00:07:03.344 EOF
[Thread-89] DEBUG 00:07:03.344 Ready to Stop: true
[Thread-89] DEBUG 00:07:03.345 H264 file: Z:\Movies\M\The.Matrix.1999.1080p.HDDVD.x264-hV.mkv: Profile: 100 / level: 51 / ref frames: 8
[Thread-89] INFO 00:07:03.345 H264 file: Z:\Movies\M\The.Matrix.1999.1080p.HDDVD.x264-hV.mkv is not ps3 compatible !
[Thread-89] INFO 00:07:03.345 Creating pipe \\.\pipe\1247641623345ffmpegaudio01
[Thread-89] INFO 00:07:03.347 Creating pipe \\.\pipe\1247641623345audioout
[Thread-102] INFO 00:07:03.347 Waiting for pipe connection \\.\pipe\1247641623345ffmpegaudio01
[Thread-103] INFO 00:07:03.347 Waiting for pipe connection \\.\pipe\1247641623345audioout
[Thread-89] INFO 00:07:03.349 Creating pipe \\.\pipe\1247641623349tsmuxerout.ts
[Thread-105] INFO 00:07:03.350 Waiting for pipe connection \\.\pipe\1247641623349tsmuxerout.ts
[win32/mencoder.exe] INFO 00:07:03.452 Starting C:\Program Files (x86)\PS3 Media Server\win32\mencoder.exe -ss 0 Z:\Movies\M\The.Matrix.1999.1080p.HDDVD.x264-hV.mkv -quiet -quiet -really-quiet -msglevel statusline=-1:mencoder=-1 -ovc copy -nosound -mc 0 -noskip -of rawvideo -o \\.\pipe\1247641622864ffmpegvideo
[Thread-91] INFO 00:07:03.502 Result of \\.\pipe\1247641622864ffmpegvideo : true
[win32/mencoder.exe] INFO 00:07:03.503 Attaching thread: win32/mencoder.exe
[win32/mencoder.exe] INFO 00:07:03.554 Starting C:\Program Files (x86)\PS3 Media Server\win32\mencoder.exe -ss 0 Z:\Movies\M\The.Matrix.1999.1080p.HDDVD.x264-hV.mkv -quiet -quiet -really-quiet -msglevel statusline=-1:mencoder=-1 -channels 6 -ovc copy -of rawaudio -mc 0 -noskip -oac copy -fafmttag 0x2000 -lavcopts acodec=ac3:abitrate=640 -af lavcresample=48000 -srate 48000 -quiet -quiet -o \\.\pipe\1247641623345ffmpegaudio01
[win32/mencoder.exe] INFO 00:07:03.557 Attaching thread: win32/mencoder.exe
[Thread-102] INFO 00:07:03.583 Result of \\.\pipe\1247641623345ffmpegaudio01 : true
[Thread-63] INFO 00:07:03.634 Stopping process: win32/mplayer.exe
[win32/tsMuxeR.exe] INFO 00:07:03.655 Starting C:\Program Files (x86)\PS3 Media Server\win32\tsMuxeR.exe C:\Users\Abhijeet\AppData\Local\Temp\javaps3media\pms-tsmuxer.meta \\.\pipe\1247641623349tsmuxerout.ts
[win32/tsMuxeR.exe] INFO 00:07:03.656 Reading pipe: \\.\pipe\1247641623349tsmuxerout.ts
[Thread-93] INFO 00:07:03.716 Forced reconnection of \\.\pipe\1247641622864videoout with result : true
[Thread-93] INFO 00:07:03.716 Result of \\.\pipe\1247641622864videoout : true
[win32/tsMuxeR.exe] INFO 00:07:03.761 Attaching thread: win32/tsMuxeR.exe
[Timer-3] DEBUG 00:07:03.761 Buffered Space: 0 bytes / inputs: 0
[Thread-115] DEBUG 00:07:03.762 SmartLabs tsMuxeR. Version 1.8.18(b) http://www.smlabs.net
[Thread-103] INFO 00:07:03.915 Forced reconnection of \\.\pipe\1247641623345audioout with result : true
[Thread-103] INFO 00:07:03.915 Result of \\.\pipe\1247641623345audioout : true
[Thread-105] INFO 00:07:03.918 Result of \\.\pipe\1247641623349tsmuxerout.ts : true
[Timer-3] DEBUG 00:07:05.783 Buffered Space: 0 bytes / inputs: 0
[Thread-100] INFO 00:07:05.846 Stopping process: win32/ffmpeg.exe
[Thread-100] INFO 00:07:05.846 Destroying buffer
[Thread-95] INFO 00:07:05.958 Stopping process: win32/ffmpeg.exe
[Thread-95] INFO 00:07:05.958 Destroying buffer
[Thread-100] INFO 00:07:06.014 Destroying buffer
[Thread-112] DEBUG 00:07:06.995 Pes packet len too large ( >100Mb). Bad stream or invalid codec speciffed.
[Thread-103] INFO 00:07:06.995 Disconnected pipe: \\.\pipe\1247641623345audioout
[win32/tsMuxeR.exe] DEBUG 00:07:07.018 EOF
[win32/tsMuxeR.exe] TRACE 00:07:07.018 Process C:\Program Files (x86)\PS3 Media Server\win32\tsMuxeR.exe has a return code of -2! Maybe an error occured... check the log file
[Thread-93] INFO 00:07:07.019 Error: null
[Thread-93] INFO 00:07:07.020 Disconnected pipe: \\.\pipe\1247641622864videoout
[win32/tsMuxeR.exe] INFO 00:07:07.020 Stopping process: win32/mencoder.exe
[win32/tsMuxeR.exe] INFO 00:07:07.020 Destroying buffer
[Thread-102] INFO 00:07:07.192 Error: null
[win32/mencoder.exe] DEBUG 00:07:07.195 EOF
[Thread-101] INFO 00:07:07.195 Error :null
[win32/tsMuxeR.exe] INFO 00:07:07.197 Stopping process: win32/mencoder.exe
[win32/tsMuxeR.exe] INFO 00:07:07.197 Destroying buffer
[win32/mencoder.exe] DEBUG 00:07:07.292 EOF
[Thread-90] INFO 00:07:07.293 Error :Read end dead


If anyone can shed light on this, I'd appreciate it.

Thanks!
abhijeet
 
Posts: 14
Joined: Sun Feb 15, 2009 5:33 am

Re: Unable to use tsMuxer for H264 file

Postby karine123 » Wed Jul 15, 2009 9:53 am

your file can't be read with tsmuxer cause it 's not compatible with ps3 , it has a profile 5.1 and must be transcoded.

You can check the infos of your file with mediainfo :http://mediainfo.sourceforge.net/en

BR
karine123
 
Posts: 91
Joined: Sat Apr 25, 2009 10:30 am


Return to General Help and Support

Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 7 guests