Can't get Avisynth / MEncoder working with MKV + Vobsubs

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Can't get Avisynth / MEncoder working with MKV + Vobsubs

Postby Hanzo » Sat Jul 11, 2009 8:59 pm


I got several anime MKVs coded with h.264 video, AAC audio and VobSub subtitles. I haven't been able to stream this to my PS3 successfully. Below the MediaInfo analysis.

Code: Select all
Complete name                    : D:\ANIME\Death Note\Death Note - 01 [Arigatou].mkv
Format                           : Matroska
File size                        : 241 MiB
Duration                         : 22mn 48s
Overall bit rate                 : 1 474 Kbps
Movie name                       : Rebirth - 新生
Encoded date                     : UTC 2007-11-18 18:48:36
Writing application              : mkvmerge v2.1.0 ('Another Place To Fall') built on Aug 19 2007 13:40:07
Writing library                  : libebml v0.7.7 + libmatroska v0.8.1

ID                               : 1
Format                           : AVC
Format/Info                      : Advanced Video Codec
Format profile                   : High@L5.1
Format settings, CABAC           : Yes
Format settings, ReFrames        : 6 frames
Muxing mode                      : Container profile=Unknown@5.1
Codec ID                         : V_MPEG4/ISO/AVC
Duration                         : 22mn 47s
Nominal bit rate                 : 1 630 Kbps
Width                            : 720 pixels
Height                           : 480 pixels
Display aspect ratio             : 16/9
Frame rate                       : 29.970 fps
Standard                         : NTSC
Resolution                       : 24 bits
Colorimetry                      : 4:2:0
Scan type                        : Progressive
Bits/(Pixel*Frame)               : 0.157
Writing library                  : x264 core 56 svn-669
Encoding settings                : cabac=1 / ref=3 / deblock=1:0:0 / analyse=0x3:0x133 / me=hex / subme=6 / brdo=1 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=1 / 8x8dct=1 / cqm=0 / deadzone=21,11 / chroma_qp_offset=0 / threads=1 / nr=0 / decimate=1 / mbaff=0 / bframes=3 / b_pyramid=1 / b_adapt=1 / b_bias=0 / direct=1 / wpredb=1 / bime=1 / keyint=250 / keyint_min=25 / scenecut=40 / rc=2pass / bitrate=1630 / ratetol=1.0 / rceq='blurCplx^(1-qComp)' / qcomp=0.60 / qpmin=10 / qpmax=51 / qpstep=4 / cplxblur=20.0 / qblur=0.5 / ip_ratio=1.40 / pb_ratio=1.30

Audio #1
ID                               : 2
Format                           : AAC
Format/Info                      : Advanced Audio Codec
Format version                   : Version 4
Format profile                   : LC
Format settings, SBR             : Yes
Format settings, PS              : No
Codec ID                         : A_AAC
Duration                         : 22mn 48s
Channel(s)                       : 2 channels
Channel positions                : L R
Sampling rate                    : 48.0 KHz
Resolution                       : 16 bits
Title                            : English (2.0)
Language                         : English

Audio #2
ID                               : 3
Format                           : AAC
Format/Info                      : Advanced Audio Codec
Format version                   : Version 4
Format profile                   : LC
Format settings, SBR             : Yes
Format settings, PS              : No
Codec ID                         : A_AAC
Duration                         : 22mn 48s
Channel(s)                       : 2 channels
Channel positions                : L R
Sampling rate                    : 48.0 KHz
Resolution                       : 16 bits
Title                            : Japanese (2.0)
Language                         : Japanese

ID                               : 4
Format                           : VobSub
Codec ID                         : S_VOBSUB
Codec ID/Info                    : The same subtitle format used on DVDs
Title                            : Audio
Language                         : English

00:00:00.000                     : en:Chapter 1
00:01:20.267                     : en:Chapter 2
00:10:40.667                     : en:Chapter 3
00:21:20.733                     : en:Chapter 4
00:22:31.000                     : en:Chapter 5

I had some issues with MKVs and SRT subtitles in the past, I simply extracted the SRT from the MKV and the PS3 Media Server read and streamed correctly. But it hasn't work for me in this case. It's the first time I'm see an MKV with VobSubs. The PS3 won't show me any option for subtitles, only the two audio tracks. I read a bit online and tried installing Avisynth (2.5.7) (added VSfilter in the plugins directory), the Haali Media Splitter and tried separately with CCCP and K-lite Codec Pack (uninstalled one before trying the other). Also installed the CoreAVC trial, disabled the h.264 decoder in FFmpeg and still and no luck.

I specified the audio track and subtitle track in Haali and on VobSub (english) I can play the files just fine with Window Media Player and VLC doesn't sweat it at all. I have also tried re-muxing the tracks into a fresh file with the latest MKV Extract, no luck either. I also tried to set the audio and subtitle preferences in PMS with Mencoder, still no difference. I'm asking for a little help because I'm really out of ideas and I can't figure out why it won't detect the subs on these files.

Whenever I attempt to stream with AviSynth on the PS3 it takes a while and then gives me "data is corrupted error" Below the traces...

Code: Select all
[main] TRACE 14:20:59.540 Starting Java PS3 Media Server v1.10.51
[main] TRACE 14:20:59.565 by shagrath / 2008-2009
[main] TRACE 14:20:59.565
[main] TRACE 14:20:59.569
[main] TRACE 14:20:59.570
[main] TRACE 14:20:59.572 Java 1.6.0_10-Sun Microsystems Inc.
[main] TRACE 14:20:59.573 OS Windows Vista x86 6.1
[main] TRACE 14:20:59.574 Encoding: Cp1252
[main] TRACE 14:20:59.598 Temp folder: C:\Users\Hanzo\AppData\Local\Temp\javaps3media
[main] TRACE 14:20:59.601 Found AviSynth plugins dir: C:\Program Files\AviSynth 2.5\plugins
[main] TRACE 14:20:59.605 Found VideoLAN version 1.0.0 at: C:\Program Files\VideoLAN\VLC\vlc.exe
[main] TRACE 14:20:59.632 Registering transcoding engine AviSynth/FFmpeg
[main] TRACE 14:20:59.642 Registering transcoding engine FFmpeg Audio
[main] TRACE 14:20:59.663 Registering transcoding engine MEncoder
[main] TRACE 14:20:59.664 Registering transcoding engine Avisynth/MEncoder
[main] TRACE 14:20:59.665 Registering transcoding engine MPlayer Audio
[main] TRACE 14:20:59.667 Registering transcoding engine MEncoder Web
[main] TRACE 14:20:59.668 Registering transcoding engine MPlayer Video Dump
[main] TRACE 14:20:59.669 Registering transcoding engine MPlayer Web
[main] TRACE 14:20:59.674 Registering transcoding engine TsMuxer
[main] TRACE 14:20:59.675 Registering transcoding engine Audio High Fidelity
[main] TRACE 14:20:59.678 Registering transcoding engine VideoLan Audio Streaming
[main] TRACE 14:20:59.680 Registering transcoding engine VideoLan Video Streaming
[main] TRACE 14:20:59.682 Registering transcoding engine FFmpeg DVR-MS Remux
[main] TRACE 14:20:59.683 Registering transcoding engine Raws Thumbnailer
[main] TRACE 14:21:00.526 Scanning network interface lo / Software Loopback Interface 1
[main] TRACE 14:21:00.539 Scanning network interface net0 / WAN Miniport (SSTP)
[main] TRACE 14:21:00.552 Scanning network interface net1 / WAN Miniport (IKEv2)
[main] TRACE 14:21:00.565 Scanning network interface net2 / WAN Miniport (L2TP)
[main] TRACE 14:21:00.580 Scanning network interface net3 / WAN Miniport (PPTP)
[main] TRACE 14:21:00.595 Scanning network interface ppp0 / WAN Miniport (PPPOE)
[main] TRACE 14:21:00.609 Scanning network interface eth0 / WAN Miniport (IPv6)
[main] TRACE 14:21:00.623 Scanning network interface eth1 / WAN Miniport (Network Monitor)
[main] TRACE 14:21:00.639 Scanning network interface eth2 / WAN Miniport (IP)
[main] TRACE 14:21:00.651 Scanning network interface ppp1 / RAS Async Adapter
[main] TRACE 14:21:00.664 Scanning network interface eth3 / Realtek RTL8101E Family PCI-E Fast Ethernet NIC (NDIS 6.20)
[main] TRACE 14:21:00.677 Scanning network interface net4 / Bluetooth Device (RFCOMM Protocol TDI)
[main] TRACE 14:21:00.690 Scanning network interface eth4 / Bluetooth Device (Personal Area Network)
[main] TRACE 14:21:00.704 Scanning network interface net5 / Belkin Wireless G USB Network Adapter
[main] TRACE 14:21:00.718 Using address / found on network interface: name:net5 (Belkin Wireless G USB Network Adapter) index: 14 addresses: /;
[main] TRACE 14:21:00.718 Created socket: /
[Thread-4] TRACE 14:21:00.726 Starting DLNA Server on host and port 5001...
[main] TRACE 14:21:00.731 Sending ALIVE...
[main] TRACE 14:21:00.840 Unable to retrieve MAC address for UUID creation: using a random one...
[main] TRACE 14:21:00.877 Using following UUID: 68f4a089-dfd0-4b5d-9e4f-26ee9b809513
[Thread-4] TRACE 14:21:03.651 Receiving a request from:
[main] TRACE 14:21:05.414 It's ready! You should see the server appears on XMB
[Thread-13] TRACE 14:21:15.413 Sending ALIVE...
[Thread-13] TRACE 14:21:39.245 Sending ALIVE...
[Thread-323] TRACE 14:21:57.529 Starting transcode/remux of Death Note - 01 [Arigatou].mkv
[Thread-402] TRACE 14:24:05.242 Starting transcode/remux of Death Note - 01 [Arigatou].mkv
[Thread-13] TRACE 14:24:45.788 Sending ALIVE...
[win32/ffmpeg.exe] TRACE 14:25:24.373 Process C:\Program Files\PS3 Media Server\win32\ffmpeg.exe has a return code of -1073741676! Maybe an error occured... check the log file
[Thread-409] TRACE 14:25:24.596 Exception in thread "Thread-409" java.lang.ArrayIndexOutOfBoundsException
[Thread-409] TRACE 14:25:24.597    at java.lang.System.arraycopy(Native Method)
[Thread-409] TRACE 14:25:24.598    at
[Thread-409] TRACE 14:25:24.598    at$100(
[Thread-409] TRACE 14:25:24.601    at$
[Thread-409] TRACE 14:25:24.602    at
[Thread-409] TRACE 14:25:24.602    at
[Thread-409] TRACE 14:25:24.603    at
[Thread-409] TRACE 14:25:24.604    at Source)
[Thread-415] TRACE 14:25:30.344 Starting transcode/remux of Death Note - 01 [Arigatou].mkv
[win32/mencoder.exe] TRACE 14:26:33.206 Process C:\Program Files\PS3 Media Server\win32\mencoder.exe has a return code of 1! Maybe an error occured... check the log file
[Thread-423] TRACE 14:26:33.670 Exception in thread "Thread-423" java.lang.ArrayIndexOutOfBoundsException
[Thread-423] TRACE 14:26:33.671    at java.lang.System.arraycopy(Native Method)
[Thread-423] TRACE 14:26:33.672    at
[Thread-423] TRACE 14:26:33.673    at$100(
[Thread-423] TRACE 14:26:33.673    at$
[Thread-423] TRACE 14:26:33.674    at
[Thread-423] TRACE 14:26:33.674    at
[Thread-423] TRACE 14:26:33.675    at
[Thread-423] TRACE 14:26:33.675    at Source)
[Thread-13] TRACE 14:27:53.408 Sending ALIVE...

Also the AVS script from AviSynth...

Code: Select all
#AviSynth script is now fully customisable !
#You must use the following variables ("clip" being the avisynth variable of the movie):
#clip=DirectShowSource("D:\ANIME\Death Note\Death Note - 01 [Arigatou].mkv", convertfps=true): insert the complete DirectShowSource instruction [ clip=DirectShowSource(movie, convertfps) ]
##: insert the complete TextSub/VobSub instruction if there's any detected srt/sub/idx/ass subtitle file
#D:\ANIME\Death Note\Death Note - 01 [Arigatou].mkv: variable of the movie filename, if you want to do all this by yourself
#Be careful, the custom script MUST return the clip object
clip=DirectShowSource("D:\ANIME\Death Note\Death Note - 01 [Arigatou].mkv", convertfps=true)
return clip

The Debug.log is attached for reference... I really appreciate any help you can provide.
(32.87 KiB) Downloaded 56 times
Posts: 4
Joined: Fri Apr 24, 2009 5:36 am

Re: Can't get Avisynth / MEncoder working with MKV + Vobsubs

Postby Hanzo » Wed Jul 15, 2009 4:55 pm

No help?
Posts: 4
Joined: Fri Apr 24, 2009 5:36 am

Return to General Help and Support

Who is online

Users browsing this forum: Google [Bot], Yahoo [Bot] and 3 guests