How to ensure remux, Improper Seeking

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

How to ensure remux, Improper Seeking

Postby SmartWater » Mon Jul 06, 2009 6:20 am

I just stumbled upon ps3mediaserver and it works great for the most part. Thanks to devs!

I'm running i7 on a gigabit network, so I don't think there is any problem with my setup. My question is how do I make sure that the files are being simply remuxed and not transcoded? Is this done automatically? I have been using mkv2vob up until this point, and I do not want any degradation in quality whatsoever. I would rather the video take longer to load initially and then ran smoothly and was lossless.

When I load a simple .mkv with x264 and ac3, the seeking does not work anywhere near as well as when I use mkv2vob and the stock wmp dlna streaming. This led me to believe it was transcoding and not remuxing, but I prefer a lossless remux to transcoding.

Vista x64 i7 6GB Gigabit V1.10.51
Settings
Settings 2
SmartWater
 
Posts: 4
Joined: Mon Jul 06, 2009 6:08 am

Re: How to ensure remux, Improper Seeking

Postby shan1212 » Mon Jul 06, 2009 6:52 am

SmartWater wrote:I just stumbled upon ps3mediaserver and it works great for the most part. Thanks to devs!

I'm running i7 on a gigabit network, so I don't think there is any problem with my setup. My question is how do I make sure that the files are being simply remuxed and not transcoded? Is this done automatically? I have been using mkv2vob up until this point, and I do not want any degradation in quality whatsoever. I would rather the video take longer to load initially and then ran smoothly and was lossless.

When I load a simple .mkv with x264 and ac3, the seeking does not work anywhere near as well as when I use mkv2vob and the stock wmp dlna streaming. This led me to believe it was transcoding and not remuxing, but I prefer a lossless remux to transcoding.

Vista x64 i7 6GB Gigabit V1.10.51
Settings
Settings 2


how do u know if the connection between ur pc and ps3 is in fact gigabit?
shan1212
 
Posts: 12
Joined: Sun Jul 05, 2009 6:41 am

Re: How to ensure remux, Improper Seeking

Postby SmartWater » Mon Jul 06, 2009 6:57 am

Gigabit port on i7 desktop --> unmanaged gigabit hub --> PS3 using 1000BASE-T full duplex
SmartWater
 
Posts: 4
Joined: Mon Jul 06, 2009 6:08 am

Re: How to ensure remux, Improper Seeking

Postby shan1212 » Mon Jul 06, 2009 7:00 am

SmartWater wrote:Gigabit port on i7 desktop --> unmanaged gigabit hub --> PS3 using 1000BASE-T full duplex


thats the same for me, (except that i have a gigabit router instead of hub), but how do u really know the gigabit connection is working? have u ever gotten > 200Mbps ?
shan1212
 
Posts: 12
Joined: Sun Jul 05, 2009 6:41 am

Re: How to ensure remux, Improper Seeking

Postby meskibob » Mon Jul 06, 2009 1:09 pm

tsMuxer is used for remuxing, and MEncoder for full transcoding. You can check which is being used by looking at the bottom of the PMS status page in the status bar, or in the debug log. You can also look at the codecs listed by the PS3, as the video codec will stay as H264 for remuxing and MPEG2 for any full transcoding. If none of your files will ever need a full transcode, you can disable MEncoder and only leave tsMuxer active (use the little plug icon).

For the seeking, any form of transcoding (including remuxing) makes the FF/RW much less responsive when compared to a just-streamed file. However, using the PS3's Go To function (available from the playback Control Panel) is pretty quick for both streamed and transcoded files.
I provide NO application support via PM or email, so please post your question to the forum per the Forum Rules.
meskibob
Moderator
 
Posts: 4784
Joined: Mon Jan 19, 2009 4:11 pm

Re: How to ensure remux, Improper Seeking

Postby SmartWater » Mon Jul 06, 2009 4:48 pm

Thanks for your help meskibob, that's pretty much as I expected.

My only follow-up question is that you mentioned the ps3 would list the codec as x264 when being remuxed, but my ps3 lists mpeg-2 for all videos (even when I disable MEncoder and Avisynth) as well as all videos that I've already remuxed. It lists them as mpeg-2 under the file name when browsing the folders.
SmartWater
 
Posts: 4
Joined: Mon Jul 06, 2009 6:08 am

Re: How to ensure remux, Improper Seeking

Postby meskibob » Mon Jul 06, 2009 5:17 pm

What does MediaInfo say?
Also, did you save and restart PMS after disabling MEncoder and AviSynth?
I provide NO application support via PM or email, so please post your question to the forum per the Forum Rules.
meskibob
Moderator
 
Posts: 4784
Joined: Mon Jan 19, 2009 4:11 pm

Re: How to ensure remux, Improper Seeking

Postby SmartWater » Mon Jul 06, 2009 6:29 pm

MediaInfo says AVC. Yes, I saved and restarted PMS. It's weird that PS3 always displays the videos as MPEG-2 though
SmartWater
 
Posts: 4
Joined: Mon Jul 06, 2009 6:08 am

Re: How to ensure remux, Improper Seeking

Postby meskibob » Mon Jul 06, 2009 6:34 pm

And what about the codecs listed in the info bar (via Select) when the video is actually playing?
I provide NO application support via PM or email, so please post your question to the forum per the Forum Rules.
meskibob
Moderator
 
Posts: 4784
Joined: Mon Jan 19, 2009 4:11 pm


Return to General Help and Support

Who is online

Users browsing this forum: Bing [Bot], Yahoo [Bot] and 15 guests