Need help for streaming XVID

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Need help for streaming XVID

Postby Lelle » Sun May 03, 2009 12:16 am

Hello,

I've been using ps3 media server for a while to stream media to my ps3. I've mostly been streaming h264 content which has been working perfectly.
When recently trying to stream an .avi movie encoded as XVID, I get an error from the ps3 saying "The data type is not supported".

I'm using "MEncoder" as first priority for video and "MPlayer Audio" for audio.
My media server has a Q6600 and is connected to the ps3 through gbit-lan.
The media server version is 1.10.51.

Usually when selecting a file from the PS3, it says which encoder is being used, for example [MEncoder]. In this case, there is no such thing. Could this mean the video is being streamed "as is"?

I'm fairly sure I've localized the part of the debug.log which is relevant to this:

[Thread-144] DEBUG 01:06:37.310 Opened handler on socket Socket[addr=/192.168.1.198,port=55267,localport=5001]
[Thread-144] DEBUG 01:06:37.310 Received on socket: POST /upnp/control/content_directory HTTP/1.1
[Thread-144] DEBUG 01:06:37.310 Received on socket: X-AV-Client-Info: av=5.0; cn="Sony Computer Entertainment Inc."; mn="PLAYSTATION 3"; mv="1.0";
[Thread-144] DEBUG 01:06:37.326 Received on socket: Host: 192.168.1.3:5001
[Thread-144] DEBUG 01:06:37.326 Received on socket: User-Agent: UPnP/1.0 DLNADOC/1.50
[Thread-144] DEBUG 01:06:37.326 Received on socket: Content-Length: 276
[Thread-144] DEBUG 01:06:37.326 Received on socket: Content-Type: text/xml; charset="utf-8"
[Thread-144] DEBUG 01:06:37.326 Received on socket: SOAPACTION: "urn:schemas-upnp-org:service:ContentDirectory:1#GetSystemUpdateID"
[Thread-145] DEBUG 01:06:37.341 Opened handler on socket Socket[addr=/192.168.1.198,port=55266,localport=5001]
[Thread-145] DEBUG 01:06:37.341 Received on socket: GET /get/0$2$0$50/%5BRumbel%5D_Gintama_-_104_%5BXviD%5D%5B98659001%5D.avi HTTP/1.1
[Thread-145] DEBUG 01:06:37.341 Received on socket: Host: 192.168.1.3:5001
[Thread-145] DEBUG 01:06:37.341 Received on socket: User-Agent: PLAYSTATION 3
[Thread-145] DEBUG 01:06:37.357 Received on socket: Connection: Keep-Alive
[Thread-145] DEBUG 01:06:37.357 Received on socket: Accept-Encoding: identity
[Thread-145] DEBUG 01:06:37.357 Received on socket: transferMode.dlna.org: Streaming
[Thread-145] DEBUG 01:06:37.357 Received on socket: Range: bytes=0-
[Thread-145] INFO 01:06:37.357 HTTP: get/0$2$0$50/%5BRumbel%5D_Gintama_-_104_%5BXviD%5D%5B98659001%5D.avi / 0-100000000000
[Thread-145] DEBUG 01:06:37.357 Wrote on socket: HTTP/1.1 206 Partial Content
[Thread-145] DEBUG 01:06:37.357 Searching for objectId: 0$2$0$50 with children option: false
[Thread-145] DEBUG 01:06:37.357 Asked stream chunk [0-100000000000] timeseek: 0.0 of [Rumbel]_Gintama_-_104_[XviD][98659001].avi and player null
[Thread-145] DEBUG 01:06:37.357 Wrote on socket: Content-Type: video/x-divx
[Thread-145] DEBUG 01:06:37.357 Wrote on socket: CONTENT-RANGE: bytes 0-181649407/181649408
[Thread-145] DEBUG 01:06:37.357 Wrote on socket: Accept-Ranges: bytes
[Thread-145] DEBUG 01:06:37.357 Wrote on socket: Connection: keep-alive
[Thread-145] DEBUG 01:06:37.357 Wrote on socket: Server: Windows_Vista-x86-6.1, UPnP/1.0, PMS/1.10.51
[Thread-145] DEBUG 01:06:37.357 Wrote on socket: Content-Length: 181649408
[Thread-145] DEBUG 01:06:37.357 Wrote on socket:
[Thread-145] DEBUG 01:06:37.404 Sending stream with premature end : 1146880 bytes of get/0$2$0$50/%5BRumbel%5D_Gintama_-_104_%5BXviD%5D%5B98659001%5D.avi. Reason: An existing connection was forcibly closed by the remote host
[Thread-145] DEBUG 01:06:37.404 Sending stream: 1146880 bytes of get/0$2$0$50/%5BRumbel%5D_Gintama_-_104_%5BXviD%5D%5B98659001%5D.avi
[Thread-145] DEBUG 01:06:37.404 Close Connection
[Thread-146] DEBUG 01:06:37.404 Opened handler on socket Socket[addr=/192.168.1.198,port=55265,localport=5001]
[Thread-146] DEBUG 01:06:37.404 Received on socket: GET /get/0$2$0$50/%5BRumbel%5D_Gintama_-_104_%5BXviD%5D%5B98659001%5D.avi HTTP/1.1
[Thread-146] DEBUG 01:06:37.404 Received on socket: Host: 192.168.1.3:5001
[Thread-146] DEBUG 01:06:37.404 Received on socket: User-Agent: PLAYSTATION 3
[Thread-146] DEBUG 01:06:37.419 Received on socket: Connection: Keep-Alive
[Thread-146] DEBUG 01:06:37.419 Received on socket: Accept-Encoding: identity
[Thread-146] DEBUG 01:06:37.419 Received on socket: transferMode.dlna.org: Streaming
[Thread-146] DEBUG 01:06:37.419 Received on socket: Range: bytes=180486144-181649407
[Thread-146] INFO 01:06:37.419 HTTP: get/0$2$0$50/%5BRumbel%5D_Gintama_-_104_%5BXviD%5D%5B98659001%5D.avi / 180486144-181649407
[Thread-146] DEBUG 01:06:37.419 Wrote on socket: HTTP/1.1 206 Partial Content
[Thread-146] DEBUG 01:06:37.419 Searching for objectId: 0$2$0$50 with children option: false
[Thread-146] DEBUG 01:06:37.419 Asked stream chunk [180486144-181649407] timeseek: 0.0 of [Rumbel]_Gintama_-_104_[XviD][98659001].avi and player null
[Thread-146] DEBUG 01:06:37.419 Wrote on socket: Content-Type: video/x-divx
[Thread-146] DEBUG 01:06:37.419 Wrote on socket: CONTENT-RANGE: bytes 180486144-181649407/181649408
[Thread-146] DEBUG 01:06:37.419 Wrote on socket: Accept-Ranges: bytes
[Thread-146] DEBUG 01:06:37.419 Wrote on socket: Connection: keep-alive
[Thread-146] DEBUG 01:06:37.419 Wrote on socket: Server: Windows_Vista-x86-6.1, UPnP/1.0, PMS/1.10.51
[Thread-146] DEBUG 01:06:37.419 Wrote on socket: Content-Length: 1163264
[Thread-146] DEBUG 01:06:37.419 Wrote on socket:
[Thread-146] DEBUG 01:06:37.497 Sending stream: 1163264 bytes of get/0$2$0$50/%5BRumbel%5D_Gintama_-_104_%5BXviD%5D%5B98659001%5D.avi
[Thread-146] DEBUG 01:06:37.497 Close Connection
[Thread-144] INFO 01:06:37.528 HTTP: upnp/control/content_directory / 0-0
[Thread-144] DEBUG 01:06:37.528 Wrote on socket: HTTP/1.1 200 OK
[Thread-144] DEBUG 01:06:37.528 Wrote on socket: CONTENT-TYPE: text/xml; charset="utf-8"
[Thread-144] DEBUG 01:06:37.528 Wrote on socket: Server: Windows_Vista-x86-6.1, UPnP/1.0, PMS/1.10.51
[Thread-144] DEBUG 01:06:37.528 Wrote on socket: Content-Length: 335
[Thread-144] DEBUG 01:06:37.528 Wrote on socket:
[Thread-144] DEBUG 01:06:37.528 Close Connection
[Thread-147] DEBUG 01:06:37.528 Opened handler on socket Socket[addr=/192.168.1.198,port=55264,localport=5001]
[Thread-147] DEBUG 01:06:37.528 Received on socket: POST /upnp/control/content_directory HTTP/1.1
[Thread-147] DEBUG 01:06:37.528 Received on socket: X-AV-Client-Info: av=5.0; cn="Sony Computer Entertainment Inc."; mn="PLAYSTATION 3"; mv="1.0";
[Thread-147] DEBUG 01:06:37.528 Received on socket: Host: 192.168.1.3:5001
[Thread-147] DEBUG 01:06:37.528 Received on socket: User-Agent: UPnP/1.0 DLNADOC/1.50
[Thread-147] DEBUG 01:06:37.528 Received on socket: Content-Length: 905
[Thread-147] DEBUG 01:06:37.528 Received on socket: Content-Type: text/xml; charset="utf-8"
[Thread-147] DEBUG 01:06:37.528 Received on socket: SOAPACTION: "urn:schemas-upnp-org:service:ContentDirectory:1#Browse"
[Thread-147] INFO 01:06:37.747 HTTP: upnp/control/content_directory / 0-0
[Thread-147] DEBUG 01:06:37.747 Wrote on socket: HTTP/1.1 200 OK
[Thread-147] DEBUG 01:06:37.747 Wrote on socket: CONTENT-TYPE: text/xml; charset="utf-8"
[Thread-147] DEBUG 01:06:37.747 Searching for objectId: 0$2$0 with children option: false
[Thread-147] DEBUG 01:06:37.747 Search extension for maayan.zip
[Thread-147] DEBUG 01:06:37.747 Search extension for film.rar
[Thread-147] DEBUG 01:06:37.747 Wrote on socket: Server: Windows_Vista-x86-6.1, UPnP/1.0, PMS/1.10.51
[Thread-147] DEBUG 01:06:37.747 Wrote on socket: Content-Length: 851
[Thread-147] DEBUG 01:06:37.747 Wrote on socket:
[Thread-147] DEBUG 01:06:37.747 Close Connection


I'll be thankful for any help i may receive.

Best regards,
Lelle
Lelle
 
Posts: 2
Joined: Sun May 03, 2009 12:01 am

Re: Need help for streaming XVID

Postby Burrito » Sun May 03, 2009 10:40 pm

If there is no transcoding engine in brackets behind the filename (e.g. [MEncoder]), the file will indeed be streamed as it is.

It seems the file has some features that the PS3 doesn't like. The workaround in this case is to manually advance to the #Transcode# folder and select the file there (choose MEncoder).
Burrito
 
Posts: 39
Joined: Mon Jan 19, 2009 12:41 am

Re: Need help for streaming XVID

Postby Lelle » Mon May 04, 2009 6:25 pm

Thank you for your help!

I didn't even consider the option to look for such directories in the folder structure.
Lelle
 
Posts: 2
Joined: Sun May 03, 2009 12:01 am

Re: Need help for streaming XVID

Postby hjason7812 » Wed May 06, 2009 6:32 pm

i have all video files converted to avi xvid but when i check to see if they are on my ps3 they show up as divx instead of avi.
i just started using ps3ms yesterday switched from tversity because they screwed it all up with the latest update.

so i was wondering why does ps3ms do this for avi xvid files.
the difference i have from the op is that they play no problem but look all fuzzy because divx is lower in res.
so i think anyways i never liked divx.
hjason7812
 
Posts: 2
Joined: Wed May 06, 2009 6:22 pm


Return to General Help and Support

Who is online

Users browsing this forum: Google [Bot] and 12 guests